By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 1,686 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

Smartnavigation not working on windows 2003 server

P: n/a
I have turned on smartnavigation=True for some of the forms in my .NET
application. It seemed to be working fine on Windows 2000 SP4, which also has
VS 2003 installted, but when I moved the application to window 2003
production evnironment, the Smartnavigation stopped working.

Any ideas or suggestions would be appreciated.

Thanks,
Ashhad.
Mar 24 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Have you tried viewing the website from a Windows XP machine running IE?
Smart navigation uses Javascript and Windows 2003 Server has 'Enhanced
Internet Security' installed as default. This basically stops some scripting
running. One way around this is to reduce the security zone for trusted sites
to nothing and then add your website URL to the list of Trusted Sites by
Internet Explorer.

This should basically allow your web browser to run the javascript necessary
to automatically scroll down the page to where it was before postback.

I hope this helps.

Regards,

--
Kurt Farrar
..NET Developer & Computer Enthusiast

"Ashhad Syed" wrote:
I have turned on smartnavigation=True for some of the forms in my .NET
application. It seemed to be working fine on Windows 2000 SP4, which also has
VS 2003 installted, but when I moved the application to window 2003
production evnironment, the Smartnavigation stopped working.

Any ideas or suggestions would be appreciated.

Thanks,
Ashhad.

Mar 24 '06 #2

P: n/a
Kurt:

THanks for your response. In both cases I was viewing the website from the
same computer.

case 1: smartnavigation is working, application being hosted on windows 2000,
case 2: smartnavigation not working, application being hosted on windows 2003

Therefore I believe this has to do with the hosting environment, rather than
the viewing environment. If I am understanding your response correctly, you
were suggesting changing the security level of the viewing environment,
correct?

Thanks,
Ashhad.

"Kurt Farrar" wrote:
Have you tried viewing the website from a Windows XP machine running IE?
Smart navigation uses Javascript and Windows 2003 Server has 'Enhanced
Internet Security' installed as default. This basically stops some scripting
running. One way around this is to reduce the security zone for trusted sites
to nothing and then add your website URL to the list of Trusted Sites by
Internet Explorer.

This should basically allow your web browser to run the javascript necessary
to automatically scroll down the page to where it was before postback.

I hope this helps.

Regards,

--
Kurt Farrar
.NET Developer & Computer Enthusiast

"Ashhad Syed" wrote:
I have turned on smartnavigation=True for some of the forms in my .NET
application. It seemed to be working fine on Windows 2000 SP4, which also has
VS 2003 installted, but when I moved the application to window 2003
production evnironment, the Smartnavigation stopped working.

Any ideas or suggestions would be appreciated.

Thanks,
Ashhad.

Mar 24 '06 #3

P: n/a
Yes, you're right. I misunderstood what you meant. I thought you meant that
you'd moved the host and was trying to view the application using the host.

That sounds unusual since the smart navigation stuff is javascript that is
written into the page that is loaded in the client browser. I assume there is
absolutely no difference between the deployed website on both of the hosts
(ie. same build for same version of the .net framework) and that the
configuration in IIS (ie. same website name, same virtual directory etc.) is
all the same on both hosts?

Have you checked the HTTP Headers are the same for both hosts? I'm wondering
if maybe one of the servers is returning something in the headers that is
screwing up the javascript that comes back to the page.

--
Kurt Farrar
..NET Developer & Computer Enthusiast

"Ashhad Syed" wrote:
Kurt:

THanks for your response. In both cases I was viewing the website from the
same computer.

case 1: smartnavigation is working, application being hosted on windows 2000,
case 2: smartnavigation not working, application being hosted on windows 2003

Therefore I believe this has to do with the hosting environment, rather than
the viewing environment. If I am understanding your response correctly, you
were suggesting changing the security level of the viewing environment,
correct?

Thanks,
Ashhad.

"Kurt Farrar" wrote:
Have you tried viewing the website from a Windows XP machine running IE?
Smart navigation uses Javascript and Windows 2003 Server has 'Enhanced
Internet Security' installed as default. This basically stops some scripting
running. One way around this is to reduce the security zone for trusted sites
to nothing and then add your website URL to the list of Trusted Sites by
Internet Explorer.

This should basically allow your web browser to run the javascript necessary
to automatically scroll down the page to where it was before postback.

I hope this helps.

Regards,

--
Kurt Farrar
.NET Developer & Computer Enthusiast

"Ashhad Syed" wrote:
I have turned on smartnavigation=True for some of the forms in my .NET
application. It seemed to be working fine on Windows 2000 SP4, which also has
VS 2003 installted, but when I moved the application to window 2003
production evnironment, the Smartnavigation stopped working.

Any ideas or suggestions would be appreciated.

Thanks,
Ashhad.

Mar 24 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.