By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,039 Members | 1,831 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,039 IT Pros & Developers. It's quick & easy.

error C2144 and C4430 when compiling anything in VC++ 2005

P: n/a
In VC++ from Visual Studio 2005 the following occurs: If I try to compile
anyting, even a newly created empty MFC application with 1 empty dialog, I
get the following 2 errors:

Compiling...
stdafx.cpp
c:\program files\microsoft visual studio 8\vc\include\excpt.h(33) : error
C2144: syntax error : 'int' should be preceded by ';'
c:\program files\microsoft visual studio 8\vc\include\excpt.h(33) : error
C4430: missing type specifier - int assumed. Note: C++ does not support
default-int

The same project(s) compile fine at another workstation with Visual Studio
2005 installed. Does anyone know what is going on and how this can be fixed ?
Mar 15 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
> In VC++ from Visual Studio 2005 the following occurs: If I try to compile
anyting, even a newly created empty MFC application with 1 empty dialog, I
get the following 2 errors:

Compiling...
stdafx.cpp
c:\program files\microsoft visual studio 8\vc\include\excpt.h(33) : error
C2144: syntax error : 'int' should be preceded by ';'
c:\program files\microsoft visual studio 8\vc\include\excpt.h(33) : error
C4430: missing type specifier - int assumed. Note: C++ does not support
default-int

The same project(s) compile fine at another workstation with Visual Studio
2005 installed. Does anyone know what is going on and how this can be
fixed ?


Try to do a repair of your VS2005 install.
Some time ago someone else had a similar problem and it turned out that some
header files were
modified.

If the same project compiles without a problem on another pc then the
environment is the problem.
in that case a repair or reinstall should fix the problem.

--

Kind regards,
Bruno.
br**********************@hotmail.com
Remove only "_nos_pam"
Mar 15 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.