By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,745 Members | 1,957 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,745 IT Pros & Developers. It's quick & easy.

Cannot Request a Java Webservice

P: n/a
hi,

i have a java webservice which i would like to invoke from .net Application.

i am able to generate the proxy class, but if i try to invoke the webservice
i got an exception of type "java.lang.Nullpointer". if i run the webservice
in the debugmode i got an exception:

Message="Tried to invoke method public byte[]
mii.StandardObjects.DocumentSecurity.WebSignature. SignDocument(byte[],java.lang.String,java.lang.String,java.lang.Strin g,java.lang.String,java.lang.String,java.lang.Stri ng,boolean,java.lang.String)
throws java.lang.Exception with arguments
[B,null,null,null,null,null,null,null,null. The arguments do not match the
signature.; nested exception is: \n\tjava.lang.IllegalArgumentException"

the function behind the webservice:

JAVA:
public byte[] SignDocument(byte[] document, String sCredential, String PWD,
String reason, String Location,
String contactInfo,String SigPermissions, boolean LockSignatureField,
String legalAttest) throws Exception

..NET Client invokes the webservice in this way:
sbyte[]
signedDocument=myService.SignDocument(sbDocument," InvoiceAdmin","password","reason","loc","contin"," NO_CHANGES",true,"aa");

i can post the wsdl if it is neccessary.

please help


Mar 15 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.