By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,558 Members | 1,373 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,558 IT Pros & Developers. It's quick & easy.

Slow painting

P: n/a
I'm working (along with my coworkers) on a fairly large and complex
application. Something very strange started happening about a week ago and
I've been unable to figure out why (to my knowledge nothing changed on my
machine at this time). These problems are only appearing when the project is
executed on my machine and happens in both debug and release modes, in the
IDE and outside of the IDE. The other developers are having no issues
whatsoever. Also, this problem only happens to me in a particular project.

The first, and most significant, symptom is that everything within the
application (winforms) is repainting very, very slowly. For example,
changing the text of two subitems on a listview item causes a visible paint
as repainting occurs for each subitem and altogether takes about 3/4 second.
The other thing we've noticed is that when I compile XML files are being
created for each of the DLL assemblies in the solution.

If you've seen this before and know how to resolve it please let me know.

Thanks
Mar 14 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I forgot to mention that we're using Visual Studio 2003, in case that matters.

"Jeff Beem" wrote:
I'm working (along with my coworkers) on a fairly large and complex
application. Something very strange started happening about a week ago and
I've been unable to figure out why (to my knowledge nothing changed on my
machine at this time). These problems are only appearing when the project is
executed on my machine and happens in both debug and release modes, in the
IDE and outside of the IDE. The other developers are having no issues
whatsoever. Also, this problem only happens to me in a particular project.

The first, and most significant, symptom is that everything within the
application (winforms) is repainting very, very slowly. For example,
changing the text of two subitems on a listview item causes a visible paint
as repainting occurs for each subitem and altogether takes about 3/4 second.
The other thing we've noticed is that when I compile XML files are being
created for each of the DLL assemblies in the solution.

If you've seen this before and know how to resolve it please let me know.

Thanks

Mar 14 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.