By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,270 Members | 1,582 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,270 IT Pros & Developers. It's quick & easy.

404 error accessing my webservice PLEASE HELP

P: n/a
hi
I can access and play with my webservice without any problems in my
localhost. I am using .net 2.0
but I can not access it when I placed it in my win2003 server. also have
..net 2.0 there.

on IIS I set the permissions to browse the virtual directory. So, I can
browse the directory content and I can see that my asmx file is there but
when I click on it I get "The page you are looking for might have been
removed, had its name changed, or is temporarily unavailable" 404 error.

I added the add name=httpget and add name=httppost to the web.config
already. Still get the error.

I changed the permissions for the virtual directory. I gave permissions to
IUSR_xxx, local service, network service and aspnet user but still I can not
open my webservice.

what could I be missing here? anyone knows any tool to help me debug this?

TIA
Feb 6 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
This is an IIS issue.

Does the virtual directory path end in a \ for your application or any
parent virtual directories?

For instance. If your root folder in iis (http://localhost/) is mapped
to "E:\" then you will have this problem. Basically, you can't map to
anything ending in \.

This is easy to fix if it's a folder "C:\MyApp\" should be changed to
"C:\MyApp". It's not so easy if it's the root of a drive.

Apparently this is because of a security vulnerability.

Let me know if that helps.

Josh
http://www.thejoyofcode.com/

Feb 6 '06 #2

P: n/a
That's 100% IIS issue I would say.
Adding to the suggestions you have received, also take a look at the web
services extensions (in your IIS 6.0 tree)
Verify if asp.net 2.0 is allowed, if not you should add it to the list of
allowed extensions.

HTH
-Edge
"xisco" <xi***@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP10.phx.gbl...
hi
I can access and play with my webservice without any problems in my
localhost. I am using .net 2.0
but I can not access it when I placed it in my win2003 server. also have
.net 2.0 there.

on IIS I set the permissions to browse the virtual directory. So, I can
browse the directory content and I can see that my asmx file is there but
when I click on it I get "The page you are looking for might have been
removed, had its name changed, or is temporarily unavailable" 404 error.

I added the add name=httpget and add name=httppost to the web.config
already. Still get the error.

I changed the permissions for the virtual directory. I gave permissions to
IUSR_xxx, local service, network service and aspnet user but still I can
not open my webservice.

what could I be missing here? anyone knows any tool to help me debug this?

TIA

Feb 6 '06 #3

P: n/a
Yes. It was the extension that was not enabled.
Thanks a lot you guys :)
"xisco" <xi***@hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP10.phx.gbl...
hi
I can access and play with my webservice without any problems in my
localhost. I am using .net 2.0
but I can not access it when I placed it in my win2003 server. also have
.net 2.0 there.

on IIS I set the permissions to browse the virtual directory. So, I can
browse the directory content and I can see that my asmx file is there but
when I click on it I get "The page you are looking for might have been
removed, had its name changed, or is temporarily unavailable" 404 error.

I added the add name=httpget and add name=httppost to the web.config
already. Still get the error.

I changed the permissions for the virtual directory. I gave permissions to
IUSR_xxx, local service, network service and aspnet user but still I can
not open my webservice.

what could I be missing here? anyone knows any tool to help me debug this?

TIA

Feb 7 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.