By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,288 Members | 1,175 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,288 IT Pros & Developers. It's quick & easy.

unable to start debugging on the web server

P: n/a
I have an ASP.NET application "Modeler" that I adapted from ibuyspy. I worked
fine under ASP.NET 1.1 & Visual Studio 2003. I recently installed ASP.NET 2.0
& Visual Studio 2005 Pro. After reconfirming "Modeler" still worked, I ran
the converter. Post conversion, I cleaned up a few build-time errors, but now
I cannot start the debugger. After the build messages -

------ Build started: Project: http://localhost/modeler/, Configuration:
Debug .NET ------
Validating Web Site
Building directory '/modeler/admin/'.
Building directory '/modeler/'.
Building directory '/modeler/DesktopModules/'.
Building directory '/modeler/Components/'.
Building directory '/modeler/scraps/'.
Building directory '/modeler/SourceViewer/'.

Validation Complete
========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========

A Microsoft Visual Studio dialog pops up stating "Unable to start debugging
on the web server. The web server is not configured correctly. ..."

My configuration worked an hour earlier under ASP.NET 1.1. Any ideas?

Other things I tried -
I loaded the start .aspx page into IE 6.0 and saw an error
"Failed to access IIS metabase"
I tried the usual stuff (1) aspnet_regiis.exe -u and then aspnet_regiis.exe
-i (2) Reinstalling VS 2005 Pro. If I now invoke aspnet_regiis.exe /lv it
returns
1.0.3705.6018
Valid C:\WINNT\Microsoft.NET\Framework\v1.0.3705\aspnet_ isapi.dll
1.1.4322.0 Valid C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll
2.0.50727.0 Valid
(Root) C:\WINNT\Microsoft.NET\Framework\v2.0.50727\aspnet _isapi.dll
None of that helped!

My environment is WinXP Pro SP2, VS 2005 Pro.

What to try next?
Jan 26 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.