By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,490 Members | 1,270 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,490 IT Pros & Developers. It's quick & easy.

Urgent!! Big Problem opening solution file in visual studio

P: n/a
Hi all,

We are facing this big problem.
Scenario is as follows.

We have one single solution (say EIS) under which there are 25 projects. All
the files are saved at a central location under Visual Sorce Safe on a
seprate machine. For a new person who is trying to setup this solution file
on his / her local machine follows the following step.
1. "Set working folder" for the EIS folder from VSS on to his local machine
(by defualt D:\EIS)
2. Do a "get latest version" of all the files from VSS on to his local
machine.
3. After all the files are copied on to local machine, EIS.solution file is
opened in to Visual Studio environment by double clicking it.
4. For first time it ask for the server mapping for the projects under the
solution file. On click of OK it creates virtual directory for EIS under IIS
and further directories for projects under EIS (under IIS).

Now problem is after it has added all the folders under IIS, visual studio
hangs indefinately... and we are forced to do end task of the same.

Again opeing EIS solution file, tries to create further directories under
IIS and does not refer to the already created directories.

We are not even able to locate the source the problem.

Someone kindly help on this.

Thanks & Regards
Paras Sharma
Jan 13 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
"Paras Sharma" <pa**********@persistent.co.in> wrote in message
news:%2***************@TK2MSFTNGP12.phx.gbl...
We are facing this big problem.


You could try disregarding the solution file. In VS, open one of the
*project* files instead of the solution file. VS will create a new solution
for you. Then, manually add the remaining projects to the new solution
(Add/Existing Project...), and save the new solution. This has worked for
me in the past.

-- Alan
Jan 13 '06 #2

P: n/a
Can you try creating Virtual Directories first and then open a solution in VS.
--
Harish Shikhare

"Paras Sharma" wrote:
Hi all,

We are facing this big problem.
Scenario is as follows.

We have one single solution (say EIS) under which there are 25 projects. All
the files are saved at a central location under Visual Sorce Safe on a
seprate machine. For a new person who is trying to setup this solution file
on his / her local machine follows the following step.
1. "Set working folder" for the EIS folder from VSS on to his local machine
(by defualt D:\EIS)
2. Do a "get latest version" of all the files from VSS on to his local
machine.
3. After all the files are copied on to local machine, EIS.solution file is
opened in to Visual Studio environment by double clicking it.
4. For first time it ask for the server mapping for the projects under the
solution file. On click of OK it creates virtual directory for EIS under IIS
and further directories for projects under EIS (under IIS).

Now problem is after it has added all the folders under IIS, visual studio
hangs indefinately... and we are forced to do end task of the same.

Again opeing EIS solution file, tries to create further directories under
IIS and does not refer to the already created directories.

We are not even able to locate the source the problem.

Someone kindly help on this.

Thanks & Regards
Paras Sharma

Feb 1 '06 #3

P: n/a
Paras,

We had the same issue with a project that included an ASP project that
created a virtual directory. You may want to review the issue we had
and see how we resolved it:

http://forums.microsoft.com/MSDN/Sho...33905&SiteID=1

Please let me know if you need further help with this and I will try to
review it a little further. There is a link on that page for
instructions for checking out what exactly is causing the problem too.

Mark Dahl

Feb 2 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.