By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,544 Members | 2,002 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,544 IT Pros & Developers. It's quick & easy.

Service to macth WSDL document

P: n/a
Hi,

I've been building a webservice in dotnet to match a provided WSDL document
to allow interoperability with a third party developer's system. As a start
point I used the wsdl.exe command line tool to build an abstract service
class based on the document and alterred it for use in the actual service.

Having finished the service I've tried pointing the third party's system at
it. The system gives an error message indicating a HTTP 405 error. I know
this usually means that some needed HTTP methods aren't allowed in IIS but
all verbs are allowed for both asmx and wsdl extensions for the service
itself and the local computer.

Communication is being done through HTTPS (I can't alter this since it's
inbuilt into the third party's system) making my attempts at spotting a
problem by intercepting the messages sent pretty useless :-(

The WSDL document they've given me is generated by GLUE and I've tried using
a copy of it (properly adjusted for the local machine) and the wsdl document
generated through IIS.

Put simply can anyone think of a reason for the 405 error?

Also is it even possible/practical to match up a dotnet webservice to a WSDL
document produced by a non-IIS server?

Any help at this point would be much appreciated...
Jan 5 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.