467,146 Members | 1,229 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,146 developers. It's quick & easy.

How to change address location

How do I change the address location in the wsdl

<wsdl:port name="SearchSoap12" binding="tns:SearchSoap12">
<soap12:address location="http://searchservices/engine/search.asmx" />
</wsdl:port>
Anderas
Jan 5 '06 #1
  • viewed: 5865
Share:
4 Replies
Continued:

When I look at the WSDL (http://searchservices/engine/search.asmx?WSDL )I
find that the address:location is wrong.
How can I manipulate address:location?
Andreas
Jan 5 '06 #2
Hi Andreas,

Welcome to MSDN newsgroup.
As for the ASP.NET webservice(asmx) 's autogenerated wsdl document's
service address, it is always pointed to the asmx file's http url address.
So what's the difference between it and your expected address? Also, for
webservice WSDL document, it is mainly used for describe service contract
(method interface and message format....) rather than service's actual port
address... So we don't quite need to change it , and after the clientside
create proxy class to consume the webservce, client code can flexiblely
change the actual service's endpoint address......

Also, based on my research, we can customize our ASMX file's displaying
page by using our own page so that we can point user to our own WSDL
document (create a custom xml file that contains the WSDL document).

#<wsdlHelpGenerator> Element
http://msdn.microsoft.com/library/en...lhelpgenerator
.asp?frame=true

#Configuration Options for XML Web Services Created Using ASP.NET
http://msdn.microsoft.com/library/en...igurationOptio
nsForASPNETWebServices.asp?frame=true

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
From: "andreas.w.h.k. :-\)" <aw**@newsgroup.nospam>
References: <#0**************@tk2msftngp13.phx.gbl>
Subject: Continued: How to change address location
Date: Thu, 5 Jan 2006 12:28:54 +0100
Lines: 10
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
X-RFC2646: Format=Flowed; Response
Message-ID: <OM*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: www.kf.no 195.18.146.10
Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msft ngp13.phx.gbl
Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.webservices:1325 1
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

Continued:

When I look at the WSDL (http://searchservices/engine/search.asmx?WSDL )I
find that the address:location is wrong.
How can I manipulate address:location?
Andreas

Jan 6 '06 #3
Thank you very much for your reply, Steven!

My problem is that the address:location (in the WSDL) differs from the url
in which I use when I surf to my webservice. When I try to Invoke my method
(via the webform) the result pops up in a new window with the url of the
address:location. And that is the wrong url. That is not the URL which I use
when I surfed to my webservice.

Could it be an DNS issue? Because the address in the address:location is
only accessable from the intranet. And the address I use to access the
webservice is a public address accessable from the internet. Two DNS
pointing at the same service.

Andreas :-)
"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:VW**************@TK2MSFTNGXA02.phx.gbl...
Hi Andreas,

Welcome to MSDN newsgroup.
As for the ASP.NET webservice(asmx) 's autogenerated wsdl document's
service address, it is always pointed to the asmx file's http url address.
So what's the difference between it and your expected address? Also, for
webservice WSDL document, it is mainly used for describe service contract
(method interface and message format....) rather than service's actual
port
address... So we don't quite need to change it , and after the clientside
create proxy class to consume the webservce, client code can flexiblely
change the actual service's endpoint address......

Also, based on my research, we can customize our ASMX file's displaying
page by using our own page so that we can point user to our own WSDL
document (create a custom xml file that contains the WSDL document).

#<wsdlHelpGenerator> Element
http://msdn.microsoft.com/library/en...lhelpgenerator
asp?frame=true

#Configuration Options for XML Web Services Created Using ASP.NET
http://msdn.microsoft.com/library/en...igurationOptio
nsForASPNETWebServices.asp?frame=true

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
From: "andreas.w.h.k. :-\)" <aw**@newsgroup.nospam>
References: <#0**************@tk2msftngp13.phx.gbl>
Subject: Continued: How to change address location
Date: Thu, 5 Jan 2006 12:28:54 +0100
Lines: 10
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
X-RFC2646: Format=Flowed; Response
Message-ID: <OM*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: www.kf.no 195.18.146.10
Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msft ngp13.phx.gbl
Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.webservices:1325 1
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

Continued:

When I look at the WSDL (http://searchservices/engine/search.asmx?WSDL )I
find that the address:location is wrong.
How can I manipulate address:location?
Andreas

Jan 6 '06 #4
Thanks for your response Andreas,

Yes, I think this is a DNS or webserver(IIS)'s IP address related problem
because when creating the asp.net webservice, the address location we view
in the generated asmx file in browser is identical to the address of the
IIS website's ip address(or mapped dns name....). You can test this with a
web page application also (view some webpages in the server from
browser...). And vs 2005 has no idea of whether the iis site or local
machine has a public IP to external internet or not.....

Also, based on my local test, the expected behavior should be, the address
location in the asmx WSDL document should be the same with the address we
typed in browser... e.g:

when I navigate to the asmx view through

http://localhost/WebServices/MyWebSe...ice1.asmx?WSDL

then, the WSDL's service endpoint shows
<wsdl:port name="Service1HttpPost" binding="tns:Service1HttpPost">
<http:address
location="http://localhost/WebServices/MyWebService/Service1.asmx" />
</wsdl:port>
</wsdl:service>

while if I navigate it through public servername:

http://servername/WebServices/MyWebS...ice1.asmx?WSDL

the wsdl document's endpoint address should be:

<wsdl:port name="Service1HttpPost" binding="tns:Service1HttpPost">
<http:address
location="http://servername/WebServices/MyWebService/Service1.asmx" />
</wsdl:port>
</wsdl:service>
Anyway, the clientside proxy can flexibly change the address to the new
value or updated value since they may create the proxy from a local copy of
the WSDL document rather than through the asmx address...

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
From: "andreas.w.h.k. :-\)" <aw**@newsgroup.nospam>
References: <#0**************@tk2msftngp13.phx.gbl>
<OM*************@tk2msftngp13.phx.gbl>
<VW**************@TK2MSFTNGXA02.phx.gbl>
Subject: Re: Continued: How to change address location
Date: Fri, 6 Jan 2006 09:42:27 +0100
Lines: 89
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
X-RFC2646: Format=Flowed; Original
Message-ID: <#3**************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: www.kf.no 195.18.146.10
Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msft ngp13.phx.gbl
microsoft.public.dotnet.framework.webservices:1326 2
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

Thank you very much for your reply, Steven!

My problem is that the address:location (in the WSDL) differs from the url
in which I use when I surf to my webservice. When I try to Invoke my method
(via the webform) the result pops up in a new window with the url of the
address:location. And that is the wrong url. That is not the URL which I
use
when I surfed to my webservice.

Could it be an DNS issue? Because the address in the address:location is
only accessable from the intranet. And the address I use to access the
webservice is a public address accessable from the internet. Two DNS
pointing at the same service.

Andreas :-)
"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:VW**************@TK2MSFTNGXA02.phx.gbl...
Hi Andreas,

Welcome to MSDN newsgroup.
As for the ASP.NET webservice(asmx) 's autogenerated wsdl document's
service address, it is always pointed to the asmx file's http url address.
So what's the difference between it and your expected address? Also, for
webservice WSDL document, it is mainly used for describe service contract
(method interface and message format....) rather than service's actual
port
address... So we don't quite need to change it , and after the clientside
create proxy class to consume the webservce, client code can flexiblely
change the actual service's endpoint address......

Also, based on my research, we can customize our ASMX file's displaying
page by using our own page so that we can point user to our own WSDL
document (create a custom xml file that contains the WSDL document).

#<wsdlHelpGenerator> Element
http://msdn.microsoft.com/library/en...lhelpgenerator asp?frame=true

#Configuration Options for XML Web Services Created Using ASP.NET
http://msdn.microsoft.com/library/en...igurationOptio nsForASPNETWebServices.asp?frame=true

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
From: "andreas.w.h.k. :-\)" <aw**@newsgroup.nospam>
References: <#0**************@tk2msftngp13.phx.gbl>
Subject: Continued: How to change address location
Date: Thu, 5 Jan 2006 12:28:54 +0100
Lines: 10
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2670
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.2670
X-RFC2646: Format=Flowed; Response
Message-ID: <OM*************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: www.kf.no 195.18.146.10
Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msft ngp13.phx.gbl
Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.webservices:1325 1
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

Continued:

When I look at the WSDL (http://searchservices/engine/search.asmx?WSDL )I
find that the address:location is wrong.
How can I manipulate address:location?
Andreas


Jan 9 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Richard Cornford | last post: by
reply views Thread by S | last post: by
4 posts views Thread by toton | last post: by
6 posts views Thread by Narasimha Rao | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.