By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,652 Members | 1,182 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,652 IT Pros & Developers. It's quick & easy.

The default IIS invoke method page doesn't call SoapExtentions

P: n/a
Hi,

I have a web service with two soap extensions enabled on it.

When I run the default IIS method invoke page, the invoke button bypasses
all my soap extensions. But when I call the web method through another
proxy, it works fine.

Why this is happening?

Any help would be appreciated,

Alan
Nov 23 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hi Alan,

As for the ASP.NET Webservice, it support multiple protocols(transport
protocols) and message format to access it, include HTTP Get, HTTP POST,
HTTP SOAP...., and the default test invoke page generated by asp.net is
using HTTP Get , which doesn't use standard SOAP message( use a simple
http get message), so the ASP.NET webservice handler won't attache
soapExtensions for such format webservice call. If you want to test
soapExtensions, we need to always send SOAP format webservice call to the
service, and the simplest way is to use the .net generated webservice
client proxy to call the webservice.

In addition, we can configure whether our ASP.NET web application support
certain protocol through the
<configuration>
<system.web>
<webServices>
<protocols>
......
setting, for example the following configuration means we support all
these protocol accessing.
===============
<configuration>
<system.web>
<webServices>
<protocols>
<add name="HttpSoap"/>
<add name="HttpPost"/>
<add name="HttpGet"/>
<add name="Documentation"/>
</protocols>
</webServices>
<system.web>
</configuration>
================

You can find the default configuration in the machine.config file.

thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
From: "A.M-SG" <al******@newsgroup.nospam>
Subject: The default IIS invoke method page doesn't call SoapExtentions
Date: Wed, 28 Sep 2005 08:22:01 -0400
Lines: 23
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
Message-ID: <u4**************@TK2MSFTNGP14.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: hse-toronto-ppp137724.sympatico.ca 64.228.95.207
Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP14.phx.gbl
microsoft.public.dotnet.framework.webservices:8045
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

Hi,

I have a web service with two soap extensions enabled on it.

When I run the default IIS method invoke page, the invoke button bypasses
all my soap extensions. But when I call the web method through another
proxy, it works fine.

Why this is happening?

Any help would be appreciated,

Alan

Nov 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.