By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,333 Members | 1,843 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,333 IT Pros & Developers. It's quick & easy.

maxRequestLength not effective for increasing Upload size limitation

P: n/a
I'm developing a Web Service using DIME to download and upload files from
and to an IIS server. In order to increase the download filesize to
unlimited, I have the following block in my App.config and Web.config files:

<messaging>
<maxRequestLength>-1</maxRequestLength>
</messaging>

The largest file I've downloaded is 70 meg and that's more than plenty for
me. However, I'm finding that on upload, if I attempt to upload greater than
4 meg, I get an error:

An unhandled exception of type 'System.Web.Services.Protocols.SoapException'
occurred in system.web.services.dll
Additional information: There was an exception running the extensions
specified in the config file. --> Maximum request length exceeded.

This error occurs inside the client proxy on the this.invoke statements;

this.Invoke("PutFile", new object[] {
FileSpec,
Checkin,
AuthentiKey1});

My Web Service method is never even called.

How can I increase the upload size?

Thanks for your help!

- Joe Geretz -
Nov 23 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
It looks like you're running into the ASP.NET limits. Setting the
<httpRuntime> element should take care of it.

For example, ten minutes and 400 mb it should look like this:
<httpRuntime executionTimeout="600" maxRequestLength="409600"/>

I have more details here:
http://spaces.msn.com/members/nra314159/Blog/cns!1pYM-YN5bjuKTPUnvGkZ1b_Q!165.entry

Thanks.

"Joseph Geretz" <jg*****@nospam.com> wrote in message
news:u8**************@tk2msftngp13.phx.gbl...
I'm developing a Web Service using DIME to download and upload files from
and to an IIS server. In order to increase the download filesize to
unlimited, I have the following block in my App.config and Web.config files:
<messaging>
<maxRequestLength>-1</maxRequestLength>
</messaging>

The largest file I've downloaded is 70 meg and that's more than plenty for
me. However, I'm finding that on upload, if I attempt to upload greater than 4 meg, I get an error:

An unhandled exception of type 'System.Web.Services.Protocols.SoapException' occurred in system.web.services.dll
Additional information: There was an exception running the extensions
specified in the config file. --> Maximum request length exceeded.

This error occurs inside the client proxy on the this.invoke statements;

this.Invoke("PutFile", new object[] {
FileSpec,
Checkin,
AuthentiKey1});

My Web Service method is never even called.

How can I increase the upload size?

Thanks for your help!

- Joe Geretz -

Nov 23 '05 #2

P: n/a
Thanks Nate,

Yes, you are correct. Setting the httpRuntime maxRequestLength allows me to
increase the upload size past the 4 meg default. However, I am finding that
I cannot exceed 64 meg on upload. I've been discussion this issue on the
Microsoft forum at:

http://forums.microsoft.com/msdn/Sho...x?PostID=92989

The original post deals with the 4 meg limitation, but towards the middle of
the thread MiceaT jumps in reporting an absolute 64 meg limitation. I have
confirmed this limitation myself, so we are both observing the same
behavior.

If you could take a look at this thread and make a recommendation for us,
that would be most appreciated!

Thanks!

- Joe Geretz -

"Nathan Anderson [MSFT]" <na*********************@microsoft.com> wrote in
message news:43********@news.microsoft.com...
It looks like you're running into the ASP.NET limits. Setting the
<httpRuntime> element should take care of it.

For example, ten minutes and 400 mb it should look like this:
<httpRuntime executionTimeout="600" maxRequestLength="409600"/>

I have more details here:
http://spaces.msn.com/members/nra314159/Blog/cns!1pYM-YN5bjuKTPUnvGkZ1b_Q!165.entry

Thanks.

"Joseph Geretz" <jg*****@nospam.com> wrote in message
news:u8**************@tk2msftngp13.phx.gbl...
I'm developing a Web Service using DIME to download and upload files from
and to an IIS server. In order to increase the download filesize to
unlimited, I have the following block in my App.config and Web.config

files:

<messaging>
<maxRequestLength>-1</maxRequestLength>
</messaging>

The largest file I've downloaded is 70 meg and that's more than plenty
for
me. However, I'm finding that on upload, if I attempt to upload greater

than
4 meg, I get an error:

An unhandled exception of type

'System.Web.Services.Protocols.SoapException'
occurred in system.web.services.dll
Additional information: There was an exception running the extensions
specified in the config file. --> Maximum request length exceeded.

This error occurs inside the client proxy on the this.invoke statements;

this.Invoke("PutFile", new object[] {
FileSpec,
Checkin,
AuthentiKey1});

My Web Service method is never even called.

How can I increase the upload size?

Thanks for your help!

- Joe Geretz -


Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.