By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,918 Members | 2,248 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,918 IT Pros & Developers. It's quick & easy.

Basic question: Can't add Web Reference to a client project on the same solution as the web services server

P: n/a
Hi all,

My problem is basic. I'm starting to try web services with Visual
Studio .NET 2002, .NET Framework 1.0. I'm testing the following
configuration for my project. It's a ASP.NET Web Service project in the
role of server. It's another project, a Windows Form project to act as
the web services client. Both projects are joined in the same solution.
I hope this will be the best arrangement to develop in parallel both
the server and the client.
So I create my first Web Service on the server. When I tryed to
register this web reference within the client Windows Form to get the
proxy automatically created, I can't.
The first try was the following: The web service project is not
running. The help says I should open Project/Add Web Reference in the
menu, but the form that appears only allows me to connect to a running
service. The help says it should have an option to open a web reference
to a project located on your PC but it is missing.
The second try was to run the Web Service project, and try to add the
web reference to the client. It doesn't work also. When the Web Service
is running, the menu Project/Add Web Reference is disabled, even right
clicking over the client project on the Solution Explorer...
My last try was to use the WSDL utility to generate the proxy class. It
worked, but the generated file did not compile under the client
project.
What I'm doing erong?
Which is the recommended arrangement for developing in parallel a web
service and a client? Join them on the same solution, or in separate
solution?
Any hint is welcomed
Thanks in advance
Sammy

Nov 23 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.