By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,028 Members | 1,945 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,028 IT Pros & Developers. It's quick & easy.

Pocket Application accessing a Webservice on a STANDALONE desktop

P: n/a
Hi, everyone.

That's my environment:
- I have a pocket pc (iPAQ h4350) application developed with
VSNET2003/C# that has a SQL Server CE Database, running. That's working
fine. Obs: the pocket is NOT supposed to have a wireless conection
available.
- I have an access database on a standalone desktop running Windows XP,
i.e., there is NO guaranteed network connection available.
- I've developed a webservice with VSNET2003/C# too to do some data
synchronizing. That's a bunch of webmethods that receive a table name and
returns a dataset to pocket, OR receive a dataset and insert its records
into the corresponding table at the access database. They are running at my
desktop over an IIS 5.0 server, with .Net Framework 1.1 already installed.

Well, here's the problem: ok, when I have a internet connection
available on my desktop, the activesync (3.7.1 OR 3.8, whatever) enables the
pass through feature when the device is placed in the cradle, and from my
application or even from the pocket Internet Explorer i CAN reach my
webservice, or any other page/web application that my IIS provides. But, if
there is no network connection available on the desktop, activesync
teorically just does not provides the pass through, EVEN IF the "address"
requested is the desktop host's name. Or localhost, or 127.0.0.1, or
anyother name I can even define, e.g., at hosts or lmhosts file
(system32\drivers\etc\).

Am I nuts? Or there is a way to make this work?
I just wanted the damn pocket, or the activesync, to be able to resolve
a local address for the pocket when he is connected to my desktop, which IS
in fact acting as a web server.

If that's an enforced rule of activesync - it WILL NOT receive and "pass
through" the request from pocket, even if that's a local address on a
desktop's web server -, is that right?? It should enable pass through
anyway, I think!! After all, I of course am able to open an Internet
Explorer instance on my desktop, and call my webservice normally. And works
when I'm still testing on my PPC emulator.

Please! Need some light here!

Thanks in advance.
Daniel.

--
Fudiotes, desencatum.
Vita brevis.
Nov 23 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi
this is only applied in PPC Emulator. But if you can't found problem, try
connection with loopback adaptor.
Configuring a loopback adapter under Windows 2000
Like any network adapter, installing a loopback adapter is only half of the
process. You also need to configure your new adapter. Perform the following
steps to configure the loopback adapter:

1.. On the Start menu, click Settings, point to Network and Dial-up
Connections, and then click Local Area Connection. The Local Area Connection
Status dialog displays.
2.. Click Properties. The Local Area Connection Properties window
displays.
Note Check to make sure that you are working with the right connection.
The Connection Using field of this dialog should read "Microsoft Loopback
Adapter".
3.. Select Internet Protocol (TCP/IP), and then click Properties. The
Internet Protocol window displays.
4.. Configure the IP address properties.
5.. Click OK to close the Internet Protocol window.
6.. Click OK to close the Local Area Connection Properties window.
7.. Click Close to close the Local Area Connection Status window.
http://www.codeproject.com/netcf/net..._Desktop_Setup
----------------------------
GuyV

"Daniel Liberman" <daniel@no_sp_am.bestway.com.br> wrote in message
news:uH*************@tk2msftngp13.phx.gbl...
Hi, everyone.

That's my environment:
- I have a pocket pc (iPAQ h4350) application developed with
VSNET2003/C# that has a SQL Server CE Database, running. That's working
fine. Obs: the pocket is NOT supposed to have a wireless conection
available.
- I have an access database on a standalone desktop running Windows XP, i.e., there is NO guaranteed network connection available.
- I've developed a webservice with VSNET2003/C# too to do some data
synchronizing. That's a bunch of webmethods that receive a table name and
returns a dataset to pocket, OR receive a dataset and insert its records
into the corresponding table at the access database. They are running at my desktop over an IIS 5.0 server, with .Net Framework 1.1 already installed.

Well, here's the problem: ok, when I have a internet connection
available on my desktop, the activesync (3.7.1 OR 3.8, whatever) enables the pass through feature when the device is placed in the cradle, and from my
application or even from the pocket Internet Explorer i CAN reach my
webservice, or any other page/web application that my IIS provides. But, if there is no network connection available on the desktop, activesync
teorically just does not provides the pass through, EVEN IF the "address"
requested is the desktop host's name. Or localhost, or 127.0.0.1, or
anyother name I can even define, e.g., at hosts or lmhosts file
(system32\drivers\etc\).

Am I nuts? Or there is a way to make this work?
I just wanted the damn pocket, or the activesync, to be able to resolve a local address for the pocket when he is connected to my desktop, which IS in fact acting as a web server.

If that's an enforced rule of activesync - it WILL NOT receive and "pass through" the request from pocket, even if that's a local address on a
desktop's web server -, is that right?? It should enable pass through
anyway, I think!! After all, I of course am able to open an Internet
Explorer instance on my desktop, and call my webservice normally. And works when I'm still testing on my PPC emulator.

Please! Need some light here!

Thanks in advance.
Daniel.

--
Fudiotes, desencatum.
Vita brevis.

Nov 23 '05 #2

P: n/a
I am not sure I understand the question, but be aware of that the localhost,
127.0.0.1, might be different from the PocketPC's point of view. I think it
is safer to use the 'name' of the host instead. Or use the command
ipconfig/all to figure out the ip-address of the PC host.

"guyv" wrote:
Hi
this is only applied in PPC Emulator. But if you can't found problem, try
connection with loopback adaptor.
Configuring a loopback adapter under Windows 2000
Like any network adapter, installing a loopback adapter is only half of the
process. You also need to configure your new adapter. Perform the following
steps to configure the loopback adapter:

1.. On the Start menu, click Settings, point to Network and Dial-up
Connections, and then click Local Area Connection. The Local Area Connection
Status dialog displays.
2.. Click Properties. The Local Area Connection Properties window
displays.
Note Check to make sure that you are working with the right connection.
The Connection Using field of this dialog should read "Microsoft Loopback
Adapter".
3.. Select Internet Protocol (TCP/IP), and then click Properties. The
Internet Protocol window displays.
4.. Configure the IP address properties.
5.. Click OK to close the Internet Protocol window.
6.. Click OK to close the Local Area Connection Properties window.
7.. Click Close to close the Local Area Connection Status window.
http://www.codeproject.com/netcf/net..._Desktop_Setup
----------------------------
GuyV

"Daniel Liberman" <daniel@no_sp_am.bestway.com.br> wrote in message
news:uH*************@tk2msftngp13.phx.gbl...
Hi, everyone.

That's my environment:
- I have a pocket pc (iPAQ h4350) application developed with
VSNET2003/C# that has a SQL Server CE Database, running. That's working
fine. Obs: the pocket is NOT supposed to have a wireless conection
available.
- I have an access database on a standalone desktop running Windows

XP,
i.e., there is NO guaranteed network connection available.
- I've developed a webservice with VSNET2003/C# too to do some data
synchronizing. That's a bunch of webmethods that receive a table name and
returns a dataset to pocket, OR receive a dataset and insert its records
into the corresponding table at the access database. They are running at

my
desktop over an IIS 5.0 server, with .Net Framework 1.1 already installed.

Well, here's the problem: ok, when I have a internet connection
available on my desktop, the activesync (3.7.1 OR 3.8, whatever) enables

the
pass through feature when the device is placed in the cradle, and from my
application or even from the pocket Internet Explorer i CAN reach my
webservice, or any other page/web application that my IIS provides. But,

if
there is no network connection available on the desktop, activesync
teorically just does not provides the pass through, EVEN IF the "address"
requested is the desktop host's name. Or localhost, or 127.0.0.1, or
anyother name I can even define, e.g., at hosts or lmhosts file
(system32\drivers\etc\).

Am I nuts? Or there is a way to make this work?
I just wanted the damn pocket, or the activesync, to be able to

resolve
a local address for the pocket when he is connected to my desktop, which

IS
in fact acting as a web server.

If that's an enforced rule of activesync - it WILL NOT receive and

"pass
through" the request from pocket, even if that's a local address on a
desktop's web server -, is that right?? It should enable pass through
anyway, I think!! After all, I of course am able to open an Internet
Explorer instance on my desktop, and call my webservice normally. And

works
when I'm still testing on my PPC emulator.

Please! Need some light here!

Thanks in advance.
Daniel.

--
Fudiotes, desencatum.
Vita brevis.


Nov 23 '05 #3

P: n/a
I am not sure I understand the question, but be aware of that the localhost,
127.0.0.1, might be different from the PocketPC's point of view. I think it
is safer to use the 'name' of the host instead. Or use the command
ipconfig/all to figure out the ip-address of the PC host.

"guyv" wrote:
Hi
this is only applied in PPC Emulator. But if you can't found problem, try
connection with loopback adaptor.
Configuring a loopback adapter under Windows 2000
Like any network adapter, installing a loopback adapter is only half of the
process. You also need to configure your new adapter. Perform the following
steps to configure the loopback adapter:

1.. On the Start menu, click Settings, point to Network and Dial-up
Connections, and then click Local Area Connection. The Local Area Connection
Status dialog displays.
2.. Click Properties. The Local Area Connection Properties window
displays.
Note Check to make sure that you are working with the right connection.
The Connection Using field of this dialog should read "Microsoft Loopback
Adapter".
3.. Select Internet Protocol (TCP/IP), and then click Properties. The
Internet Protocol window displays.
4.. Configure the IP address properties.
5.. Click OK to close the Internet Protocol window.
6.. Click OK to close the Local Area Connection Properties window.
7.. Click Close to close the Local Area Connection Status window.
http://www.codeproject.com/netcf/net..._Desktop_Setup
----------------------------
GuyV

"Daniel Liberman" <daniel@no_sp_am.bestway.com.br> wrote in message
news:uH*************@tk2msftngp13.phx.gbl...
Hi, everyone.

That's my environment:
- I have a pocket pc (iPAQ h4350) application developed with
VSNET2003/C# that has a SQL Server CE Database, running. That's working
fine. Obs: the pocket is NOT supposed to have a wireless conection
available.
- I have an access database on a standalone desktop running Windows

XP,
i.e., there is NO guaranteed network connection available.
- I've developed a webservice with VSNET2003/C# too to do some data
synchronizing. That's a bunch of webmethods that receive a table name and
returns a dataset to pocket, OR receive a dataset and insert its records
into the corresponding table at the access database. They are running at

my
desktop over an IIS 5.0 server, with .Net Framework 1.1 already installed.

Well, here's the problem: ok, when I have a internet connection
available on my desktop, the activesync (3.7.1 OR 3.8, whatever) enables

the
pass through feature when the device is placed in the cradle, and from my
application or even from the pocket Internet Explorer i CAN reach my
webservice, or any other page/web application that my IIS provides. But,

if
there is no network connection available on the desktop, activesync
teorically just does not provides the pass through, EVEN IF the "address"
requested is the desktop host's name. Or localhost, or 127.0.0.1, or
anyother name I can even define, e.g., at hosts or lmhosts file
(system32\drivers\etc\).

Am I nuts? Or there is a way to make this work?
I just wanted the damn pocket, or the activesync, to be able to

resolve
a local address for the pocket when he is connected to my desktop, which

IS
in fact acting as a web server.

If that's an enforced rule of activesync - it WILL NOT receive and

"pass
through" the request from pocket, even if that's a local address on a
desktop's web server -, is that right?? It should enable pass through
anyway, I think!! After all, I of course am able to open an Internet
Explorer instance on my desktop, and call my webservice normally. And

works
when I'm still testing on my PPC emulator.

Please! Need some light here!

Thanks in advance.
Daniel.

--
Fudiotes, desencatum.
Vita brevis.


Nov 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.