468,272 Members | 1,999 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,272 developers. It's quick & easy.

Difficulties Consuming Java Web Services in .NET


I am consuming Java Web Services in .NET. The Java Web Services have
been coded using Apache Axis.

The binding style in the WSDL is 'Document' and type is 'Literal'.

I have added these Java Web Services both as Web Reference and Reference
(ie dll generated using wsdl.exe) in the Project in order to access
them. I am able to get the output for web methods that return just a
string. However when it comes to complex data like an object / array ,
it returns me an object with empty attribute values.

I have tried posting the XML Content to the Web Services using XML Spy
and it seems to work fine suggesting that there does not seem to be any
problem with the Web Service.

What could be the problem? Do we need to modify the .NET proxy that
Visual Studio.NET IDE generates when output is an object or whatever is
generated by default should work?

I have tried the same consuming a .NEt service and it works fine.

Hoping to hear from you soon.
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 23 '05 #1
0 1181

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by David Young | last post: by
4 posts views Thread by bob garbados | last post: by
1 post views Thread by Samudrala | last post: by
1 post views Thread by leslie_tighe | last post: by
3 posts views Thread by Jeremy Chapman | last post: by
4 posts views Thread by Scott M. | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.