By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,890 Members | 1,286 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,890 IT Pros & Developers. It's quick & easy.

Headless Industrial Automation/Gateway in WinCE 5.0

P: n/a
I have been having trouble trying to create a sample headless
application in Platform Builder 5.0. Eventually, this must have TCP/IP,
WebServer, and probably DHCP for a local net. I tried using the PB5.0
sample configuration for a Gateway, but could not get my desktop PC to
talk to it. I am trying to use the Emulator as the platform. I also
tried creating a Custom device and adding catalog items, but could not
get that to work.

After much web searching, I read the article "Yes, Virginia, Windows CE
..NET Does Handle Headless Systems"; however, this article expects PB4.1
and I have PB5.0, where the "Industrial Automation Controller"
configuration is no longer available.

Does anyone have any experience getting a Gateway-style HEADLESS device
to work within the Emulator, such that the development desktop PC
(running PB5.0) can talk to the Gateway's web interface via Internet
Explorer?

Maybe I'm just missing some of the TCP/IP or Emulator registry setup,
or have the wrong adapter specified, or... who knows? I have read many
help pages from PB5.0, but they often say to do something, but do not
say how to do it nor what is expected (i.e. for settings).
Please help!! Thanks much!!

Nov 23 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I assume in the "Target Device Connectivity Option" dialog, you have
selected Emulator for the Download list box.
Press the 'Settings" button and in the "Communication" group box, make sure
to select "Virtual Switch" in the Ethernet Support box.

Bill.

"dvstormuser" <cw******@outsitenetworks.com> wrote in message
news:11**********************@c13g2000cwb.googlegr oups.com...
I have been having trouble trying to create a sample headless
application in Platform Builder 5.0. Eventually, this must have TCP/IP,
WebServer, and probably DHCP for a local net. I tried using the PB5.0
sample configuration for a Gateway, but could not get my desktop PC to
talk to it. I am trying to use the Emulator as the platform. I also
tried creating a Custom device and adding catalog items, but could not
get that to work.

After much web searching, I read the article "Yes, Virginia, Windows CE
.NET Does Handle Headless Systems"; however, this article expects PB4.1
and I have PB5.0, where the "Industrial Automation Controller"
configuration is no longer available.

Does anyone have any experience getting a Gateway-style HEADLESS device
to work within the Emulator, such that the development desktop PC
(running PB5.0) can talk to the Gateway's web interface via Internet
Explorer?

Maybe I'm just missing some of the TCP/IP or Emulator registry setup,
or have the wrong adapter specified, or... who knows? I have read many
help pages from PB5.0, but they often say to do something, but do not
say how to do it nor what is expected (i.e. for settings).
Please help!! Thanks much!!

Nov 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.