By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,870 Members | 1,189 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,870 IT Pros & Developers. It's quick & easy.

404 problems for simple web service in 2003 but not in 2000

P: n/a
Hi,

a) I have a windows 2003 server on my machine with in built .NET
Framework 1.1.

b) I have also installed .NET Framework 1.0 on this machine.

c) I have a web service, when i try to invoke the methods of it, it
returns "404 not found error".

4) I have disabled the IE option "show friendly messages" then it
returns " The system can not find the file specified".

5) To debug I have created one console application and referred this
web service in it, while trying to debug at the point where it calls
web service method it says "An unhandled exception of type
'System.Net.WebException' occurred in system.web.services.dll
Additional information: The request failed with HTTP status 404: Not
Found."

In trying to resolve this...I have done following things...but
unfortunately of no avail.

a) because I have two version of .NET and I specifially want to use one
which is .NET 1.0, because tthe existing application is in 1.0. I have
changes in my web.config file of web service so I added following lines
in my web.config file but that also did not help.

<startup>
<requiredRuntime imageVersion="v1.0.3705" version="v1.0.3705" />
<supportedRuntime version="v1.0.3705" />
<supportedRuntime version="v1.0.4322" />
</startup>

I also reversed this order to use 1.1 but no difference

b) Also I have found on net that by default HTTP GET and HTTP POST are
disabled in .NET Framework 1.1 so I added following lines in web.config
file.

<protocols>
<add name="HttpGet"/>
<add name="HttpPost"/>
</protocols>
c) Also I have fould that we can provide filter which Framework we have
to use in ISAPI Filter under IIS manager, so I have provided a ISAPI
Filer for aspnet_filter.dll of the version I want to use which is 1.0.

d) Last but not the least I found the info. that by default web service
extenstions are disabled in windows server 2003..so I have

following steps mentioned here...both of my asp.net versions
http://support.microsoft.com/?id=315122

"HTTP Error 404 - File or Directory not found" error message when you
request dynamic content with IIS 6.0
but I still see the same problem...

The same hello world service works in 2000 perfectly..but not in
2003...Please help...any pointers will be appreciated
Thanks In advance,
Varsha

Nov 23 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Hello Varsha,

Can you browse to you web service directory in IE?

HTH
Regards,
Dilip Krishnan
MCAD, MCSD.net
dkrishnan at geniant dot com
http://www.geniant.com
Hi,

a) I have a windows 2003 server on my machine with in built .NET
Framework 1.1.

b) I have also installed .NET Framework 1.0 on this machine.

c) I have a web service, when i try to invoke the methods of it, it
returns "404 not found error".

4) I have disabled the IE option "show friendly messages" then it
returns " The system can not find the file specified".

5) To debug I have created one console application and referred this
web service in it, while trying to debug at the point where it calls
web service method it says "An unhandled exception of type
'System.Net.WebException' occurred in system.web.services.dll
Additional information: The request failed with HTTP status 404: Not
Found."

In trying to resolve this...I have done following things...but
unfortunately of no avail.

a) because I have two version of .NET and I specifially want to use
one which is .NET 1.0, because tthe existing application is in 1.0. I
have changes in my web.config file of web service so I added following
lines in my web.config file but that also did not help.

<startup>
<requiredRuntime imageVersion="v1.0.3705" version="v1.0.3705" />
<supportedRuntime version="v1.0.3705" />
<supportedRuntime version="v1.0.4322" />
</startup>
I also reversed this order to use 1.1 but no difference

b) Also I have found on net that by default HTTP GET and HTTP POST are
disabled in .NET Framework 1.1 so I added following lines in
web.config file.

<protocols>
<add name="HttpGet"/>
<add name="HttpPost"/>
</protocols>
c) Also I have fould that we can provide filter which Framework we
have to use in ISAPI Filter under IIS manager, so I have provided a
ISAPI Filer for aspnet_filter.dll of the version I want to use which
is 1.0.

d) Last but not the least I found the info. that by default web
service extenstions are disabled in windows server 2003..so I have

following steps mentioned here...both of my asp.net versions
http://support.microsoft.com/?id=315122

"HTTP Error 404 - File or Directory not found" error message when you
request dynamic content with IIS 6.0

but I still see the same problem...

The same hello world service works in 2000 perfectly..but not in
2003...Please help...any pointers will be appreciated
Thanks In advance,
Varsha

Nov 23 '05 #2

P: n/a
Hello,

Can you please look in the IIS log file and tell us what the substatus
code of the request is.

Is it none, 2 or 3?

None: The file is simply not there, are you using the correct path? Could
also be URLScan* blocking it (if installed)

2: The request of the file is denied due to lockdown policy

3: Denied due to MIME not allowed (this should not be true in your case).

* I'm not completely sure what status code URLScan would give you, i
*think* it is none (0).

--
Regards,
Kristofer Gafvert
www.ilopia.com

Varsha wrote:
Hi,

a) I have a windows 2003 server on my machine with in built .NET
Framework 1.1.

b) I have also installed .NET Framework 1.0 on this machine.

c) I have a web service, when i try to invoke the methods of it, it
returns "404 not found error".

4) I have disabled the IE option "show friendly messages" then it
returns " The system can not find the file specified".

5) To debug I have created one console application and referred this
web service in it, while trying to debug at the point where it calls
web service method it says "An unhandled exception of type
'System.Net.WebException' occurred in system.web.services.dll
Additional information: The request failed with HTTP status 404: Not
Found."

In trying to resolve this...I have done following things...but
unfortunately of no avail.

a) because I have two version of .NET and I specifially want to use one
which is .NET 1.0, because tthe existing application is in 1.0. I have
changes in my web.config file of web service so I added following lines
in my web.config file but that also did not help.

<startup>
<requiredRuntime imageVersion="v1.0.3705" version="v1.0.3705" />
<supportedRuntime version="v1.0.3705" />
<supportedRuntime version="v1.0.4322" />
</startup>

I also reversed this order to use 1.1 but no difference

b) Also I have found on net that by default HTTP GET and HTTP POST are
disabled in .NET Framework 1.1 so I added following lines in web.config
file.

<protocols>
<add name="HttpGet"/>
<add name="HttpPost"/>
</protocols>
c) Also I have fould that we can provide filter which Framework we have
to use in ISAPI Filter under IIS manager, so I have provided a ISAPI
Filer for aspnet_filter.dll of the version I want to use which is 1.0.

d) Last but not the least I found the info. that by default web service
extenstions are disabled in windows server 2003..so I have

following steps mentioned here...both of my asp.net versions
http://support.microsoft.com/?id=315122

"HTTP Error 404 - File or Directory not found" error message when you
request dynamic content with IIS 6.0
but I still see the same problem...

The same hello world service works in 2000 perfectly..but not in
2003...Please help...any pointers will be appreciated
Thanks In advance,
Varsha

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.