By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,916 Members | 1,286 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,916 IT Pros & Developers. It's quick & easy.

Server Busy dialog when calling web service function

P: n/a
I have a proxy class derived from
System.Web.Services.Protocols.SoapHTTPClient that calls a web service.
Sometimes, because the call takes a longer time, I get the OLE server busy
dialog. Is there any way to control/customize the display of this dialog?

Michael S. Scherotter
Business Solutions Architect
Mindjet LLC
Nov 23 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Michael,

The ole server busy dialog is normally only showed when you're on an UI
and/or STA thread and not pumping messages. So, you'd better make sure you
give the framework the opportunity to pump messages. There's 2 ways to do
that:

1) start a background thread on which you do you web service interaction.
This is the way to go if your cient does a lot of web service calls that you
want to tie together (in other words, your client spends most of its cycles
waiting for network io)
2) use the BeginXXX / EndXXX async pattern of your proxy. You can use the
returned IAsyncResult to either poll for completion or wait for completion,
or you can pass in an AsyncCallback delegate that will be invoked when the
call completes.

Please note that the thread started in option 1 will keep your app alive,
while option 2 will run on a threadpool thread (which does not keep your app
alive).

HTH,

-- Henkk
"Michael S. Scherotter" wrote:
I have a proxy class derived from
System.Web.Services.Protocols.SoapHTTPClient that calls a web service.
Sometimes, because the call takes a longer time, I get the OLE server busy
dialog. Is there any way to control/customize the display of this dialog?

Michael S. Scherotter
Business Solutions Architect
Mindjet LLC

Nov 23 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.