468,107 Members | 1,337 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,107 developers. It's quick & easy.

https and vs 1.1

I have a web service Im using on a machine via http in a dmz that works file.
Im now attempting to use it in a second server, this one using https.
When I attempt to add the Web Reference in vs.net 1.1, I get the following
message:
*****************************************
There was an error downloading 'https://<dns
name>/ScheduledJobs.asmx?op=GetMetrics'.

The underlying connection was closed: Unable to connect to the remote server.

The underlying connection was closed: The proxy name could not be resolved,
verify correct proxy configuration.
*****************************************
The proxy name appears to be resolving, as in the left hand panel the "test"
..asmx page is displaying with the exposed method (GetMetrics), and I dont
tell it the name of the method, just the name of the .asmx.

Any ideas on how to make this work?

Thanks, Mark
Nov 23 '05 #1
2 2717
Hi,

When making secured connections, is the request being made from a client
(logged in) application? Or from another service on another machine. If
it is being made from your DMZ service to your back-end service, then you
need to get a server certificate and specify this certificate be used when
you establish the connection. The reason is server based requests don't
have a user context to pick up an automatic negotiated cert for.

It looks as if the server is rejecting the connect request. This is
usually due to there either being no certificate, or a cert that it doesn't
recognize.

I hope this helps

Dan Rogers
Microsoft Corporation
--------------------
Thread-Topic: https and vs 1.1
thread-index: AcTchZ+V5W2MnnCEQsSenkdxg4AlHA==
X-WBNR-Posting-Host: 12.156.88.116
From: =?Utf-8?B?TWFya0F1cml0?= <Ma*******@discussions.microsoft.com>
Subject: https and vs 1.1
Date: Tue, 7 Dec 2004 09:53:13 -0800
Lines: 20
Message-ID: <5F**********************************@microsoft.co m>
MIME-Version: 1.0
Content-Type: text/plain;
charset="Utf-8"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
Content-Class: urn:content-classes:message
Importance: normal
Priority: normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
Path:
cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFT NGXA01.phx.gbl!TK2MSFTNGXA
03.phx.gbl
Xref: cpmsftngxa10.phx.gbl
microsoft.public.dotnet.framework.webservices:7954
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

I have a web service Im using on a machine via http in a dmz that works
file.
Im now attempting to use it in a second server, this one using https.
When I attempt to add the Web Reference in vs.net 1.1, I get the following
message:
*****************************************
There was an error downloading 'https://<dns
name>/ScheduledJobs.asmx?op=GetMetrics'.

The underlying connection was closed: Unable to connect to the remote
server.

The underlying connection was closed: The proxy name could not be resolved,
verify correct proxy configuration.
*****************************************
The proxy name appears to be resolving, as in the left hand panel the
"test"
.asmx page is displaying with the exposed method (GetMetrics), and I dont
tell it the name of the method, just the name of the .asmx.

Any ideas on how to make this work?

Thanks, Mark

Nov 23 '05 #2
In other words just go the address in ie and accept the certificate and install
it. It should solve yr problem
HTH
Regards,
Dilip Krishnan
MCAD, MCSD.net
dkrishnan at geniant dot com
www.geniant.com
Hi,

When making secured connections, is the request being made from a
client (logged in) application? Or from another service on another
machine. If it is being made from your DMZ service to your back-end
service, then you need to get a server certificate and specify this
certificate be used when you establish the connection. The reason is
server based requests don't have a user context to pick up an
automatic negotiated cert for.

It looks as if the server is rejecting the connect request. This is
usually due to there either being no certificate, or a cert that it
doesn't recognize.

I hope this helps

Dan Rogers
Microsoft Corporation
--------------------
Thread-Topic: https and vs 1.1
thread-index: AcTchZ+V5W2MnnCEQsSenkdxg4AlHA==
X-WBNR-Posting-Host: 12.156.88.116
From: =?Utf-8?B?TWFya0F1cml0?= <Ma*******@discussions.microsoft.com>
Subject: https and vs 1.1
Date: Tue, 7 Dec 2004 09:53:13 -0800
Lines: 20
Message-ID: <5F**********************************@microsoft.co m>
MIME-Version: 1.0
Content-Type: text/plain;
charset="Utf-8"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
Content-Class: urn:content-classes:message
Importance: normal
Priority: normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
Path:
cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFT NGXA01.phx.gbl!TK2MS
FTNGXA
03.phx.gbl
Xref: cpmsftngxa10.phx.gbl
microsoft.public.dotnet.framework.webservices:7954
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices
I have a web service Im using on a machine via http in a dmz that
works
file.
Im now attempting to use it in a second server, this one using https.
When I attempt to add the Web Reference in vs.net 1.1, I get the
following
message:
*****************************************
There was an error downloading 'https://<dns name>> /ScheduledJobs.asmx?op=GetMetrics'.
name>> The underlying connection was closed: Unable to connect to the remote
server.

The underlying connection was closed: The proxy name could not be
resolved,
verify correct proxy configuration.
*****************************************
The proxy name appears to be resolving, as in the left hand panel the
"test"
.asmx page is displaying with the exposed method (GetMetrics), and I
dont
tell it the name of the method, just the name of the .asmx.
Any ideas on how to make this work?

Thanks, Mark

{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl {\f0\fnil\fprq2\fcha
rset0 MS Sans Serif;}}

\viewkind4\uc1\pard\f0\fs20 Hi,

\par

\par When making secured connections, is the request being made from a
client (logged in) application? Or from another service on another
machine. If it is being made from your DMZ service to your back-end
service, then you need to get a server certificate and specify this
certificate be used when you establish the connection. The reason is
server based requests don't have a user context to pick up an
automatic negotiated cert for.

\par

\par It looks as if the server is rejecting the connect request. This
is usually due to there either being no certificate, or a cert that it
doesn't recognize.

\par

\par I hope this helps

\par

\par Dan Rogers

\par Microsoft Corporation

\par \pard\li720 --------------------

\par Thread-Topic: https and vs 1.1

\par thread-index: AcTchZ+V5W2MnnCEQsSenkdxg4AlHA==

\par X-WBNR-Posting-Host: 12.156.88.116

\par From: =?Utf-8?B?TWFya0F1cml0?=
<Ma*******@discussions.microsoft.com>

\par Subject: https and vs 1.1

\par Date: Tue, 7 Dec 2004 09:53:13 -0800

\par Lines: 20

\par Message-ID: <5F**********************************@microsoft.co m>

\par MIME-Version: 1.0

\par Content-Type: text/plain;

\par \tab charset="Utf-8"

\par Content-Transfer-Encoding: 7bit

\par X-Newsreader: Microsoft CDO for Windows 2000

\par Content-Class: urn:content-classes:message

\par Importance: normal

\par Priority: normal

\par X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0

\par Newsgroups: microsoft.public.dotnet.framework.webservices

\par NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29

\par Path:
cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFT NGXA01.phx.gbl!TK2MS
FTNGXA03.phx.gbl

\par Xref: cpmsftngxa10.phx.gbl
microsoft.public.dotnet.framework.webservices:7954

\par X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

\par

\par I have a web service Im using on a machine via http in a dmz that
works file.

\par Im now attempting to use it in a second server, this one using
https.

\par When I attempt to add the Web Reference in vs.net 1.1, I get the
following

\par message:

\par *****************************************

\par There was an error downloading 'https://<dns

\par name>/ScheduledJobs.asmx?op=GetMetrics'.

\par

\par The underlying connection was closed: Unable to connect to the
remote server.

\par

\par The underlying connection was closed: The proxy name could not be
resolved,

\par verify correct proxy configuration.

\par *****************************************

\par The proxy name appears to be resolving, as in the left hand panel
the "test"

\par .asmx page is displaying with the exposed method (GetMetrics),
and I dont

\par tell it the name of the method, just the name of the .asmx.

\par

\par Any ideas on how to make this work?

\par

\par Thanks, Mark

\par \pard

\par

\par }

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by kiran | last post: by
2 posts views Thread by Craig Keightley | last post: by
16 posts views Thread by Paul Sweeney | last post: by
12 posts views Thread by Grunff | last post: by
14 posts views Thread by Peter Chant | last post: by
14 posts views Thread by david | last post: by
2 posts views Thread by scott mcfadden | last post: by
reply views Thread by NoaGross | last post: by
1 post views Thread by Solo | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.