By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,994 Members | 1,570 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,994 IT Pros & Developers. It's quick & easy.

Enterprise library problem, configuration block

P: n/a
Hi!

I try to use the configuration application block from the Enterprise Library
and have done prework as specified from one of the hands-on labs from that
package. When trying to get configuration settings using the
ConfigurationManager.GetConfiguration my application, which is a windows
service, stops with the following error message (parts of it) written to the
event log.

"Service cannot be started. System.IO.FileNotFoundException: File or
assembly name psee3aqf.dll, or one of its dependencies, was not found.
File name: "psee3aqf.dll"
at System.Reflection.Assembly.nLoad(AssemblyName fileName, String
codeBase, Boolean isStringized, Evidence assemblySecurity, Boolean
throwOnFileNotFound, Assembly locationHint, StackCrawlMark& stackMark)
at System.Reflection.Assembly.InternalLoad(AssemblyNa me assemblyRef,
Boolean stringized, Evidence assemblySecurity, StackCrawlMark& stackMark)
at System.Reflection.Assembly.Load(AssemblyName assemblyRef, Evidence
assemblySecurity)
at System.CodeDom.Compiler.CompilerResults.get_Compil edAssembly()
at System.CodeDom.Compiler.CompilerResults.get_Compil edAssembly()
at System.Xml.Serialization.Compiler.Compile()
at System.Xml.Serialization.TempAssembly..ctor(XmlMap ping[] xmlMappings)
at System.Xml.Serialization.XmlSerializer..ctor(Type type, String
defaultNamespace)
at System.Xml.Serialization.XmlSerializer..ctor(Type type)
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationSettingsLoader.CreateXmlSerializer( Type[] types)
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationSettingsLoader.Build(XmlNode node)
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationSettingsLoader.Build(String configurationFile)
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationFile.GetConfig(String configKey)
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationBuilder.ReadMetaConfiguration()
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationBuilder.LoadMetaConfiguration(Strin g configurationFile)
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationBuilder..ctor()
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationManager..ctor()
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationManager.get_Current()
at
Microsoft.Practices.EnterpriseLibrary.Configuratio n.ConfigurationManager.GetConfiguration(String sectionName)
at TmeCollectorService.TmeCollectorService.OnStart(St ring[] args)
at System.ServiceProcess.ServiceBase.ServiceQueuedMai nCallback(Object
state)

=== Pre-bind state information ===
LOG: Where-ref bind. Location = C:\WINDOWS\Temp\psee3aqf.dll
LOG: Appbase = c:\services\tmecollectorservice\
LOG: Initial PrivatePath = NULL
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private, custom,
partial, or location-based assembly bind).
LOG: Attempting download of new URL file:///C:/WINDOWS/Temp/psee3aqf.dll."

Now the name psee3aqf.dll differs from each time I try to restart the
windows service.... This is something I just don't understand. If I comment
out the lines of code where the ConfigurationManager.GetConfig is performed
everything works as before, so it is that call that for some reason messes
things up for me.

Does anyone have any idea as to what this problem is caused by? I'm glad to
receive any help available...

Best regards,
--
/ Jorgas
Nov 22 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.