By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,588 Members | 1,920 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,588 IT Pros & Developers. It's quick & easy.

asp.net server application unavailable

P: n/a
hi all!

=====================================
my environment:
MS .NET 1.1 with Service pack 1
ASP.NET framework
IIS 5.0
C#.NET language.
=====================================

during the development of an web application i am facing the following
problem.
======================================
Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.
Administrator Note: An error message detailing the cause of this specific
request failure can be found in the application event log of the web server.
Please review this log entry to discover what caused this error to occur.
=======================================

my application contains just one webform containing a textbox, a combobox
for fontname, a combobox for fontsize, a combobox for color, a combobox for
fontstyle. beside them there is an imagebox.

i am trying to draw the content of the textbox over an image in the picture
box with the font properties from the other combobox selected vales.

i write the code in a button click event using gdi+.

i write the code in try catch finally block, but no exception caught there.

i write the following code in global.asax file:=
protected void Application_Start(Object sender, EventArgs e)
{
System.Diagnostics.Debug.Write("Application_Start" );
System.AppDomain.CurrentDomain.DomainUnload += new
System.EventHandler(AppDomainUnload);
}

protected void Application_Error(Object sender, EventArgs e)
{
Exception ex = Server.GetLastError();
Context.ClearError();
Response.Write("Application_Error");
Response.Write(ex.ToString());
}

private void AppDomainUnload(Object sender, EventArgs e)
{
System.Diagnostics.Debug.Write("AppDomainUnload");
System.Environment.Exit(0);
}

=============================================
The scenario: when i run the application it gives the above mentioned error.
but refreshing the page gives me the proper page and the all code functions
well. i run it again withouut any modification in the code... this time no
error, the function works well. now just change a location of a coordinate,
rebuild the solution and run it gives the error. refreshing the page solve
it. and this way it goes on. that means first time run after a build it gives
the error.

will u people face such problems ?? how can i solve it ? i search "server
application unavailable" in msdn and they suggest to install service pack 1
for .NET 1.1. i installed that. One suggestion says that right click on the
server in the IIS and go to all task, then go to check server extension. i
went there a message comes and a message asks to set security. i also do
that. but the same old error comes again and again.

Nov 22 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.