468,783 Members | 1,684 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,783 developers. It's quick & easy.

URL Forwarding Problem

Hi All,

I have an ASP.NET appication running on http://xx.xxx.xxxx.xx/aspApplication
and I have a domain http://www.mydomain.com registered at godaddy.com for
this application.I have setup domain forwarding at goDaddy.com to forward to
http://xx.xxx.xxxx.xx/aspApplication. I am using Forms Authentication on the
application.Now the problem i am facing is , when i login to the application
through http://xx.xxx.xxxx.xx/aspApplication everything works fine and get
authenticated and logged in. But when I login in through
http://www.mydomain.com , the cookie gets blocked and I am prevented from
logging in(i am not getting authenticated).

The path in the web.config file is pointed to path="/".

Any help appreciated.

--binod
Nov 22 '05 #1
1 1562
I've experencied this kind of behavior too, the problem was the forwarding
used a html iframe to display the underlying page. I've solved this by
disabling the "stealth" forwarding and using a normal redirect.

You can check what kind of forwarding you are using by surfing to the site
by using mydomain.com and the choosing View Source in IE. Can you post the
HTML?

--
Greetz,
Jan
__________________________________
Read my weblog: http://weblogs.asp.net/jan
"Binod Nair" <na*******@hotmail.com> schreef in bericht
news:u1****************@TK2MSFTNGP09.phx.gbl...
Hi All,

I have an ASP.NET appication running on http://xx.xxx.xxxx.xx/aspApplication and I have a domain http://www.mydomain.com registered at godaddy.com for
this application.I have setup domain forwarding at goDaddy.com to forward to http://xx.xxx.xxxx.xx/aspApplication. I am using Forms Authentication on the application.Now the problem i am facing is , when i login to the application through http://xx.xxx.xxxx.xx/aspApplication everything works fine and get
authenticated and logged in. But when I login in through
http://www.mydomain.com , the cookie gets blocked and I am prevented from
logging in(i am not getting authenticated).

The path in the web.config file is pointed to path="/".

Any help appreciated.

--binod

Nov 22 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Anu | last post: by
1 post views Thread by Binod Nair | last post: by
1 post views Thread by Jesse Rosenthal | last post: by
reply views Thread by nicholas | last post: by
reply views Thread by Daniel P. | last post: by
5 posts views Thread by Dave | last post: by
reply views Thread by zhoujie | last post: by
2 posts views Thread by Marin | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.