By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,365 Members | 3,095 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,365 IT Pros & Developers. It's quick & easy.

WebService – Returning an Object

P: n/a
H

I have a WebService calling a Method in a Remote Object. The Remote method Returns an Object. This Webservice also returns the same object. All things are working fine when this Web Service is running in a Windows XP. But when I am trying to run the same webservice in a Windows 2000 Advanced Server Machine, I am getting the following error

“System.Web.Services.Protocols.SoapException: Server was unable to process request. System.Exception: Return argument has an invalid type. at MyComponent.Users.DoLogin(String userName, String password)

When I am running some other Web Methods returning void or string or integer, its working fine

So when I am running a webmethod returning an object in a Windows 2000 Advanced Server machine, anything has to be done related security, etc.

Why am I getting such error in Windows 2000 Advanced Server machine only

Thanks and Regard

Siv
---
Posted using Wimdows.net Newsgroups - http://www.wimdows.net/newsgroups/
Nov 22 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Karuppasamy, please do not multi-post
http://www.ezine.com/netiquette.html
"Karuppasamy" <siva_prakash75@-NOSPAM-hotmail.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
Hi

I have a WebService calling a Method in a Remote Object. The Remote method Returns an Object. This Webservice also returns the same object. All things
are working fine when this Web Service is running in a Windows XP. But when
I am trying to run the same webservice in a Windows 2000 Advanced Server
Machine, I am getting the following error.
?oSystem.Web.Services.Protocols.SoapException: Server was unable to process request. System.Exception: Return argument has an invalid type. at
MyComponent.Users.DoLogin(String userName, String password)?
When I am running some other Web Methods returning void or string or integer, its working fine.
So when I am running a webmethod returning an object in a Windows 2000 Advanced Server machine, anything has to be done related security, etc..
Why am I getting such error in Windows 2000 Advanced Server machine only?

Thanks and Regards

Siva
---
Posted using Wimdows.net Newsgroups - http://www.wimdows.net/newsgroups/

Nov 22 '05 #2

P: n/a
Karuppasamy, please do not multi-post
http://www.ezine.com/netiquette.html
"Karuppasamy" <siva_prakash75@-NOSPAM-hotmail.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
Hi

I have a WebService calling a Method in a Remote Object. The Remote method Returns an Object. This Webservice also returns the same object. All things
are working fine when this Web Service is running in a Windows XP. But when
I am trying to run the same webservice in a Windows 2000 Advanced Server
Machine, I am getting the following error.
?oSystem.Web.Services.Protocols.SoapException: Server was unable to process request. System.Exception: Return argument has an invalid type. at
MyComponent.Users.DoLogin(String userName, String password)?
When I am running some other Web Methods returning void or string or integer, its working fine.
So when I am running a webmethod returning an object in a Windows 2000 Advanced Server machine, anything has to be done related security, etc..
Why am I getting such error in Windows 2000 Advanced Server machine only?

Thanks and Regards

Siva
---
Posted using Wimdows.net Newsgroups - http://www.wimdows.net/newsgroups/

Nov 22 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.