By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,217 Members | 1,374 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,217 IT Pros & Developers. It's quick & easy.

Web Service adding dll as a reference

P: n/a
I have a web service that is consumed by a C++ application.
I added a C# dll reference to the web service, When the web service calls a
method on the dll, it sends back an HRESULT of E_FAIL to my C++ application.

What is causing the web service to return an E_FAIL when it calls the method
on the dll it added as a reference?

Thanks
Nov 21 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hi,

There are a large number of possible answers to your question. I'm
assuming the web service is a VB.NET or C# web service, and not also
written in C#. Have you set a debug point in your service and stepped into
the call into the DLL to see where the call is failing?

I hope this helps

Dan Rogers
Microsoft Corporation
--------------------
Thread-Topic: Web Service adding dll as a reference
thread-index: AcTNpxuC1dclMftlTTqZ8ulUIXDqdQ==
X-WBNR-Posting-Host: 128.47.110.81
From: "=?Utf-8?B?cmdhcmY=?=" <rg***@discussions.microsoft.com>
Subject: Web Service adding dll as a reference
Date: Thu, 18 Nov 2004 11:45:07 -0800
Lines: 8
Message-ID: <EF**********************************@microsoft.co m>
MIME-Version: 1.0
Content-Type: text/plain;
charset="Utf-8"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
Content-Class: urn:content-classes:message
Importance: normal
Priority: normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
Newsgroups: microsoft.public.dotnet.framework.webservices
NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
Path: cpmsftngxa10.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSFT NGXA03.phx.gbl
Xref: cpmsftngxa10.phx.gbl
microsoft.public.dotnet.framework.webservices:7545
X-Tomcat-NG: microsoft.public.dotnet.framework.webservices

I have a web service that is consumed by a C++ application.
I added a C# dll reference to the web service, When the web service calls a
method on the dll, it sends back an HRESULT of E_FAIL to my C++ application.

What is causing the web service to return an E_FAIL when it calls the
method
on the dll it added as a reference?

Thanks

Nov 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.