470,620 Members | 1,504 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,620 developers. It's quick & easy.

Deployment problem with msi

I have a web service and a deployment project. Inside the deployment
project, is a custom action to create some database related items such as
stored procedures. I have this packaged as an msi, and can run the
deployment on win2k, win2k server, and winxp without problems. The database
related part of the custom deployment action uses integrated security to
login (SSPI). When tracing the deployments using sql profiler from any of
the machines, I see the login to the database as the user running the msi
When using the same deployment package on win2003 server, the database
connection now uses "domain\machinename$" instead of the logged in user
running the package. This then fails because the domain\machinename$ does
not have any permissions to the database. The install is being done thru
terminal services and the logged in user is a domain admin.
I am pulling my hair out trying to figure out how to get this to use the
logged in user. I do not want to put in the sa password and log in that way,
because the web service will be deployed to different servers and databases.
Right now I have one service and a deployment package that can be deployed
anywhere (except win2003).
Any help or recommendations on where to look would be greatly
appreciated, or if there is a better user group to post to.

Nov 21 '05 #1
0 1465

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Felix | last post: by
4 posts views Thread by wobbles | last post: by
3 posts views Thread by Steve Brecher | last post: by
3 posts views Thread by al | last post: by
11 posts views Thread by Thom Little | last post: by
2 posts views Thread by Bill Nguyen | last post: by
6 posts views Thread by andrewbb | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.