467,877 Members | 1,124 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,877 developers. It's quick & easy.

What does VS.NET when creating WebService

are there special settings applied to IIS5, when creating a webService in
VS.NET?

I wonder - because when I create a webService (let's call it webservice1)
using VStudio.NET on my remote W2K IIS5 it works fine and without any
problems.
When I don't use the VStudio.NET Wizard but only copy the .asmx and
bin/*.dll files to another web (on the _same_ server) it won't work! I
double-checked every setting in IIS and NTFS and can't found any difference!

What I did / settings:
I created a virtual folder called webservice1, which is here
\myWEBName\SOAP\webservice1
This folder has the application name 'webservice1', Execute Permissions for
'Scripts only' and Protection 'Medium(Pooled)'. Directory Security is set to
anonymous access using the IUSR_BILLIE, also Integr.Security is activated.

Application Mappings for .asmx and .aspx are set to
C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll with
GET,HEAD,POST,DEBUG

HTML and ASP Files work fine. When I save the ASP-File under .aspx I get
Server Error in '/SOAP/webservice1' Application. with no further
details - error messages are suppressed;-(
With .asmx it's the same problem.

My web.config looks exactly like this:
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.web>
<compilation defaultLanguage="vb" debug="false" />
<customErrors mode="Off" />
</system.web>
</configuration>

File Security is set to 'Everyone -> Full Control' for the whole
'webservice1'-Folder for Testing.
I'm desperataly searching for any help...

Thank you very much for any idea...
eRic

Nov 21 '05 #1
  • viewed: 1606
Share:
1 Reply
Hello Eric!

Weird that You get: Server Error in '/SOAP/webservice1' Application. With a
virtual folder called webservice1, I'd expect: Server Error in '/webservice1'
Application. Maybe you can clarify what your physical path is and where your bin
directory is located?

Björn
Eric Voigt wrote:
are there special settings applied to IIS5, when creating a webService in
VS.NET?

I wonder - because when I create a webService (let's call it webservice1)
using VStudio.NET on my remote W2K IIS5 it works fine and without any
problems.
When I don't use the VStudio.NET Wizard but only copy the .asmx and
bin/*.dll files to another web (on the _same_ server) it won't work! I
double-checked every setting in IIS and NTFS and can't found any difference!

What I did / settings:
I created a virtual folder called webservice1, which is here
\myWEBName\SOAP\webservice1
This folder has the application name 'webservice1', Execute Permissions for
'Scripts only' and Protection 'Medium(Pooled)'. Directory Security is set to
anonymous access using the IUSR_BILLIE, also Integr.Security is activated.

Application Mappings for .asmx and .aspx are set to
C:\WINNT\Microsoft.NET\Framework\v1.1.4322\aspnet_ isapi.dll with
GET,HEAD,POST,DEBUG

HTML and ASP Files work fine. When I save the ASP-File under .aspx I get
Server Error in '/SOAP/webservice1' Application. with no further
details - error messages are suppressed;-(
With .asmx it's the same problem.

My web.config looks exactly like this:
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.web>
<compilation defaultLanguage="vb" debug="false" />
<customErrors mode="Off" />
</system.web>
</configuration>

File Security is set to 'Everyone -> Full Control' for the whole
'webservice1'-Folder for Testing.

I'm desperataly searching for any help...

Thank you very much for any idea...
eRic


Nov 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by mklapp | last post: by
1 post views Thread by Steve | last post: by
reply views Thread by jack112 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.