By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,696 Members | 1,424 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,696 IT Pros & Developers. It's quick & easy.

Auto Complete of Variable Names

P: n/a
I would like to find out how to turn on the Auto Complete variable names
feature while editing source code in Visual Studio. It seems to appear on
intermittantly, and when it does the variable list is incomplete or contains
variables that do not even exist in the project being worked on. It seems
like there should be a setting to turn this on and keep it up to date but I
cannot find anything in MSDN. It is also a complete mystery why it only pops
up on rare occassions and is missing the rest of the time.

Thanks
Dave
Nov 17 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Did you look at Options->Text Editor->All Languages->General?

When IntelliSence acts funny, deleting the .ncb file in the project
directory usually solves the problem.

Hope the helps,
Mark.

"Brakeshoe" wrote:
I would like to find out how to turn on the Auto Complete variable names
feature while editing source code in Visual Studio. It seems to appear on
intermittantly, and when it does the variable list is incomplete or contains
variables that do not even exist in the project being worked on. It seems
like there should be a setting to turn this on and keep it up to date but I
cannot find anything in MSDN. It is also a complete mystery why it only pops
up on rare occassions and is missing the rest of the time.

Thanks
Dave

Nov 17 '05 #2

P: n/a
I do not see Options->Text Editor->All Languages->General. When I go under
the Tools tab in Visual Studio I see an options tab with 3 sections. They
are Windows settings, save options and statement completion options. I am in
Visual Studio 6.0.
Deleting the NCB files did not have any effect, I still do not get auto
complete even when pressing control-space.

"Mark" wrote:
Did you look at Options->Text Editor->All Languages->General?

When IntelliSence acts funny, deleting the .ncb file in the project
directory usually solves the problem.

Hope the helps,
Mark.

"Brakeshoe" wrote:
I would like to find out how to turn on the Auto Complete variable names
feature while editing source code in Visual Studio. It seems to appear on
intermittantly, and when it does the variable list is incomplete or contains
variables that do not even exist in the project being worked on. It seems
like there should be a setting to turn this on and keep it up to date but I
cannot find anything in MSDN. It is also a complete mystery why it only pops
up on rare occassions and is missing the rest of the time.

Thanks
Dave

Nov 17 '05 #3

P: n/a
There still is an option for it on the Editor tab, Statement Completion
Options.

It's time to upgrade. You can download VC++ 8.0 Express for free from MSDN.

Mark.

"Brakeshoe" wrote:
I do not see Options->Text Editor->All Languages->General. When I go under
the Tools tab in Visual Studio I see an options tab with 3 sections. They
are Windows settings, save options and statement completion options. I am in
Visual Studio 6.0.
Deleting the NCB files did not have any effect, I still do not get auto
complete even when pressing control-space.

"Mark" wrote:
Did you look at Options->Text Editor->All Languages->General?

When IntelliSence acts funny, deleting the .ncb file in the project
directory usually solves the problem.

Hope the helps,
Mark.

"Brakeshoe" wrote:
I would like to find out how to turn on the Auto Complete variable names
feature while editing source code in Visual Studio. It seems to appear on
intermittantly, and when it does the variable list is incomplete or contains
variables that do not even exist in the project being worked on. It seems
like there should be a setting to turn this on and keep it up to date but I
cannot find anything in MSDN. It is also a complete mystery why it only pops
up on rare occassions and is missing the rest of the time.

Thanks
Dave

Nov 17 '05 #4

P: n/a
I have all the statement completion options checked on, but it does work. I
do not know if my IT department will allow me to upgrade.

"Mark" wrote:
There still is an option for it on the Editor tab, Statement Completion
Options.

It's time to upgrade. You can download VC++ 8.0 Express for free from MSDN.

Mark.

"Brakeshoe" wrote:
I do not see Options->Text Editor->All Languages->General. When I go under
the Tools tab in Visual Studio I see an options tab with 3 sections. They
are Windows settings, save options and statement completion options. I am in
Visual Studio 6.0.
Deleting the NCB files did not have any effect, I still do not get auto
complete even when pressing control-space.

"Mark" wrote:
Did you look at Options->Text Editor->All Languages->General?

When IntelliSence acts funny, deleting the .ncb file in the project
directory usually solves the problem.

Hope the helps,
Mark.

"Brakeshoe" wrote:

> I would like to find out how to turn on the Auto Complete variable names
> feature while editing source code in Visual Studio. It seems to appear on
> intermittantly, and when it does the variable list is incomplete or contains
> variables that do not even exist in the project being worked on. It seems
> like there should be a setting to turn this on and keep it up to date but I
> cannot find anything in MSDN. It is also a complete mystery why it only pops
> up on rare occassions and is missing the rest of the time.
>
> Thanks
> Dave

Nov 17 '05 #5

P: n/a
>> It's time to upgrade. You can download VC++ 8.0 Express for free from
MSDN.

Which is not compatible with anything before it, so be warned. It will
almost assuredly require you to make changes form any previous code that
worked, and then it might not act as before. For example, in my case, I
can't run my program without it being in Console mode (brings up a Console
screen) or else I get an exception error on exit. This didn't happen in
2003. And there are many REQUIRED syntax changes, EVEN if you use the old
syntax switch. For example, references to handler functions must now be
fully quilfied in managed code. So if you had any code that looked like:

Click += new EventHandler( this, m_Handler ) ;

then if this is in the class myClass you know are REQUIRED to express it
like this:

Click += new EventHandler( this, &myClass::m_Handler ) ;

Note also the '&' in front of "myClass::m_Handler".
do not know if my IT department will allow me to upgrade.
They might be afraid of your code no longer working if you do... : )

In a nutshell, the new 2005 is not backwards compatible with any previous
version (except of course 2005 beta...hehe), so upgrade at your own risk!
: )

[==P==]

PS - And if you use a lot of managed code in your legacy code, I recommend
NOT trying to switch over to /clr, and leave it in old syntax mode (which,
like I said, still requires changes from all previous versions). It is quite
mindboggling how many changes need to be made to convert from __gc to /clr.
But note that MS plans to completely remove all __gc syntax functionality
and support in the future, so you're damned if you do, and damned if you
don't... : )
"Brakeshoe" <Br*******@discussions.microsoft.com> wrote in message
news:D9**********************************@microsof t.com...I have all the statement completion options checked on, but it does work.
I
do not know if my IT department will allow me to upgrade.

"Mark" wrote:
There still is an option for it on the Editor tab, Statement Completion
Options.

It's time to upgrade. You can download VC++ 8.0 Express for free from
MSDN.

Mark.

"Brakeshoe" wrote:
> I do not see Options->Text Editor->All Languages->General. When I go
> under
> the Tools tab in Visual Studio I see an options tab with 3 sections.
> They
> are Windows settings, save options and statement completion options. I
> am in
> Visual Studio 6.0.
> Deleting the NCB files did not have any effect, I still do not get auto
> complete even when pressing control-space.
>
> "Mark" wrote:
>
> > Did you look at Options->Text Editor->All Languages->General?
> >
> > When IntelliSence acts funny, deleting the .ncb file in the project
> > directory usually solves the problem.
> >
> > Hope the helps,
> > Mark.
> >
> > "Brakeshoe" wrote:
> >
> > > I would like to find out how to turn on the Auto Complete variable
> > > names
> > > feature while editing source code in Visual Studio. It seems to
> > > appear on
> > > intermittantly, and when it does the variable list is incomplete or
> > > contains
> > > variables that do not even exist in the project being worked on.
> > > It seems
> > > like there should be a setting to turn this on and keep it up to
> > > date but I
> > > cannot find anything in MSDN. It is also a complete mystery why it
> > > only pops
> > > up on rare occassions and is missing the rest of the time.
> > >
> > > Thanks
> > > Dave

Nov 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.