By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,659 Members | 910 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,659 IT Pros & Developers. It's quick & easy.

ASP/ActiveX Error

P: n/a
I have set up a website and am testing ASPs. I have created
a very simple ActiveX component with two interfaces:

AboutBox() - displays About details
calcpi() - returns 3.14159

Here is my configuration (All the most up to date versions
except for Visual C++):

Windows XP (Home Edition).
Visual C++ 6.0
Apache Webserver
SUN ASPONE
Internet Explorer

When I use ATL COM Appwizard to create my ActiveX
component (DLL really), I can get the following
to work quite easily:

<%
Set x =Server.CreateObject("AC.AcCtrl.1")

x.calcpi()
%>

However, when I use MFC ActiveX Control Wizzard to create
my ActiveX (.ocx really) component, the above does not
work. Well, the instantion of the x object appears to
work but I obtain the following error when I try to
invoke x.calcpi():

error '8000ffff'

/t.asp, line 4

Can anyone tell me what they think is happening here?

Possible problems: Internet Explorer ?
ActiveX Wizzard ?
XP Home Edition ?
SUN ASPONE ? (least likely)

Please don't ask me to use the latest Express Edition of
Visual C++ (It's an abortion).

Don't know if this is the right place for this question but no activity seems
to be going on in the ASP forum...

Thanks,
John Gabriel
Nov 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Found out these are not supported by ASP ONE. What is strange though is that
the ATL COM DLLs do work in ASP but the Activex MFC components do not.

"ActiveX DLL files are not supported. For more information, visit the Sun
ONE Active Server Pages Web site at http://www.chilisoft.com"


"John Gabriel" wrote:
I have set up a website and am testing ASPs. I have created
a very simple ActiveX component with two interfaces:

AboutBox() - displays About details
calcpi() - returns 3.14159

Here is my configuration (All the most up to date versions
except for Visual C++):

Windows XP (Home Edition).
Visual C++ 6.0
Apache Webserver
SUN ASPONE
Internet Explorer

When I use ATL COM Appwizard to create my ActiveX
component (DLL really), I can get the following
to work quite easily:

<%
Set x =Server.CreateObject("AC.AcCtrl.1")

x.calcpi()
%>

However, when I use MFC ActiveX Control Wizzard to create
my ActiveX (.ocx really) component, the above does not
work. Well, the instantion of the x object appears to
work but I obtain the following error when I try to
invoke x.calcpi():

error '8000ffff'

/t.asp, line 4

Can anyone tell me what they think is happening here?

Possible problems: Internet Explorer ?
ActiveX Wizzard ?
XP Home Edition ?
SUN ASPONE ? (least likely)

Please don't ask me to use the latest Express Edition of
Visual C++ (It's an abortion).

Don't know if this is the right place for this question but no activity seems
to be going on in the ASP forum...

Thanks,
John Gabriel

Nov 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.