469,646 Members | 1,201 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,646 developers. It's quick & easy.

AVI file not play Audio and video in Sync

nan

Please give me some tips or some source code by using which able to
make the avi file for audio and video data to play in sync.

Some details are given below:
I noticed that many times the video recorded is 7 Frames
per second and again it will change to 15 frames per second. While in
this scenario the audio card's sampling frequency is 8000Hz therefore
the number of samples per second is 8000. So , in this situation I am
not understanding how to synchronize these two streams video and the
audio.

For audio it is fixed ie. the number of samples per second is 8000 but

for video frames, it is not fixed it will always get changes (ie. 7FPS

15FPS, 30FPS - here FPS -> Frames per second).So many times the audio
is ahead and many times the video.

--
nan
------------------------------------------------------------------------
Posted via http://www.codecomments.com
------------------------------------------------------------------------

Nov 17 '05 #1
0 1205

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

22 posts views Thread by The Road To Utopia | last post: by
7 posts views Thread by Kilian A. Foth | last post: by
reply views Thread by Mohammad | last post: by
1 post views Thread by Isabella | last post: by
5 posts views Thread by Baren | last post: by
6 posts views Thread by k.vanderstarren | last post: by
4 posts views Thread by Kevin | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.