By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,563 Members | 1,066 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,563 IT Pros & Developers. It's quick & easy.

Fatal internal C1060: out of heap space error even with hotfix

P: n/a
I use the C++ compiler with Visual Studio .NET 2003. OS is XP SP2.
Our projects include many large 3rd party C++ include files.
I have installed the hotfix mentioned in MSDN KB article 837437.
It helped for a while, but now the problem as popped up again.
/Zm option does not help.

The funny thing about it, is that if you compile many files in one go, the
first file will compile ok, the rest will fail. So you can solve the problem
by compiling one by one file or compile a project again and again till all
problem files have been "first in the line". But it is a productivitykiller
de luxe.

My guess is that when compiling many files, the compiler does not release
and reallocate memory properly between each file to compile.

Anyway, when do we get a real fix for this?

For a preliminary fix: Is there a way where I can *prevent* Visual Studio to
group the compiling of many files (with the same compiler options) when it
invoces the compiler? I.e. Force it to start the C++ compiler once for each
C++ file.

--
-Rune Jorgensen
www.dds.no
Nov 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
JD

"Rune Jorgensen (DDS)" <Ru**************@discussions.microsoft.com> wrote in
message news:10**********************************@microsof t.com...
I use the C++ compiler with Visual Studio .NET 2003. OS is XP SP2.
Our projects include many large 3rd party C++ include files.
I have installed the hotfix mentioned in MSDN KB article 837437.
It helped for a while, but now the problem as popped up again.
/Zm option does not help.

The funny thing about it, is that if you compile many files in one go, the
first file will compile ok, the rest will fail. So you can solve the problem by compiling one by one file or compile a project again and again till all
problem files have been "first in the line". But it is a productivitykiller de luxe.

My guess is that when compiling many files, the compiler does not release
and reallocate memory properly between each file to compile.

Anyway, when do we get a real fix for this?

For a preliminary fix: Is there a way where I can *prevent* Visual Studio to group the compiling of many files (with the same compiler options) when it
invoces the compiler? I.e. Force it to start the C++ compiler once for each C++ file.

--
-Rune Jorgensen
www.dds.no


I had this problem a few years back with Visual Studio 6 --- It turned out
the the problem was caused by a circular include file situation. And it was
a big problem to locate.

JD
Nov 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.