By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,688 Members | 1,226 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,688 IT Pros & Developers. It's quick & easy.

Command line warning D4025 : overriding '/EHs' with '/EHa'

P: n/a
I have recently purchased Visual C++ . Net compiler and i am trying to
compile a project that i had working in Visual C++ 6.0.

When I compile, I am receiving the warning:

cl : Command line warning D4025 : overriding '/EHs' with '/EHa'

I have specifically asked for the /EHsc switch because that is what I
require.

Is there anyway that I can get it to compile in this way?

Thanks,
Brett.
Nov 17 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
"Brett" <bg*******@hotmail.com> wrote in message
news:72**************************@posting.google.c om...
I have recently purchased Visual C++ . Net compiler and i am trying to
compile a project that i had working in Visual C++ 6.0.
OK.
When I compile, I am receiving the warning:

cl : Command line warning D4025 : overriding '/EHs' with '/EHa'

I have specifically asked for the /EHsc switch because that is what I
require.
Are you using Win32's structured exception handling
(__try/__except/__finally) or using a structured exception translator (
_set_se_translator() ) in that project?
If you are, then the compiler knows better. :-)
Is there anyway that I can get it to compile in this way?


Perhaps. You might want to post a little information as to why you can't use
/EHa. Someone may be able to suggest something.

Regards,
Will
Nov 17 '05 #2

P: n/a
You normally only get this when you specify both /EHc and /EHa. Can you
provide the full command line? And let us know what version of the compiler
it is (7.0 or 7.1)?

Thanks.

Ronald Laeremans
Visual C++ team

"Brett" <bg*******@hotmail.com> wrote in message
news:72**************************@posting.google.c om...
I have recently purchased Visual C++ . Net compiler and i am trying to
compile a project that i had working in Visual C++ 6.0.

When I compile, I am receiving the warning:

cl : Command line warning D4025 : overriding '/EHs' with '/EHa'

I have specifically asked for the /EHsc switch because that is what I
require.

Is there anyway that I can get it to compile in this way?

Thanks,
Brett.

Nov 17 '05 #3

P: n/a
I see the problem now, the old project had /EHa added (by hand) to the
command line, when I imported it into the new environment (7.1.3088),
it defaulted to the /EHsc option as well as using my additional
switch. This then caused the conflict when I compiled.

One small point with the new environment is that I can't select a /EHa
option from the project options. I can write in the edit control, but
that info isn't kept. I've just selected no exceptions, and added /EHa
to the additional command line switches.

Brett.

"Ronald Laeremans [MSFT]" <ro*****@online.microsoft.com> wrote in message news:<On**************@TK2MSFTNGP10.phx.gbl>...
You normally only get this when you specify both /EHc and /EHa. Can you
provide the full command line? And let us know what version of the compiler
it is (7.0 or 7.1)?

Thanks.

Ronald Laeremans
Visual C++ team

"Brett" <bg*******@hotmail.com> wrote in message
news:72**************************@posting.google.c om...
I have recently purchased Visual C++ . Net compiler and i am trying to
compile a project that i had working in Visual C++ 6.0.

When I compile, I am receiving the warning:

cl : Command line warning D4025 : overriding '/EHs' with '/EHa'

I have specifically asked for the /EHsc switch because that is what I
require.

Is there anyway that I can get it to compile in this way?

Thanks,
Brett.

Nov 17 '05 #4

P: n/a
I am glad you got it resolved.

On you small point. Yes that was a (design) bug we had in VS 2003. /EHa is
back in the project options for VC 2005. The workaround you applied is the
best one.

Ronald

"Brett" <bg*******@hotmail.com> wrote in message
news:72**************************@posting.google.c om...
I see the problem now, the old project had /EHa added (by hand) to the
command line, when I imported it into the new environment (7.1.3088),
it defaulted to the /EHsc option as well as using my additional
switch. This then caused the conflict when I compiled.

One small point with the new environment is that I can't select a /EHa
option from the project options. I can write in the edit control, but
that info isn't kept. I've just selected no exceptions, and added /EHa
to the additional command line switches.

Brett.

"Ronald Laeremans [MSFT]" <ro*****@online.microsoft.com> wrote in message
news:<On**************@TK2MSFTNGP10.phx.gbl>...
You normally only get this when you specify both /EHc and /EHa. Can you
provide the full command line? And let us know what version of the
compiler
it is (7.0 or 7.1)?

Thanks.

Ronald Laeremans
Visual C++ team

"Brett" <bg*******@hotmail.com> wrote in message
news:72**************************@posting.google.c om...
>I have recently purchased Visual C++ . Net compiler and i am trying to
> compile a project that i had working in Visual C++ 6.0.
>
> When I compile, I am receiving the warning:
>
> cl : Command line warning D4025 : overriding '/EHs' with '/EHa'
>
> I have specifically asked for the /EHsc switch because that is what I
> require.
>
> Is there anyway that I can get it to compile in this way?
>
> Thanks,
> Brett.

Nov 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.