By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,538 Members | 2,225 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,538 IT Pros & Developers. It's quick & easy.

Major problem with XSD schema's in Internet Explorer

P: n/a
We develop and host a webbased accounting application which is fully xml/xsd
and webservice oriented.

We have recently noticed that xml schemas (xsd or xdr) are not being cached
by Internet Explorer, or at least the cache isn't being used anymore. We know
for a fact that this was working properly until recently: if-modified-since
headers would be sent to the server which then replied with 304's, but now we
see that these headers are not being sent anymore, forcing the server to
respond with a 200. We suspect it must be due to some recent windows update
(urlmon, wininet, msxml ??) but we're not exactly sure when.

When the schema is directly requested through the location bar of IE it is
cached correctly while if the xml parser is allowed to resolve it as an
external the cache is by-passed (no if-modified-since header).

Our XSD is over 140kB and caching is obviously crucial to the performance of
our application.

Any comments, suggestions, similar experiences?
Thanks in advance


--------Sample XML-file:---------------
<?xml version="1.0" encoding="utf-8" ?>
<DATA xmlns="x-schema:schema.xsd">
<CUS>
<CUSNBR>1</CUSNBR>
</CUS>
</DATA>

--------Sample XSD-file:--------------
<Schema xmlns="urn:schemas-microsoft-com:xml-data"
xmlns:dt="urn:schemas-microsoft-com:datatypes">
<ElementType name="DATA" content="eltOnly" order="many">
<element type="CUS" maxOccurs="1" />
</ElementType>
<ElementType name="CUS" content="eltOnly" order="many">
<element type="CUSNBR" maxOccurs="1" />
</ElementType>
<ElementType name="CUSNBR" content="textOnly" dt:type="int"/>
</Schema>
Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.