467,166 Members | 1,023 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,166 developers. It's quick & easy.

delete service cause driver uninstalled

Hi,

I install a filter driver through INF file to a 3rd party audio device (with
driver). The filter driver works well on the 3rd party driver. However upon
uninstallation of the filter driver, it will eventually cause the audio
driver get uninstalled as well.

Here are the steps to uninstall the filter driver:
1. Disable the target audio device.
2. Delete the filter name from "Upperfilters" key of the audio device in
registry.
3. Enable the target audio device.
4. Run "sc stop <filter-name>" and "sc delete <filter-name>".

The problem happens when I try to delete the filter driver from the service
database at step 4. Straight after the service removal, the audio driver
indicates that it will be uninstalled in next system reboot.

1. What exactly causes the audio driver to be uninstalled?
2. How could I delete the filter service and yet won't have audio driver
uninstalled?

Thanks in advance.

CS
Nov 11 '05 #1
  • viewed: 995
Share:

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by trialproduct2004@yahoo.com | last post: by
4 posts views Thread by news.microsoft.com | last post: by
reply views Thread by CS Loh | last post: by
reply views Thread by =?Utf-8?B?c3VqaXRo?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.