By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,117 Members | 2,093 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,117 IT Pros & Developers. It's quick & easy.

Permission Errors

P: n/a

Hello. My new dev machine is running XP Pro. In the past all
equipment has only used Windows 2000. I have had a lot of problems
getting my projects up and running on the new machine. The current
one is a permission error.

The project is a VC++ Web Service. It works fine when the service is
hosted on the old W2K dev machine, but on the new XP machine I get a
permission error when the service tries to open a text file on the
Windows 2000 domain server. It is a standard fopen call across the
LAN. I have no problem opening the file from Windows Explorer, or
from a standard windows program on the XP machine, but with the Web
Service, when running on the XP machine, the fopen call returns NULL
and GetNextError returns 5 - permission error.

I cannot find any reason - any help?

Thanks, Russ

Oct 16 '05 #1
Share this Question
Share on Google+
12 Replies


P: n/a
Hi Russ,

Welcome to MSDN newsgroup.
From your description, you have a c++ built Webservcie which will access a
remote file on a local domain server. This works well when deploying on a
win2k server , however after move it to a winxp box, you found the
webservice failed with permission error when perform the file accessing
operation, yes?

AS for the VC++ webservice is it hosed in IIS and how did you creating it
and deploying it? Generally the permission problem is likely caused by the
webservice's process idenitity. For most service applications they're
running under a non-interactive account(local account ) which won't be
remotable. So when accessing resources on remote machine, such local
service accont will be recoginzed as NULL session. For "windows explorer"
or other standard windows applications, they're running under the
interative logon user's account and when the interactive user is a domain
user, it'll surely be valid to remote machine.

So please have a check on this and feel free to post here if you have any
further finding or questions.

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Permission Errors
| Date: Sun, 16 Oct 2005 16:23:08 -0400
| Message-ID: <th********************************@4ax.com>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 19
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP 0F
ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cmpOB 8GJxt0WNYj77Zlz6C4uKfEoYW8
EeDeRHbG!47Nts75I
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornad o.fastwebnet.it!tiscali!ne
wsfeed1.ip.tiscali.net!news.glorb.com!postnews.goo gle.com!news4.google.com!b
order1.nntp.dca.giganews.com!nntp.giganews.com!loc al01.nntp.dca.giganews.com
!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| X-Tomcat-NG: microsoft.public.dotnet.general
|
|
| Hello. My new dev machine is running XP Pro. In the past all
| equipment has only used Windows 2000. I have had a lot of problems
| getting my projects up and running on the new machine. The current
| one is a permission error.
|
| The project is a VC++ Web Service. It works fine when the service is
| hosted on the old W2K dev machine, but on the new XP machine I get a
| permission error when the service tries to open a text file on the
| Windows 2000 domain server. It is a standard fopen call across the
| LAN. I have no problem opening the file from Windows Explorer, or
| from a standard windows program on the XP machine, but with the Web
| Service, when running on the XP machine, the fopen call returns NULL
| and GetNextError returns 5 - permission error.
|
| I cannot find any reason - any help?
|
| Thanks, Russ
|
|

Oct 17 '05 #2

P: n/a
On Mon, 17 Oct 2005 03:18:00 GMT, st*****@online.microsoft.com (Steven
Cheng[MSFT]) wrote:
Hi Russ,

Welcome to MSDN newsgroup.
From your description, you have a c++ built Webservcie which will access a
remote file on a local domain server. This works well when deploying on a
win2k server , however after move it to a winxp box, you found the
webservice failed with permission error when perform the file accessing
operation, yes?
Not exactly. The web service is being built on the dev station running
under XP. It accesses a file on the W2K server. When I run or debug
it on the XP station, is when it fails. When I build and test the
same source code on a W2K Pro workstation there is no failure.

Also, if I deploy the web service on the W2K server, it works ok. So
the problem is just with the XP workstation.

AS for the VC++ webservice is it hosed in IIS and how did you creating it
and deploying it?
I presume you mean hosted, not hosed? I would agree with either
statement, ha ha.

It is created with Visual Studio using managed C++. It makes calls to
an unmanaged library and it is this library that makes the call to
open the server file. I have tried a variety of methods to deploy it.
VC++ deploys it automatically on the local machine, but I have also
built a deployment project and used that to deploy on the local
machine. Additionally I have tried manually creating a virtual
directory via IIS.
Generally the permission problem is likely caused by the
webservice's process idenitity. For most service applications they're
running under a non-interactive account(local account ) which won't be
remotable. So when accessing resources on remote machine, such local
service accont will be recoginzed as NULL session. For "windows explorer"
or other standard windows applications, they're running under the
interative logon user's account and when the interactive user is a domain
user, it'll surely be valid to remote machine.
In the web.config file, I have:

<identity impersonate="true" userName="xps.PrsNj.local\Russ"
password="xxx" />

Does not this allow the web service to take on the permissions of the
user account on the XP machine? (XPS is the machine name.)

So please have a check on this and feel free to post here if you have any
further finding or questions.
I'm sure this is the crux of the problem, but how do I go about
checking it out and curing it? And why does it fail under XP but not
under W2K Pro? I did discover that for XP, in my impersonate
statement I had to use the full domain name of the XPS machine,
xps.PrsNj.local, whereas in W2K all I needed was xps.russ.

Thanks you. Russ

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Permission Errors
| Date: Sun, 16 Oct 2005 16:23:08 -0400
| Message-ID: <th********************************@4ax.com>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 19
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP 0F
ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cmpO B8GJxt0WNYj77Zlz6C4uKfEoYW8
EeDeRHbG!47Nts75I
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torna do.fastwebnet.it!tiscali!ne
wsfeed1.ip.tiscali.net!news.glorb.com!postnews.go ogle.com!news4.google.com!b
order1.nntp.dca.giganews.com!nntp.giganews.com!lo cal01.nntp.dca.giganews.com
!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| X-Tomcat-NG: microsoft.public.dotnet.general
|
|
| Hello. My new dev machine is running XP Pro. In the past all
| equipment has only used Windows 2000. I have had a lot of problems
| getting my projects up and running on the new machine. The current
| one is a permission error.
|
| The project is a VC++ Web Service. It works fine when the service is
| hosted on the old W2K dev machine, but on the new XP machine I get a
| permission error when the service tries to open a text file on the
| Windows 2000 domain server. It is a standard fopen call across the
| LAN. I have no problem opening the file from Windows Explorer, or
| from a standard windows program on the XP machine, but with the Web
| Service, when running on the XP machine, the fopen call returns NULL
| and GetNextError returns 5 - permission error.
|
| I cannot find any reason - any help?
|
| Thanks, Russ
|
|

Oct 17 '05 #3

P: n/a
Hi Russ,

Thanks for your response.
As you mentioned that you've use the following configuration in web.config
<identity impersonate="true" userName="xps.PrsNj.local\Russ"
password="xxx" />

that means the webservice will running under the impersonate idenitity.
Also, the "xps.PrsNj.local\Russ" is a local account on the XP machine, yes?
If so, it is not remotable to other remote machines. Are the xp client
machine and win2k box in a domain
environment? If so , you can try configured the webservice to running under
a domain account so that it can be validated on the win2k server machine.

In addition, is there SQLserver on the win2k box? If so, you can try let
the webservice make connection to sqlserver so that you can watch which
cilent account is logon at the server (through the SQLserver profiler). If
no sqlserver available, you can try turning on the NTFS security audit on
that shared folder at the 2k server machine. Thus , we can watch audit log
to check the client account also.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Mon, 17 Oct 2005 09:42:38 -0400
| Message-ID: <d4********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 126
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj4x
XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26IP
8Kdp9Ub8!SFDYpnTo
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tornad o.fastwebnet.it!tiscali!ne
wsfeed1.ip.tiscali.net!proxad.net!216.239.36.134.M ISMATCH!postnews.google.co
m!news4.google.com!border1.nntp.dca.giganews.com!n ntp.giganews.com!local01.n
ntp.dca.giganews.com!nntp.comcast.com!news.comcast .com.POSTED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52146
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| On Mon, 17 Oct 2005 03:18:00 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >Welcome to MSDN newsgroup.
| >From your description, you have a c++ built Webservcie which will access
a
| >remote file on a local domain server. This works well when deploying on
a
| >win2k server , however after move it to a winxp box, you found the
| >webservice failed with permission error when perform the file accessing
| >operation, yes?
|
| Not exactly. The web service is being built on the dev station running
| under XP. It accesses a file on the W2K server. When I run or debug
| it on the XP station, is when it fails. When I build and test the
| same source code on a W2K Pro workstation there is no failure.
|
| Also, if I deploy the web service on the W2K server, it works ok. So
| the problem is just with the XP workstation.
|
| >
| >AS for the VC++ webservice is it hosed in IIS and how did you creating
it
| >and deploying it?
|
| I presume you mean hosted, not hosed? I would agree with either
| statement, ha ha.
|
| It is created with Visual Studio using managed C++. It makes calls to
| an unmanaged library and it is this library that makes the call to
| open the server file. I have tried a variety of methods to deploy it.
| VC++ deploys it automatically on the local machine, but I have also
| built a deployment project and used that to deploy on the local
| machine. Additionally I have tried manually creating a virtual
| directory via IIS.
|
| > Generally the permission problem is likely caused by the
| >webservice's process idenitity. For most service applications they're
| >running under a non-interactive account(local account ) which won't be
| >remotable. So when accessing resources on remote machine, such local
| >service accont will be recoginzed as NULL session. For "windows
explorer"
| >or other standard windows applications, they're running under the
| >interative logon user's account and when the interactive user is a
domain
| >user, it'll surely be valid to remote machine.
|
| In the web.config file, I have:
|
| <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| password="xxx" />
|
| Does not this allow the web service to take on the permissions of the
| user account on the XP machine? (XPS is the machine name.)
|
| >
| >So please have a check on this and feel free to post here if you have
any
| >further finding or questions.
|
| I'm sure this is the crux of the problem, but how do I go about
| checking it out and curing it? And why does it fail under XP but not
| under W2K Pro? I did discover that for XP, in my impersonate
| statement I had to use the full domain name of the XPS machine,
| xps.PrsNj.local, whereas in W2K all I needed was xps.russ.
|
| Thanks you. Russ
|
| >
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Permission Errors
| >| Date: Sun, 16 Oct 2005 16:23:08 -0400
| >| Message-ID: <th********************************@4ax.com>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 19
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP 0 F
|ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cmpO B8GJxt0WNYj77Zlz6C4uKfEoYW 8
| >EeDeRHbG!47Nts75I
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torna do.fastwebnet.it!tiscali!n e
|wsfeed1.ip.tiscali.net!news.glorb.com!postnews.go ogle.com!news4.google.com! b
|order1.nntp.dca.giganews.com!nntp.giganews.com!lo cal01.nntp.dca.giganews.co

m
| >!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >|
| >| Hello. My new dev machine is running XP Pro. In the past all
| >| equipment has only used Windows 2000. I have had a lot of problems
| >| getting my projects up and running on the new machine. The current
| >| one is a permission error.
| >|
| >| The project is a VC++ Web Service. It works fine when the service is
| >| hosted on the old W2K dev machine, but on the new XP machine I get a
| >| permission error when the service tries to open a text file on the
| >| Windows 2000 domain server. It is a standard fopen call across the
| >| LAN. I have no problem opening the file from Windows Explorer, or
| >| from a standard windows program on the XP machine, but with the Web
| >| Service, when running on the XP machine, the fopen call returns NULL
| >| and GetNextError returns 5 - permission error.
| >|
| >| I cannot find any reason - any help?
| >|
| >| Thanks, Russ
| >|
| >|
|

Oct 19 '05 #4

P: n/a
On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
Cheng[MSFT]) wrote:
Hi Russ,

Thanks for your response.
As you mentioned that you've use the following configuration in web.config
<identity impersonate="true" userName="xps.PrsNj.local\Russ"
password="xxx" />

that means the webservice will running under the impersonate idenitity.
Also, the "xps.PrsNj.local\Russ" is a local account on the XP machine, yes?
Yes.
If so, it is not remotable to other remote machines. Are the xp client
machine and win2k box in a domain
environment? If so , you can try configured the webservice to running under
a domain account so that it can be validated on the win2k server machine.
But why should I have to do this? I did not have to do it when the
dev machine was running W2K. It seems to me that when one builds a
web service on his local machine and then tries to debug it, the
permissions of the logged in developer should apply - especially when
impersonating that user.

However I have discovered that I can deploy the web service to the W2K
domain server and there it runs with no problems, except that I had to
change the impersonated user to a domain user. I did not have to do
this when the dev station was W2K. In other words, the web service,
running on the W2K server, would impersonate a local user on the W2K
dev station, and it would still work. Not so with the dev station
being XP.

Changing the impersonated user to a user on the domain does work when
the service is running on the domain server, so that was good enough
for me to decide that the new XP dev machine is up and usable. Next I
built the client for the web service, and that works too (as long as
the service runs on the domain server). My main problem now is that I
have to use remote debugging if I need to debug something - so I still
need to find the solution.

So now that I have proved that the XP dev station is usable, I went
ahead and executed the next step in upgrading my development platform.
I retired the W2K server and built a new W2003 domain server. I have
not yet got that server up to the point where I can run the web
service on it. A lot of other work, to make sure it could support our
legacy applications, was needed first. So I am not sure exactly how
the new server will affect all this - if at all.

I will get back to you on this in a day or three when I get everything
running again. In the meanwhile it would be good if you have any
other suggestions regarding being able to debug the web service on my
dev machine.

Thanks for your continued attention to this matter,

Regards, Russ

In addition, is there SQLserver on the win2k box? If so, you can try let
the webservice make connection to sqlserver so that you can watch which
cilent account is logon at the server (through the SQLserver profiler). If
no sqlserver available, you can try turning on the NTFS security audit on
that shared folder at the 2k server machine. Thus , we can watch audit log
to check the client account also.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Mon, 17 Oct 2005 09:42:38 -0400
| Message-ID: <d4********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 126
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj4x
XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26IP
8Kdp9Ub8!SFDYpnTo
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torna do.fastwebnet.it!tiscali!ne
wsfeed1.ip.tiscali.net!proxad.net!216.239.36.134. MISMATCH!postnews.google.co
m!news4.google.com!border1.nntp.dca.giganews.com! nntp.giganews.com!local01.n
ntp.dca.giganews.com!nntp.comcast.com!news.comcas t.com.POSTED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52146
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| On Mon, 17 Oct 2005 03:18:00 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >Welcome to MSDN newsgroup.
| >From your description, you have a c++ built Webservcie which will access
a
| >remote file on a local domain server. This works well when deploying on
a
| >win2k server , however after move it to a winxp box, you found the
| >webservice failed with permission error when perform the file accessing
| >operation, yes?
|
| Not exactly. The web service is being built on the dev station running
| under XP. It accesses a file on the W2K server. When I run or debug
| it on the XP station, is when it fails. When I build and test the
| same source code on a W2K Pro workstation there is no failure.
|
| Also, if I deploy the web service on the W2K server, it works ok. So
| the problem is just with the XP workstation.
|
| >
| >AS for the VC++ webservice is it hosed in IIS and how did you creating
it
| >and deploying it?
|
| I presume you mean hosted, not hosed? I would agree with either
| statement, ha ha.
|
| It is created with Visual Studio using managed C++. It makes calls to
| an unmanaged library and it is this library that makes the call to
| open the server file. I have tried a variety of methods to deploy it.
| VC++ deploys it automatically on the local machine, but I have also
| built a deployment project and used that to deploy on the local
| machine. Additionally I have tried manually creating a virtual
| directory via IIS.
|
| > Generally the permission problem is likely caused by the
| >webservice's process idenitity. For most service applications they're
| >running under a non-interactive account(local account ) which won't be
| >remotable. So when accessing resources on remote machine, such local
| >service accont will be recoginzed as NULL session. For "windows
explorer"
| >or other standard windows applications, they're running under the
| >interative logon user's account and when the interactive user is a
domain
| >user, it'll surely be valid to remote machine.
|
| In the web.config file, I have:
|
| <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| password="xxx" />
|
| Does not this allow the web service to take on the permissions of the
| user account on the XP machine? (XPS is the machine name.)
|
| >
| >So please have a check on this and feel free to post here if you have
any
| >further finding or questions.
|
| I'm sure this is the crux of the problem, but how do I go about
| checking it out and curing it? And why does it fail under XP but not
| under W2K Pro? I did discover that for XP, in my impersonate
| statement I had to use the full domain name of the XPS machine,
| xps.PrsNj.local, whereas in W2K all I needed was xps.russ.
|
| Thanks you. Russ
|
| >
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Permission Errors
| >| Date: Sun, 16 Oct 2005 16:23:08 -0400
| >| Message-ID: <th********************************@4ax.com>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 19
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP 0

F
|
ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cmp OB8GJxt0WNYj77Zlz6C4uKfEoYW

8
| >EeDeRHbG!47Nts75I
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torn ado.fastwebnet.it!tiscali!n

e
|
wsfeed1.ip.tiscali.net!news.glorb.com!postnews.g oogle.com!news4.google.com!

b
|
order1.nntp.dca.giganews.com!nntp.giganews.com!l ocal01.nntp.dca.giganews.co

m
| >!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >|
| >| Hello. My new dev machine is running XP Pro. In the past all
| >| equipment has only used Windows 2000. I have had a lot of problems
| >| getting my projects up and running on the new machine. The current
| >| one is a permission error.
| >|
| >| The project is a VC++ Web Service. It works fine when the service is
| >| hosted on the old W2K dev machine, but on the new XP machine I get a
| >| permission error when the service tries to open a text file on the
| >| Windows 2000 domain server. It is a standard fopen call across the
| >| LAN. I have no problem opening the file from Windows Explorer, or
| >| from a standard windows program on the XP machine, but with the Web
| >| Service, when running on the XP machine, the fopen call returns NULL
| >| and GetNextError returns 5 - permission error.
| >|
| >| I cannot find any reason - any help?
| >|
| >| Thanks, Russ
| >|
| >|
|

Oct 19 '05 #5

P: n/a
Thanks for your followup Russ,

For local account, it can be authenticated on a remote server as long as
there is a duplicated mapping account which has the same username and
password on the target remote server. So not sure whether the wi2k client
and server share such a account which is used as the asp.net's process
identity at that time.

For remote debugging, it'll be a bit hard to configure, here is the related
msdn reference:

#Debugging Web Applications on a Remote Server
http://msdn.microsoft.com/library/en...ggingwebapplic
ationonremoteserver.asp?frame=true

Hope helps. Thanks,
Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| NNTP-Posting-Date: Wed, 19 Oct 2005 12:21:48 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Wed, 19 Oct 2005 13:21:58 -0400
| Message-ID: <5r********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
<d4********************************@4ax.com>
<4u**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 254
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-jtKs6ibccbcdVOqD7r0U0Nv1pR88uVIsTjSQRO/b4YNtC+c0kWEJkVyings++mPIi4yGliHb
bBqRXX7!3nlKJ7Vz4T7VqZZCzfW4LsLP6KIhDx660IlMuENAqh UErGdA+hZDcmQvXH9Uhq4easwG
t3FRAAbL!PoRmgA+B
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
ne.de!news.glorb.com!border1.nntp.dca.giganews.com !nntp.giganews.com!local01
.nntp.dca.giganews.com!nntp.comcast.com!news.comca st.com.POSTED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52368
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >Thanks for your response.
| >As you mentioned that you've use the following configuration in
web.config
| > <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >password="xxx" />
| >
| >that means the webservice will running under the impersonate idenitity.
| >Also, the "xps.PrsNj.local\Russ" is a local account on the XP machine,
yes?
|
| Yes.
|
| > If so, it is not remotable to other remote machines. Are the xp client
| >machine and win2k box in a domain
| >environment? If so , you can try configured the webservice to running
under
| >a domain account so that it can be validated on the win2k server
machine.
|
| But why should I have to do this? I did not have to do it when the
| dev machine was running W2K. It seems to me that when one builds a
| web service on his local machine and then tries to debug it, the
| permissions of the logged in developer should apply - especially when
| impersonating that user.
|
| However I have discovered that I can deploy the web service to the W2K
| domain server and there it runs with no problems, except that I had to
| change the impersonated user to a domain user. I did not have to do
| this when the dev station was W2K. In other words, the web service,
| running on the W2K server, would impersonate a local user on the W2K
| dev station, and it would still work. Not so with the dev station
| being XP.
|
| Changing the impersonated user to a user on the domain does work when
| the service is running on the domain server, so that was good enough
| for me to decide that the new XP dev machine is up and usable. Next I
| built the client for the web service, and that works too (as long as
| the service runs on the domain server). My main problem now is that I
| have to use remote debugging if I need to debug something - so I still
| need to find the solution.
|
| So now that I have proved that the XP dev station is usable, I went
| ahead and executed the next step in upgrading my development platform.
| I retired the W2K server and built a new W2003 domain server. I have
| not yet got that server up to the point where I can run the web
| service on it. A lot of other work, to make sure it could support our
| legacy applications, was needed first. So I am not sure exactly how
| the new server will affect all this - if at all.
|
| I will get back to you on this in a day or three when I get everything
| running again. In the meanwhile it would be good if you have any
| other suggestions regarding being able to debug the web service on my
| dev machine.
|
| Thanks for your continued attention to this matter,
|
| Regards, Russ
|
| >
| >In addition, is there SQLserver on the win2k box? If so, you can try let
| >the webservice make connection to sqlserver so that you can watch which
| >cilent account is logon at the server (through the SQLserver profiler).
If
| >no sqlserver available, you can try turning on the NTFS security audit
on
| >that shared folder at the 2k server machine. Thus , we can watch audit
log
| >to check the client account also.
| >
| >Thanks,
| >
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Re: Permission Errors
| >| Date: Mon, 17 Oct 2005 09:42:38 -0400
| >| Message-ID: <d4********************************@4ax.com>
| >| References: <th********************************@4ax.com>
| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 126
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj4 x
|XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26I P
| >8Kdp9Ub8!SFDYpnTo
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torna do.fastwebnet.it!tiscali!n e
|wsfeed1.ip.tiscali.net!proxad.net!216.239.36.134. MISMATCH!postnews.google.c o
|m!news4.google.com!border1.nntp.dca.giganews.com! nntp.giganews.com!local01. n
|ntp.dca.giganews.com!nntp.comcast.com!news.comcas t.com.POSTED!not-for-mail

| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52146
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >| On Mon, 17 Oct 2005 03:18:00 GMT, st*****@online.microsoft.com (Steven
| >| Cheng[MSFT]) wrote:
| >|
| >| >Hi Russ,
| >| >
| >| >Welcome to MSDN newsgroup.
| >| >From your description, you have a c++ built Webservcie which will
access
| >a
| >| >remote file on a local domain server. This works well when deploying
on
| >a
| >| >win2k server , however after move it to a winxp box, you found the
| >| >webservice failed with permission error when perform the file
accessing
| >| >operation, yes?
| >|
| >| Not exactly. The web service is being built on the dev station running
| >| under XP. It accesses a file on the W2K server. When I run or debug
| >| it on the XP station, is when it fails. When I build and test the
| >| same source code on a W2K Pro workstation there is no failure.
| >|
| >| Also, if I deploy the web service on the W2K server, it works ok. So
| >| the problem is just with the XP workstation.
| >|
| >| >
| >| >AS for the VC++ webservice is it hosed in IIS and how did you
creating
| >it
| >| >and deploying it?
| >|
| >| I presume you mean hosted, not hosed? I would agree with either
| >| statement, ha ha.
| >|
| >| It is created with Visual Studio using managed C++. It makes calls to
| >| an unmanaged library and it is this library that makes the call to
| >| open the server file. I have tried a variety of methods to deploy it.
| >| VC++ deploys it automatically on the local machine, but I have also
| >| built a deployment project and used that to deploy on the local
| >| machine. Additionally I have tried manually creating a virtual
| >| directory via IIS.
| >|
| >| > Generally the permission problem is likely caused by the
| >| >webservice's process idenitity. For most service applications they're
| >| >running under a non-interactive account(local account ) which won't
be
| >| >remotable. So when accessing resources on remote machine, such local
| >| >service accont will be recoginzed as NULL session. For "windows
| >explorer"
| >| >or other standard windows applications, they're running under the
| >| >interative logon user's account and when the interactive user is a
| >domain
| >| >user, it'll surely be valid to remote machine.
| >|
| >| In the web.config file, I have:
| >|
| >| <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >| password="xxx" />
| >|
| >| Does not this allow the web service to take on the permissions of the
| >| user account on the XP machine? (XPS is the machine name.)
| >|
| >| >
| >| >So please have a check on this and feel free to post here if you have
| >any
| >| >further finding or questions.
| >|
| >| I'm sure this is the crux of the problem, but how do I go about
| >| checking it out and curing it? And why does it fail under XP but not
| >| under W2K Pro? I did discover that for XP, in my impersonate
| >| statement I had to use the full domain name of the XPS machine,
| >| xps.PrsNj.local, whereas in W2K all I needed was xps.russ.
| >|
| >| Thanks you. Russ
| >|
| >| >
| >| >Steven Cheng
| >| >Microsoft Online Support
| >| >
| >| >Get Secure! www.microsoft.com/security
| >| >(This posting is provided "AS IS", with no warranties, and confers no
| >| >rights.)
| >| >
| >| >
| >| >
| >| >
| >| >--------------------
| >| >| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| >| >| From: Russ <ru****@eticomm.net>
| >| >| Newsgroups: microsoft.public.dotnet.general
| >| >| Subject: Permission Errors
| >| >| Date: Sun, 16 Oct 2005 16:23:08 -0400
| >| >| Message-ID: <th********************************@4ax.com>
| >| >| X-Newsreader: Forte Agent 3.0/32.763
| >| >| MIME-Version: 1.0
| >| >| Content-Type: text/plain; charset=us-ascii
| >| >| Content-Transfer-Encoding: 7bit
| >| >| Lines: 19
| >| >| NNTP-Posting-Host: 68.37.155.53
| >| >| X-Trace:
| >|
|
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP 0
| >F
| >|
|ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cmp OB8GJxt0WNYj77Zlz6C4uKfEoY W
| >8
| >| >EeDeRHbG!47Nts75I
| >| >| X-Complaints-To: ab***@comcast.net
| >| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
headers
| >| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >| >complaint properly
| >| >| X-Postfilter: 1.3.32
| >| >| Path:
| >|
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torn ado.fastwebnet.it!tiscali! n
| >e
| >|
|wsfeed1.ip.tiscali.net!news.glorb.com!postnews.g oogle.com!news4.google.com !
| >b
| >|
|order1.nntp.dca.giganews.com!nntp.giganews.com!l ocal01.nntp.dca.giganews.c

o
| >m
| >| >!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| >| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| >| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >| >|
| >| >|
| >| >| Hello. My new dev machine is running XP Pro. In the past all
| >| >| equipment has only used Windows 2000. I have had a lot of problems
| >| >| getting my projects up and running on the new machine. The current
| >| >| one is a permission error.
| >| >|
| >| >| The project is a VC++ Web Service. It works fine when the service
is
| >| >| hosted on the old W2K dev machine, but on the new XP machine I get a
| >| >| permission error when the service tries to open a text file on the
| >| >| Windows 2000 domain server. It is a standard fopen call across the
| >| >| LAN. I have no problem opening the file from Windows Explorer, or
| >| >| from a standard windows program on the XP machine, but with the Web
| >| >| Service, when running on the XP machine, the fopen call returns NULL
| >| >| and GetNextError returns 5 - permission error.
| >| >|
| >| >| I cannot find any reason - any help?
| >| >|
| >| >| Thanks, Russ
| >| >|
| >| >|
| >|
|

Oct 20 '05 #6

P: n/a
Steven, I have now a different program that is keeping me from even
getting back to the issue we were discussing. I installed the new
Windows 2003 server but suddenly I cannot get the web service to work,
either on the new server or even on the XP workstation. As far as I
know I did not change anything on the workstation, but maybe something
happened by accident. Anyway whenever I try to run the service I get
the following error screen, which is rather cryptic as I cannot figure
out what to do.

My first question is: what is "PayrollEntryService.Global"? Is it a
file, a class, or what. How do I find it and what do I do to make
sure it is loadable?

Thanks, Russ
Server Error in '/PayrollEntryService' Application.
--------------------------------------------------------------------------------

Parser Error
Description: An error occurred during the parsing of a resource
required to service this request. Please review the following specific
parse error details and modify your source file appropriately.

Parser Error Message: Could not load type
'PayrollEntryService.Global'.

Source Error:
Line 1: <%@ Application Codebehind="Global.asax.h"
Inherits="PayrollEntryService.Global" %>

Source File: C:\PssDev\PayrollEntryService\global.asax Line: 1
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
ASP.NET Version:1.1.4322.2032

On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
Cheng[MSFT]) wrote:
Hi Russ,

Thanks for your response.
As you mentioned that you've use the following configuration in web.config
<identity impersonate="true" userName="xps.PrsNj.local\Russ"
password="xxx" />

that means the webservice will running under the impersonate idenitity.
Also, the "xps.PrsNj.local\Russ" is a local account on the XP machine, yes?
If so, it is not remotable to other remote machines. Are the xp client
machine and win2k box in a domain
environment? If so , you can try configured the webservice to running under
a domain account so that it can be validated on the win2k server machine.

In addition, is there SQLserver on the win2k box? If so, you can try let
the webservice make connection to sqlserver so that you can watch which
cilent account is logon at the server (through the SQLserver profiler). If
no sqlserver available, you can try turning on the NTFS security audit on
that shared folder at the 2k server machine. Thus , we can watch audit log
to check the client account also.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Mon, 17 Oct 2005 09:42:38 -0400
| Message-ID: <d4********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 126
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj4x
XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26IP
8Kdp9Ub8!SFDYpnTo
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torna do.fastwebnet.it!tiscali!ne
wsfeed1.ip.tiscali.net!proxad.net!216.239.36.134. MISMATCH!postnews.google.co
m!news4.google.com!border1.nntp.dca.giganews.com! nntp.giganews.com!local01.n
ntp.dca.giganews.com!nntp.comcast.com!news.comcas t.com.POSTED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52146
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| On Mon, 17 Oct 2005 03:18:00 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >Welcome to MSDN newsgroup.
| >From your description, you have a c++ built Webservcie which will access
a
| >remote file on a local domain server. This works well when deploying on
a
| >win2k server , however after move it to a winxp box, you found the
| >webservice failed with permission error when perform the file accessing
| >operation, yes?
|
| Not exactly. The web service is being built on the dev station running
| under XP. It accesses a file on the W2K server. When I run or debug
| it on the XP station, is when it fails. When I build and test the
| same source code on a W2K Pro workstation there is no failure.
|
| Also, if I deploy the web service on the W2K server, it works ok. So
| the problem is just with the XP workstation.
|
| >
| >AS for the VC++ webservice is it hosed in IIS and how did you creating
it
| >and deploying it?
|
| I presume you mean hosted, not hosed? I would agree with either
| statement, ha ha.
|
| It is created with Visual Studio using managed C++. It makes calls to
| an unmanaged library and it is this library that makes the call to
| open the server file. I have tried a variety of methods to deploy it.
| VC++ deploys it automatically on the local machine, but I have also
| built a deployment project and used that to deploy on the local
| machine. Additionally I have tried manually creating a virtual
| directory via IIS.
|
| > Generally the permission problem is likely caused by the
| >webservice's process idenitity. For most service applications they're
| >running under a non-interactive account(local account ) which won't be
| >remotable. So when accessing resources on remote machine, such local
| >service accont will be recoginzed as NULL session. For "windows
explorer"
| >or other standard windows applications, they're running under the
| >interative logon user's account and when the interactive user is a
domain
| >user, it'll surely be valid to remote machine.
|
| In the web.config file, I have:
|
| <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| password="xxx" />
|
| Does not this allow the web service to take on the permissions of the
| user account on the XP machine? (XPS is the machine name.)
|
| >
| >So please have a check on this and feel free to post here if you have
any
| >further finding or questions.
|
| I'm sure this is the crux of the problem, but how do I go about
| checking it out and curing it? And why does it fail under XP but not
| under W2K Pro? I did discover that for XP, in my impersonate
| statement I had to use the full domain name of the XPS machine,
| xps.PrsNj.local, whereas in W2K all I needed was xps.russ.
|
| Thanks you. Russ
|
| >
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Permission Errors
| >| Date: Sun, 16 Oct 2005 16:23:08 -0400
| >| Message-ID: <th********************************@4ax.com>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 19
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP 0

F
|
ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cmp OB8GJxt0WNYj77Zlz6C4uKfEoYW

8
| >EeDeRHbG!47Nts75I
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torn ado.fastwebnet.it!tiscali!n

e
|
wsfeed1.ip.tiscali.net!news.glorb.com!postnews.g oogle.com!news4.google.com!

b
|
order1.nntp.dca.giganews.com!nntp.giganews.com!l ocal01.nntp.dca.giganews.co

m
| >!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >|
| >| Hello. My new dev machine is running XP Pro. In the past all
| >| equipment has only used Windows 2000. I have had a lot of problems
| >| getting my projects up and running on the new machine. The current
| >| one is a permission error.
| >|
| >| The project is a VC++ Web Service. It works fine when the service is
| >| hosted on the old W2K dev machine, but on the new XP machine I get a
| >| permission error when the service tries to open a text file on the
| >| Windows 2000 domain server. It is a standard fopen call across the
| >| LAN. I have no problem opening the file from Windows Explorer, or
| >| from a standard windows program on the XP machine, but with the Web
| >| Service, when running on the XP machine, the fopen call returns NULL
| >| and GetNextError returns 5 - permission error.
| >|
| >| I cannot find any reason - any help?
| >|
| >| Thanks, Russ
| >|
| >|
|

Oct 21 '05 #7

P: n/a
Hi Russ,

As for the new problem you mentioned, it is likely caused by some
deployment setting.
The "XXXX.Global " is a class , and generally each ASP.NET application
will have one(or using the default if we don't explicitly provide one).
When using VS.NET IDE to create the asp.net project, it'll automatically
add such a global class. However, the error message you met is not
specific to the global class, it indicate that your asp.net
application(webservice) can not find the certain class (assembly) it
requires.(generally global class is the first class which need to be loaded
into runtime...).

So on your new 2003 server, go to your webservice(PayrollEntryService)'s
application dir, and check the private "bin" sub dir to see whether all the
webservice's assemblies are in the "bin" dir.

If the assemblies are all existing, then make sure your application's
physical dir is located in a public place (not a user specific one , for
example under document settings\username......) so that the ASP.NET process
identity can successfully access them.

Also, above all , you need to makesure a normal asp.net
application(webservice) can run correctly (hosted in IIS). If there're
anything unclear, please feel free to post here.

Thanks,
Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| NNTP-Posting-Date: Fri, 21 Oct 2005 14:22:25 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Fri, 21 Oct 2005 15:22:06 -0400
| Message-ID: <nc********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
<d4********************************@4ax.com>
<4u**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 253
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-nXJenZUWWBgFZCR9vAHhVQLHt3Ar8sodPe/9DYkFMD06e5++XOLGolXHkMgGuBK9UwTQG3MJ
uOW6yvi!Oh4nJ9x+wxOR0neSTmsAJJ2RUlucT5voq4zjyjd5/cH6Ik6BJ4XkBaGpD25dXcsAPmoo
ArLXAoie!/vUojs8u
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
ne.de!border2.nntp.dca.giganews.com!border1.nntp.d ca.giganews.com!nntp.gigan
ews.com!local01.nntp.dca.giganews.com!nntp.comcast .com!news.comcast.com.POST
ED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52567
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| Steven, I have now a different program that is keeping me from even
| getting back to the issue we were discussing. I installed the new
| Windows 2003 server but suddenly I cannot get the web service to work,
| either on the new server or even on the XP workstation. As far as I
| know I did not change anything on the workstation, but maybe something
| happened by accident. Anyway whenever I try to run the service I get
| the following error screen, which is rather cryptic as I cannot figure
| out what to do.
|
| My first question is: what is "PayrollEntryService.Global"? Is it a
| file, a class, or what. How do I find it and what do I do to make
| sure it is loadable?
|
| Thanks, Russ
|
|
| Server Error in '/PayrollEntryService' Application.
|
----------------------------------------------------------------------------
----
|
| Parser Error
| Description: An error occurred during the parsing of a resource
| required to service this request. Please review the following specific
| parse error details and modify your source file appropriately.
|
| Parser Error Message: Could not load type
| 'PayrollEntryService.Global'.
|
| Source Error:
|
|
| Line 1: <%@ Application Codebehind="Global.asax.h"
| Inherits="PayrollEntryService.Global" %>
|
|
|
| Source File: C:\PssDev\PayrollEntryService\global.asax Line: 1
|
|
|
----------------------------------------------------------------------------
----
| Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
| ASP.NET Version:1.1.4322.2032
|
| On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >Thanks for your response.
| >As you mentioned that you've use the following configuration in
web.config
| > <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >password="xxx" />
| >
| >that means the webservice will running under the impersonate idenitity.
| >Also, the "xps.PrsNj.local\Russ" is a local account on the XP machine,
yes?
| > If so, it is not remotable to other remote machines. Are the xp client
| >machine and win2k box in a domain
| >environment? If so , you can try configured the webservice to running
under
| >a domain account so that it can be validated on the win2k server
machine.
| >
| >In addition, is there SQLserver on the win2k box? If so, you can try let
| >the webservice make connection to sqlserver so that you can watch which
| >cilent account is logon at the server (through the SQLserver profiler).
If
| >no sqlserver available, you can try turning on the NTFS security audit
on
| >that shared folder at the 2k server machine. Thus , we can watch audit
log
| >to check the client account also.
| >
| >Thanks,
| >
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Re: Permission Errors
| >| Date: Mon, 17 Oct 2005 09:42:38 -0400
| >| Message-ID: <d4********************************@4ax.com>
| >| References: <th********************************@4ax.com>
| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 126
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj4 x
|XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26I P
| >8Kdp9Ub8!SFDYpnTo
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torna do.fastwebnet.it!tiscali!n e
|wsfeed1.ip.tiscali.net!proxad.net!216.239.36.134. MISMATCH!postnews.google.c o
|m!news4.google.com!border1.nntp.dca.giganews.com! nntp.giganews.com!local01. n
|ntp.dca.giganews.com!nntp.comcast.com!news.comcas t.com.POSTED!not-for-mail

| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52146
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >| On Mon, 17 Oct 2005 03:18:00 GMT, st*****@online.microsoft.com (Steven
| >| Cheng[MSFT]) wrote:
| >|
| >| >Hi Russ,
| >| >
| >| >Welcome to MSDN newsgroup.
| >| >From your description, you have a c++ built Webservcie which will
access
| >a
| >| >remote file on a local domain server. This works well when deploying
on
| >a
| >| >win2k server , however after move it to a winxp box, you found the
| >| >webservice failed with permission error when perform the file
accessing
| >| >operation, yes?
| >|
| >| Not exactly. The web service is being built on the dev station running
| >| under XP. It accesses a file on the W2K server. When I run or debug
| >| it on the XP station, is when it fails. When I build and test the
| >| same source code on a W2K Pro workstation there is no failure.
| >|
| >| Also, if I deploy the web service on the W2K server, it works ok. So
| >| the problem is just with the XP workstation.
| >|
| >| >
| >| >AS for the VC++ webservice is it hosed in IIS and how did you
creating
| >it
| >| >and deploying it?
| >|
| >| I presume you mean hosted, not hosed? I would agree with either
| >| statement, ha ha.
| >|
| >| It is created with Visual Studio using managed C++. It makes calls to
| >| an unmanaged library and it is this library that makes the call to
| >| open the server file. I have tried a variety of methods to deploy it.
| >| VC++ deploys it automatically on the local machine, but I have also
| >| built a deployment project and used that to deploy on the local
| >| machine. Additionally I have tried manually creating a virtual
| >| directory via IIS.
| >|
| >| > Generally the permission problem is likely caused by the
| >| >webservice's process idenitity. For most service applications they're
| >| >running under a non-interactive account(local account ) which won't
be
| >| >remotable. So when accessing resources on remote machine, such local
| >| >service accont will be recoginzed as NULL session. For "windows
| >explorer"
| >| >or other standard windows applications, they're running under the
| >| >interative logon user's account and when the interactive user is a
| >domain
| >| >user, it'll surely be valid to remote machine.
| >|
| >| In the web.config file, I have:
| >|
| >| <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >| password="xxx" />
| >|
| >| Does not this allow the web service to take on the permissions of the
| >| user account on the XP machine? (XPS is the machine name.)
| >|
| >| >
| >| >So please have a check on this and feel free to post here if you have
| >any
| >| >further finding or questions.
| >|
| >| I'm sure this is the crux of the problem, but how do I go about
| >| checking it out and curing it? And why does it fail under XP but not
| >| under W2K Pro? I did discover that for XP, in my impersonate
| >| statement I had to use the full domain name of the XPS machine,
| >| xps.PrsNj.local, whereas in W2K all I needed was xps.russ.
| >|
| >| Thanks you. Russ
| >|
| >| >
| >| >Steven Cheng
| >| >Microsoft Online Support
| >| >
| >| >Get Secure! www.microsoft.com/security
| >| >(This posting is provided "AS IS", with no warranties, and confers no
| >| >rights.)
| >| >
| >| >
| >| >
| >| >
| >| >--------------------
| >| >| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| >| >| From: Russ <ru****@eticomm.net>
| >| >| Newsgroups: microsoft.public.dotnet.general
| >| >| Subject: Permission Errors
| >| >| Date: Sun, 16 Oct 2005 16:23:08 -0400
| >| >| Message-ID: <th********************************@4ax.com>
| >| >| X-Newsreader: Forte Agent 3.0/32.763
| >| >| MIME-Version: 1.0
| >| >| Content-Type: text/plain; charset=us-ascii
| >| >| Content-Transfer-Encoding: 7bit
| >| >| Lines: 19
| >| >| NNTP-Posting-Host: 68.37.155.53
| >| >| X-Trace:
| >|
|
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP 0
| >F
| >|
|ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cmp OB8GJxt0WNYj77Zlz6C4uKfEoY W
| >8
| >| >EeDeRHbG!47Nts75I
| >| >| X-Complaints-To: ab***@comcast.net
| >| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
headers
| >| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >| >complaint properly
| >| >| X-Postfilter: 1.3.32
| >| >| Path:
| >|
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torn ado.fastwebnet.it!tiscali! n
| >e
| >|
|wsfeed1.ip.tiscali.net!news.glorb.com!postnews.g oogle.com!news4.google.com !
| >b
| >|
|order1.nntp.dca.giganews.com!nntp.giganews.com!l ocal01.nntp.dca.giganews.c

o
| >m
| >| >!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| >| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| >| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >| >|
| >| >|
| >| >| Hello. My new dev machine is running XP Pro. In the past all
| >| >| equipment has only used Windows 2000. I have had a lot of problems
| >| >| getting my projects up and running on the new machine. The current
| >| >| one is a permission error.
| >| >|
| >| >| The project is a VC++ Web Service. It works fine when the service
is
| >| >| hosted on the old W2K dev machine, but on the new XP machine I get a
| >| >| permission error when the service tries to open a text file on the
| >| >| Windows 2000 domain server. It is a standard fopen call across the
| >| >| LAN. I have no problem opening the file from Windows Explorer, or
| >| >| from a standard windows program on the XP machine, but with the Web
| >| >| Service, when running on the XP machine, the fopen call returns NULL
| >| >| and GetNextError returns 5 - permission error.
| >| >|
| >| >| I cannot find any reason - any help?
| >| >|
| >| >| Thanks, Russ
| >| >|
| >| >|
| >|
|

Oct 24 '05 #8

P: n/a
Steven, thanks for your reply. The web service project exists on the
local workstation, not the server. It was working when I had the old
server running, both when running the web service on the local
workstation and when deployed to the W2K server.

Now it works on neither - and as far as I know I did not change
anything at the workstation. As well as I can understand, the server
should not have any effect on starting the project on the work
station. Once the service is running on the workstation, then it
needs the server in order to locate some data files, but the project
should still start, even if the server was shut down. Right???

And all I did was to set up a new server and remove the old one.
Incidentally, if I copy the service to the new server and try to run
it there, I get the same error. It seems that something has changed
in one of the project files, but I still don't have a clue what to
look for.

One last thing. The old server was a domain server and I set up the
new one to be a domain server with the same domain name. After the
2003 server was up, I removed the workstation from the domain, making
it a workgroup computer, and then joined the domain again, to be sure
it was registered correctly with the new server. Later in my testing
I started up the old server and sure enough the web service would run
on it (but still not on the work station). Then I demoted the old W2K
server down to a workgroup computer, and then joined it to the new
domain. At that point the web service no longer works on the W2K
server either!

Please try to make some sense of this for me - I haven't a clue!

Thanks, Russ

On Mon, 24 Oct 2005 04:39:22 GMT, st*****@online.microsoft.com (Steven
Cheng[MSFT]) wrote:
Hi Russ,

As for the new problem you mentioned, it is likely caused by some
deployment setting.
The "XXXX.Global " is a class , and generally each ASP.NET application
will have one(or using the default if we don't explicitly provide one).
When using VS.NET IDE to create the asp.net project, it'll automatically
add such a global class. However, the error message you met is not
specific to the global class, it indicate that your asp.net
application(webservice) can not find the certain class (assembly) it
requires.(generally global class is the first class which need to be loaded
into runtime...).

So on your new 2003 server, go to your webservice(PayrollEntryService)'s
application dir, and check the private "bin" sub dir to see whether all the
webservice's assemblies are in the "bin" dir.

If the assemblies are all existing, then make sure your application's
physical dir is located in a public place (not a user specific one , for
example under document settings\username......) so that the ASP.NET process
identity can successfully access them.

Also, above all , you need to makesure a normal asp.net
application(webservice) can run correctly (hosted in IIS). If there're
anything unclear, please feel free to post here.

Thanks,
Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| NNTP-Posting-Date: Fri, 21 Oct 2005 14:22:25 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Fri, 21 Oct 2005 15:22:06 -0400
| Message-ID: <nc********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
<d4********************************@4ax.com>
<4u**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 253
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-nXJenZUWWBgFZCR9vAHhVQLHt3Ar8sodPe/9DYkFMD06e5++XOLGolXHkMgGuBK9UwTQG3MJ
uOW6yvi!Oh4nJ9x+wxOR0neSTmsAJJ2RUlucT5voq4zjyjd 5/cH6Ik6BJ4XkBaGpD25dXcsAPmoo
ArLXAoie!/vUojs8u
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfe ed00.sul.t-online.de!t-onli
ne.de!border2.nntp.dca.giganews.com!border1.nntp. dca.giganews.com!nntp.gigan
ews.com!local01.nntp.dca.giganews.com!nntp.comcas t.com!news.comcast.com.POST
ED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52567
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| Steven, I have now a different program that is keeping me from even
| getting back to the issue we were discussing. I installed the new
| Windows 2003 server but suddenly I cannot get the web service to work,
| either on the new server or even on the XP workstation. As far as I
| know I did not change anything on the workstation, but maybe something
| happened by accident. Anyway whenever I try to run the service I get
| the following error screen, which is rather cryptic as I cannot figure
| out what to do.
|
| My first question is: what is "PayrollEntryService.Global"? Is it a
| file, a class, or what. How do I find it and what do I do to make
| sure it is loadable?
|
| Thanks, Russ
|
|
| Server Error in '/PayrollEntryService' Application.
|
----------------------------------------------------------------------------
----
|
| Parser Error
| Description: An error occurred during the parsing of a resource
| required to service this request. Please review the following specific
| parse error details and modify your source file appropriately.
|
| Parser Error Message: Could not load type
| 'PayrollEntryService.Global'.
|
| Source Error:
|
|
| Line 1: <%@ Application Codebehind="Global.asax.h"
| Inherits="PayrollEntryService.Global" %>
|
|
|
| Source File: C:\PssDev\PayrollEntryService\global.asax Line: 1
|
|
|
----------------------------------------------------------------------------
----
| Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
| ASP.NET Version:1.1.4322.2032
|
| On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >Thanks for your response.
| >As you mentioned that you've use the following configuration in
web.config
| > <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >password="xxx" />
| >
| >that means the webservice will running under the impersonate idenitity.
| >Also, the "xps.PrsNj.local\Russ" is a local account on the XP machine,
yes?
| > If so, it is not remotable to other remote machines. Are the xp client
| >machine and win2k box in a domain
| >environment? If so , you can try configured the webservice to running
under
| >a domain account so that it can be validated on the win2k server
machine.
| >
| >In addition, is there SQLserver on the win2k box? If so, you can try let
| >the webservice make connection to sqlserver so that you can watch which
| >cilent account is logon at the server (through the SQLserver profiler).
If
| >no sqlserver available, you can try turning on the NTFS security audit
on
| >that shared folder at the 2k server machine. Thus , we can watch audit
log
| >to check the client account also.
| >
| >Thanks,
| >
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Re: Permission Errors
| >| Date: Mon, 17 Oct 2005 09:42:38 -0400
| >| Message-ID: <d4********************************@4ax.com>
| >| References: <th********************************@4ax.com>
| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 126
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj4

x
|
XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26I

P
| >8Kdp9Ub8!SFDYpnTo
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torn ado.fastwebnet.it!tiscali!n

e
|
wsfeed1.ip.tiscali.net!proxad.net!216.239.36.134 .MISMATCH!postnews.google.c

o
|
m!news4.google.com!border1.nntp.dca.giganews.com !nntp.giganews.com!local01.

n
|
ntp.dca.giganews.com!nntp.comcast.com!news.comca st.com.POSTED!not-for-mail

| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52146
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >| On Mon, 17 Oct 2005 03:18:00 GMT, st*****@online.microsoft.com (Steven
| >| Cheng[MSFT]) wrote:
| >|
| >| >Hi Russ,
| >| >
| >| >Welcome to MSDN newsgroup.
| >| >From your description, you have a c++ built Webservcie which will
access
| >a
| >| >remote file on a local domain server. This works well when deploying
on
| >a
| >| >win2k server , however after move it to a winxp box, you found the
| >| >webservice failed with permission error when perform the file
accessing
| >| >operation, yes?
| >|
| >| Not exactly. The web service is being built on the dev station running
| >| under XP. It accesses a file on the W2K server. When I run or debug
| >| it on the XP station, is when it fails. When I build and test the
| >| same source code on a W2K Pro workstation there is no failure.
| >|
| >| Also, if I deploy the web service on the W2K server, it works ok. So
| >| the problem is just with the XP workstation.
| >|
| >| >
| >| >AS for the VC++ webservice is it hosed in IIS and how did you
creating
| >it
| >| >and deploying it?
| >|
| >| I presume you mean hosted, not hosed? I would agree with either
| >| statement, ha ha.
| >|
| >| It is created with Visual Studio using managed C++. It makes calls to
| >| an unmanaged library and it is this library that makes the call to
| >| open the server file. I have tried a variety of methods to deploy it.
| >| VC++ deploys it automatically on the local machine, but I have also
| >| built a deployment project and used that to deploy on the local
| >| machine. Additionally I have tried manually creating a virtual
| >| directory via IIS.
| >|
| >| > Generally the permission problem is likely caused by the
| >| >webservice's process idenitity. For most service applications they're
| >| >running under a non-interactive account(local account ) which won't
be
| >| >remotable. So when accessing resources on remote machine, such local
| >| >service accont will be recoginzed as NULL session. For "windows
| >explorer"
| >| >or other standard windows applications, they're running under the
| >| >interative logon user's account and when the interactive user is a
| >domain
| >| >user, it'll surely be valid to remote machine.
| >|
| >| In the web.config file, I have:
| >|
| >| <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >| password="xxx" />
| >|
| >| Does not this allow the web service to take on the permissions of the
| >| user account on the XP machine? (XPS is the machine name.)
| >|
| >| >
| >| >So please have a check on this and feel free to post here if you have
| >any
| >| >further finding or questions.
| >|
| >| I'm sure this is the crux of the problem, but how do I go about
| >| checking it out and curing it? And why does it fail under XP but not
| >| under W2K Pro? I did discover that for XP, in my impersonate
| >| statement I had to use the full domain name of the XPS machine,
| >| xps.PrsNj.local, whereas in W2K all I needed was xps.russ.
| >|
| >| Thanks you. Russ
| >|
| >| >
| >| >Steven Cheng
| >| >Microsoft Online Support
| >| >
| >| >Get Secure! www.microsoft.com/security
| >| >(This posting is provided "AS IS", with no warranties, and confers no
| >| >rights.)
| >| >
| >| >
| >| >
| >| >
| >| >--------------------
| >| >| NNTP-Posting-Date: Sun, 16 Oct 2005 15:23:11 -0500
| >| >| From: Russ <ru****@eticomm.net>
| >| >| Newsgroups: microsoft.public.dotnet.general
| >| >| Subject: Permission Errors
| >| >| Date: Sun, 16 Oct 2005 16:23:08 -0400
| >| >| Message-ID: <th********************************@4ax.com>
| >| >| X-Newsreader: Forte Agent 3.0/32.763
| >| >| MIME-Version: 1.0
| >| >| Content-Type: text/plain; charset=us-ascii
| >| >| Content-Transfer-Encoding: 7bit
| >| >| Lines: 19
| >| >| NNTP-Posting-Host: 68.37.155.53
| >| >| X-Trace:
| >|
|
sv3-WvRc+U+MgszlORlfxxo/gw1CB4QeCMbRWge6uJZfqu1poXRF9nyjO4sbT2RrSqItP0zWFP0
| >F
| >|
|ICfXpfc!IGA9Jyv54ErQe3Cjgk8eO4N7M2LAayvzLbN87cm pOB8GJxt0WNYj77Zlz6C4uKfEoYW
| >8
| >| >EeDeRHbG!47Nts75I
| >| >| X-Complaints-To: ab***@comcast.net
| >| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
headers
| >| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >| >complaint properly
| >| >| X-Postfilter: 1.3.32
| >| >| Path:
| >|
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tor nado.fastwebnet.it!tiscali!n
| >e
| >|
|wsfeed1.ip.tiscali.net!news.glorb.com!postnews. google.com!news4.google.com!
| >b
| >|
|order1.nntp.dca.giganews.com!nntp.giganews.com! local01.nntp.dca.giganews.c

o
| >m
| >| >!nntp.comcast.com!news.comcast.com.POSTED!not-for-mail
| >| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52108
| >| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >| >|
| >| >|
| >| >| Hello. My new dev machine is running XP Pro. In the past all
| >| >| equipment has only used Windows 2000. I have had a lot of problems
| >| >| getting my projects up and running on the new machine. The current
| >| >| one is a permission error.
| >| >|
| >| >| The project is a VC++ Web Service. It works fine when the service
is
| >| >| hosted on the old W2K dev machine, but on the new XP machine I get a
| >| >| permission error when the service tries to open a text file on the
| >| >| Windows 2000 domain server. It is a standard fopen call across the
| >| >| LAN. I have no problem opening the file from Windows Explorer, or
| >| >| from a standard windows program on the XP machine, but with the Web
| >| >| Service, when running on the XP machine, the fopen call returns NULL
| >| >| and GetNextError returns 5 - permission error.
| >| >|
| >| >| I cannot find any reason - any help?
| >| >|
| >| >| Thanks, Russ
| >| >|
| >| >|
| >|
|

Oct 24 '05 #9

P: n/a
Hi Russ,

Thanks for your response.
As you said that
============
The web service project exists on the
local workstation, not the server.
============
do you mean the webservice project's files and assemblies are on the
workstation machine and shared to remote boxes? I'm not quite sure on this
since you deployed the webservice to your new windows 2003 server, you
should also copy the files and assemblies there, didn't you?

Also, for domain controller, generally we do not recommend hosting asp.net
application on DC since DC has some restrictions such as not have local
accounts,..... Anyway, if you can start from create and run a simple
asp.net webservice on your new windows 2003 server so as to makesure the
asp.net framework and IIS works correctly. Then, we can continue to focus
on your specific project.

Please let me know if you have any questions.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| NNTP-Posting-Date: Mon, 24 Oct 2005 12:59:22 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Mon, 24 Oct 2005 13:59:18 -0400
| Message-ID: <pu********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
<d4********************************@4ax.com>
<4u**************@TK2MSFTNGXA01.phx.gbl>
<nc********************************@4ax.com>
<xt**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 401
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-mnWgmMZzSDgLc0dibOaGmDNtZP69cTDQlc3dngXWYcw4k0qJXO fG1sWSf3HLLJNh3hCvTzmI
e3Bucmc!CRFb1C/9kkVDy0wpDnOrXPLBGWeNLui/9utwvtcS9YNztk63oX2WPMPyWnCufQJZB7kt
G589JJzw!ujIEjHcT
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
ne.de!border2.nntp.dca.giganews.com!border1.nntp.d ca.giganews.com!nntp.gigan
ews.com!local01.nntp.dca.giganews.com!nntp.comcast .com!news.comcast.com.POST
ED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52690
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| Steven, thanks for your reply. The web service project exists on the
| local workstation, not the server. It was working when I had the old
| server running, both when running the web service on the local
| workstation and when deployed to the W2K server.
|
| Now it works on neither - and as far as I know I did not change
| anything at the workstation. As well as I can understand, the server
| should not have any effect on starting the project on the work
| station. Once the service is running on the workstation, then it
| needs the server in order to locate some data files, but the project
| should still start, even if the server was shut down. Right???
|
| And all I did was to set up a new server and remove the old one.
| Incidentally, if I copy the service to the new server and try to run
| it there, I get the same error. It seems that something has changed
| in one of the project files, but I still don't have a clue what to
| look for.
|
| One last thing. The old server was a domain server and I set up the
| new one to be a domain server with the same domain name. After the
| 2003 server was up, I removed the workstation from the domain, making
| it a workgroup computer, and then joined the domain again, to be sure
| it was registered correctly with the new server. Later in my testing
| I started up the old server and sure enough the web service would run
| on it (but still not on the work station). Then I demoted the old W2K
| server down to a workgroup computer, and then joined it to the new
| domain. At that point the web service no longer works on the W2K
| server either!
|
| Please try to make some sense of this for me - I haven't a clue!
|
| Thanks, Russ
|
| On Mon, 24 Oct 2005 04:39:22 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >As for the new problem you mentioned, it is likely caused by some
| >deployment setting.
| >The "XXXX.Global " is a class , and generally each ASP.NET application
| >will have one(or using the default if we don't explicitly provide one).
| >When using VS.NET IDE to create the asp.net project, it'll
automatically
| >add such a global class. However, the error message you met is not
| >specific to the global class, it indicate that your asp.net
| >application(webservice) can not find the certain class (assembly) it
| >requires.(generally global class is the first class which need to be
loaded
| >into runtime...).
| >
| >So on your new 2003 server, go to your webservice(PayrollEntryService)'s
| >application dir, and check the private "bin" sub dir to see whether all
the
| >webservice's assemblies are in the "bin" dir.
| >
| >If the assemblies are all existing, then make sure your application's
| >physical dir is located in a public place (not a user specific one , for
| >example under document settings\username......) so that the ASP.NET
process
| >identity can successfully access them.
| >
| >Also, above all , you need to makesure a normal asp.net
| >application(webservice) can run correctly (hosted in IIS). If there're
| >anything unclear, please feel free to post here.
| >
| >Thanks,
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Fri, 21 Oct 2005 14:22:25 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Re: Permission Errors
| >| Date: Fri, 21 Oct 2005 15:22:06 -0400
| >| Message-ID: <nc********************************@4ax.com>
| >| References: <th********************************@4ax.com>
| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| ><d4********************************@4ax.com>
| ><4u**************@TK2MSFTNGXA01.phx.gbl>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 253
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-nXJenZUWWBgFZCR9vAHhVQLHt3Ar8sodPe/9DYkFMD06e5++XOLGolXHkMgGuBK9UwTQG3M J
|uOW6yvi!Oh4nJ9x+wxOR0neSTmsAJJ2RUlucT5voq4zjyjd 5/cH6Ik6BJ4XkBaGpD25dXcsAPmo o
| >ArLXAoie!/vUojs8u
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfe ed00.sul.t-online.de!t-onl i
|ne.de!border2.nntp.dca.giganews.com!border1.nntp. dca.giganews.com!nntp.giga n
|ews.com!local01.nntp.dca.giganews.com!nntp.comcas t.com!news.comcast.com.POS T
| >ED!not-for-mail
| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52567
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >| Steven, I have now a different program that is keeping me from even
| >| getting back to the issue we were discussing. I installed the new
| >| Windows 2003 server but suddenly I cannot get the web service to work,
| >| either on the new server or even on the XP workstation. As far as I
| >| know I did not change anything on the workstation, but maybe something
| >| happened by accident. Anyway whenever I try to run the service I get
| >| the following error screen, which is rather cryptic as I cannot figure
| >| out what to do.
| >|
| >| My first question is: what is "PayrollEntryService.Global"? Is it a
| >| file, a class, or what. How do I find it and what do I do to make
| >| sure it is loadable?
| >|
| >| Thanks, Russ
| >|
| >|
| >| Server Error in '/PayrollEntryService' Application.
| >|
|--------------------------------------------------------------------------- -
| >----
| >|
| >| Parser Error
| >| Description: An error occurred during the parsing of a resource
| >| required to service this request. Please review the following specific
| >| parse error details and modify your source file appropriately.
| >|
| >| Parser Error Message: Could not load type
| >| 'PayrollEntryService.Global'.
| >|
| >| Source Error:
| >|
| >|
| >| Line 1: <%@ Application Codebehind="Global.asax.h"
| >| Inherits="PayrollEntryService.Global" %>
| >|
| >|
| >|
| >| Source File: C:\PssDev\PayrollEntryService\global.asax Line: 1
| >|
| >|
| >|
|---------------------------------------------------------------------------

-
| >----
| >| Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
| >| ASP.NET Version:1.1.4322.2032
| >|
| >| On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
| >| Cheng[MSFT]) wrote:
| >|
| >| >Hi Russ,
| >| >
| >| >Thanks for your response.
| >| >As you mentioned that you've use the following configuration in
| >web.config
| >| > <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >| >password="xxx" />
| >| >
| >| >that means the webservice will running under the impersonate
idenitity.
| >| >Also, the "xps.PrsNj.local\Russ" is a local account on the XP
machine,
| >yes?
| >| > If so, it is not remotable to other remote machines. Are the xp
client
| >| >machine and win2k box in a domain
| >| >environment? If so , you can try configured the webservice to running
| >under
| >| >a domain account so that it can be validated on the win2k server
| >machine.
| >| >
| >| >In addition, is there SQLserver on the win2k box? If so, you can try
let
| >| >the webservice make connection to sqlserver so that you can watch
which
| >| >cilent account is logon at the server (through the SQLserver
profiler).
| >If
| >| >no sqlserver available, you can try turning on the NTFS security
audit
| >on
| >| >that shared folder at the 2k server machine. Thus , we can watch
audit
| >log
| >| >to check the client account also.
| >| >
| >| >Thanks,
| >| >
| >| >Steven Cheng
| >| >Microsoft Online Support
| >| >
| >| >Get Secure! www.microsoft.com/security
| >| >(This posting is provided "AS IS", with no warranties, and confers no
| >| >rights.)
| >| >
| >| >
| >| >
| >| >--------------------
| >| >| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| >| >| From: Russ <ru****@eticomm.net>
| >| >| Newsgroups: microsoft.public.dotnet.general
| >| >| Subject: Re: Permission Errors
| >| >| Date: Mon, 17 Oct 2005 09:42:38 -0400
| >| >| Message-ID: <d4********************************@4ax.com>
| >| >| References: <th********************************@4ax.com>
| >| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >| >| X-Newsreader: Forte Agent 3.0/32.763
| >| >| MIME-Version: 1.0
| >| >| Content-Type: text/plain; charset=us-ascii
| >| >| Content-Transfer-Encoding: 7bit
| >| >| Lines: 126
| >| >| NNTP-Posting-Host: 68.37.155.53
| >| >| X-Trace:
| >|
|
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj 4
| >x
| >|
|XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26 I
| >P
| >| >8Kdp9Ub8!SFDYpnTo
| >| >| X-Complaints-To: ab***@comcast.net
| >| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
headers
| >| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >| >complaint properly
| >| >| X-Postfilter: 1.3.32
| >| >| Path:
| >|
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!torn ado.fastwebnet.it!tiscali! n
| >e
| >|
|wsfeed1.ip.tiscali.net!proxad.net!216.239.36.134 .MISMATCH!postnews.google. c
| >o
| >|
|m!news4.google.com!border1.nntp.dca.giganews.com !nntp.giganews.com!local01

Oct 25 '05 #10

P: n/a
Steven, responses interspersed:
Hi Russ,

Thanks for your response. As you said that
============
The web service project exists on the
local workstation, not the server.
============
do you mean the webservice project's files and assemblies are on the
workstation machine and shared to remote boxes? I'm not quite sure on this
since you deployed the webservice to your new windows 2003 server, you
should also copy the files and assemblies there, didn't you?
The web service was my first ASP.NET project. When I started the
project, visual studio automatically selected my work station as the
place where the project files would reside. I could build and host
the web service on the W2K work station with no problem. But once the
project was built and debugged I had to deploy it to the W2K server
for further testing with the ASP.NET client. So I built a deployment
project and that worked fine.

The problem now is that the web service will not run, whether it is
hosted on the XP work station, or on the new 2003 server. I always
get the error message:
Parser Error Message: Could not load type
'PayrollEntryService.Global'.
Am I correct in assuming that this problem has nothing to do with the
server, when I am trying to run or debug it on the work station?

Also, keep in mind that it was working on the work station at one
time. Then I removed the W2K server from service and set up the new
2003 server. I don't see any reason why that should have caused the
web service to stop working on the work station.

Also, for domain controller, generally we do not recommend hosting asp.net
application on DC since DC has some restrictions such as not have local
accounts,.....
This is not a problem for the usage that I need. And anyway the web
service was working fine on the W2K domain server.

Anyway, if you can start from create and run a simple
asp.net webservice on your new windows 2003 server so as to makesure the
asp.net framework and IIS works correctly. Then, we can continue to focus
on your specific project.
Ok, I understand. I will actually do that on the work station first.

I will do it today and let you know what I find out.

Thanks, Russ

Please let me know if you have any questions.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| NNTP-Posting-Date: Mon, 24 Oct 2005 12:59:22 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Mon, 24 Oct 2005 13:59:18 -0400
| Message-ID: <pu********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
<d4********************************@4ax.com>
<4u**************@TK2MSFTNGXA01.phx.gbl>
<nc********************************@4ax.com>
<xt**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 401
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-mnWgmMZzSDgLc0dibOaGmDNtZP69cTDQlc3dngXWYcw4k0qJXO fG1sWSf3HLLJNh3hCvTzmI
e3Bucmc!CRFb1C/9kkVDy0wpDnOrXPLBGWeNLui/9utwvtcS9YNztk63oX2WPMPyWnCufQJZB7kt
G589JJzw!ujIEjHcT
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfe ed00.sul.t-online.de!t-onli
ne.de!border2.nntp.dca.giganews.com!border1.nntp. dca.giganews.com!nntp.gigan
ews.com!local01.nntp.dca.giganews.com!nntp.comcas t.com!news.comcast.com.POST
ED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52690
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| Steven, thanks for your reply. The web service project exists on the
| local workstation, not the server. It was working when I had the old
| server running, both when running the web service on the local
| workstation and when deployed to the W2K server.
|
| Now it works on neither - and as far as I know I did not change
| anything at the workstation. As well as I can understand, the server
| should not have any effect on starting the project on the work
| station. Once the service is running on the workstation, then it
| needs the server in order to locate some data files, but the project
| should still start, even if the server was shut down. Right???
|
| And all I did was to set up a new server and remove the old one.
| Incidentally, if I copy the service to the new server and try to run
| it there, I get the same error. It seems that something has changed
| in one of the project files, but I still don't have a clue what to
| look for.
|
| One last thing. The old server was a domain server and I set up the
| new one to be a domain server with the same domain name. After the
| 2003 server was up, I removed the workstation from the domain, making
| it a workgroup computer, and then joined the domain again, to be sure
| it was registered correctly with the new server. Later in my testing
| I started up the old server and sure enough the web service would run
| on it (but still not on the work station). Then I demoted the old W2K
| server down to a workgroup computer, and then joined it to the new
| domain. At that point the web service no longer works on the W2K
| server either!
|
| Please try to make some sense of this for me - I haven't a clue!
|
| Thanks, Russ
|
| On Mon, 24 Oct 2005 04:39:22 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >As for the new problem you mentioned, it is likely caused by some
| >deployment setting.
| >The "XXXX.Global " is a class , and generally each ASP.NET application
| >will have one(or using the default if we don't explicitly provide one).
| >When using VS.NET IDE to create the asp.net project, it'll
automatically
| >add such a global class. However, the error message you met is not
| >specific to the global class, it indicate that your asp.net
| >application(webservice) can not find the certain class (assembly) it
| >requires.(generally global class is the first class which need to be
loaded
| >into runtime...).
| >
| >So on your new 2003 server, go to your webservice(PayrollEntryService)'s
| >application dir, and check the private "bin" sub dir to see whether all
the
| >webservice's assemblies are in the "bin" dir.
| >
| >If the assemblies are all existing, then make sure your application's
| >physical dir is located in a public place (not a user specific one , for
| >example under document settings\username......) so that the ASP.NET
process
| >identity can successfully access them.
| >
| >Also, above all , you need to makesure a normal asp.net
| >application(webservice) can run correctly (hosted in IIS). If there're
| >anything unclear, please feel free to post here.
| >
| >Thanks,
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Fri, 21 Oct 2005 14:22:25 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Re: Permission Errors
| >| Date: Fri, 21 Oct 2005 15:22:06 -0400
| >| Message-ID: <nc********************************@4ax.com>
| >| References: <th********************************@4ax.com>
| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| ><d4********************************@4ax.com>
| ><4u**************@TK2MSFTNGXA01.phx.gbl>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 253
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-nXJenZUWWBgFZCR9vAHhVQLHt3Ar8sodPe/9DYkFMD06e5++XOLGolXHkMgGuBK9UwTQG3M

J
|
uOW6yvi!Oh4nJ9x+wxOR0neSTmsAJJ2RUlucT5voq4zjyj d5/cH6Ik6BJ4XkBaGpD25dXcsAPmo

o
| >ArLXAoie!/vUojs8u
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsf eed00.sul.t-online.de!t-onl

i
|
ne.de!border2.nntp.dca.giganews.com!border1.nntp .dca.giganews.com!nntp.giga

n
|
ews.com!local01.nntp.dca.giganews.com!nntp.comca st.com!news.comcast.com.POS

T
| >ED!not-for-mail
| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52567
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >| Steven, I have now a different program that is keeping me from even
| >| getting back to the issue we were discussing. I installed the new
| >| Windows 2003 server but suddenly I cannot get the web service to work,
| >| either on the new server or even on the XP workstation. As far as I
| >| know I did not change anything on the workstation, but maybe something
| >| happened by accident. Anyway whenever I try to run the service I get
| >| the following error screen, which is rather cryptic as I cannot figure
| >| out what to do.
| >|
| >| My first question is: what is "PayrollEntryService.Global"? Is it a
| >| file, a class, or what. How do I find it and what do I do to make
| >| sure it is loadable?
| >|
| >| Thanks, Russ
| >|
| >|
| >| Server Error in '/PayrollEntryService' Application.
| >|
|
---------------------------------------------------------------------------

-
| >----
| >|
| >| Parser Error
| >| Description: An error occurred during the parsing of a resource
| >| required to service this request. Please review the following specific
| >| parse error details and modify your source file appropriately.
| >|
| >| Parser Error Message: Could not load type
| >| 'PayrollEntryService.Global'.
| >|
| >| Source Error:
| >|
| >|
| >| Line 1: <%@ Application Codebehind="Global.asax.h"
| >| Inherits="PayrollEntryService.Global" %>
| >|
| >|
| >|
| >| Source File: C:\PssDev\PayrollEntryService\global.asax Line: 1
| >|
| >|
| >|
|
---------------------------------------------------------------------------

-
| >----
| >| Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
| >| ASP.NET Version:1.1.4322.2032
| >|
| >| On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
| >| Cheng[MSFT]) wrote:
| >|
| >| >Hi Russ,
| >| >
| >| >Thanks for your response.
| >| >As you mentioned that you've use the following configuration in
| >web.config
| >| > <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >| >password="xxx" />
| >| >
| >| >that means the webservice will running under the impersonate
idenitity.
| >| >Also, the "xps.PrsNj.local\Russ" is a local account on the XP
machine,
| >yes?
| >| > If so, it is not remotable to other remote machines. Are the xp
client
| >| >machine and win2k box in a domain
| >| >environment? If so , you can try configured the webservice to running
| >under
| >| >a domain account so that it can be validated on the win2k server
| >machine.
| >| >
| >| >In addition, is there SQLserver on the win2k box? If so, you can try
let
| >| >the webservice make connection to sqlserver so that you can watch
which
| >| >cilent account is logon at the server (through the SQLserver
profiler).
| >If
| >| >no sqlserver available, you can try turning on the NTFS security
audit
| >on
| >| >that shared folder at the 2k server machine. Thus , we can watch
audit
| >log
| >| >to check the client account also.
| >| >
| >| >Thanks,
| >| >
| >| >Steven Cheng
| >| >Microsoft Online Support
| >| >
| >| >Get Secure! www.microsoft.com/security
| >| >(This posting is provided "AS IS", with no warranties, and confers no
| >| >rights.)
| >| >
| >| >
| >| >
| >| >--------------------
| >| >| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| >| >| From: Russ <ru****@eticomm.net>
| >| >| Newsgroups: microsoft.public.dotnet.general
| >| >| Subject: Re: Permission Errors
| >| >| Date: Mon, 17 Oct 2005 09:42:38 -0400
| >| >| Message-ID: <d4********************************@4ax.com>
| >| >| References: <th********************************@4ax.com>
| >| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >| >| X-Newsreader: Forte Agent 3.0/32.763
| >| >| MIME-Version: 1.0
| >| >| Content-Type: text/plain; charset=us-ascii
| >| >| Content-Transfer-Encoding: 7bit
| >| >| Lines: 126
| >| >| NNTP-Posting-Host: 68.37.155.53
| >| >| X-Trace:
| >|
|
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj4
| >x
| >|
|XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26I
| >P
| >| >8Kdp9Ub8!SFDYpnTo
| >| >| X-Complaints-To: ab***@comcast.net
| >| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
headers
| >| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >| >complaint properly
| >| >| X-Postfilter: 1.3.32
| >| >| Path:
| >|
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!tor nado.fastwebnet.it!tiscali!n
| >e
| >|
|wsfeed1.ip.tiscali.net!proxad.net!216.239.36.13 4.MISMATCH!postnews.google.c
| >o
| >|
|m!news4.google.com!border1.nntp.dca.giganews.co m!nntp.giganews.com!local01

Oct 25 '05 #11

P: n/a
Ok, I built the TempConvert3 sample web service on the XP work
station. It works fine.

I then compared the files with the same files of my web service that
does not work. I could not find anything that looks suspicious. Of
course I have added a lot of code and additional files in my web
service. I especially looked at global.asax.h and found no
differences except in the name of the namespace.

.... well I have it all working now! After I wrote the above, I looked
at IIS manager and noticed a difference in the local path. For the
TempConvert3 web it showed the path as "\TempConvert3", but for my
service the path was "C:\PssDev\PayrollEntryService". I then deleted
PayrollEntryService from IIS, and then cleaned/built the project in
Visual Studio again. When it deployed, I looked in IIS again and the
path was now "\PayrollEntryService". And my web service now works on
the XP machine - hooray!

Next I looked at the 2003 server and saw that the local path was
similarly wrong. I deleted it from IIS and then rebuilt the service
setup project, and then deployed it on the server. The local path was
now right and the service runs on the server now.

Finally I tested the original problem - the problem that the service
could not open files on the server when the service was running on the
XP work station. All seems ok now as long as I impersonate a user on
the XP workstation when running on that machine, and impersonate a
user on the server when running on that machine.

I sure don't know how things got so screwed up, but I surely
appreciate all the time you have taken to help me Steven. I think I
can finally get back to working on the project again now.

Thanks again, Russ

On Tue, 25 Oct 2005 14:27:04 -0400, Russ <ru****@eticomm.net> wrote:
Steven, responses interspersed:
Hi Russ,

Thanks for your response. As you said that
============
The web service project exists on the
local workstation, not the server.
============
do you mean the webservice project's files and assemblies are on the
workstation machine and shared to remote boxes? I'm not quite sure on this
since you deployed the webservice to your new windows 2003 server, you
should also copy the files and assemblies there, didn't you?


The web service was my first ASP.NET project. When I started the
project, visual studio automatically selected my work station as the
place where the project files would reside. I could build and host
the web service on the W2K work station with no problem. But once the
project was built and debugged I had to deploy it to the W2K server
for further testing with the ASP.NET client. So I built a deployment
project and that worked fine.

The problem now is that the web service will not run, whether it is
hosted on the XP work station, or on the new 2003 server. I always
get the error message:
Parser Error Message: Could not load type
'PayrollEntryService.Global'.


Am I correct in assuming that this problem has nothing to do with the
server, when I am trying to run or debug it on the work station?

Also, keep in mind that it was working on the work station at one
time. Then I removed the W2K server from service and set up the new
2003 server. I don't see any reason why that should have caused the
web service to stop working on the work station.

Also, for domain controller, generally we do not recommend hosting asp.net
application on DC since DC has some restrictions such as not have local
accounts,.....


This is not a problem for the usage that I need. And anyway the web
service was working fine on the W2K domain server.

Anyway, if you can start from create and run a simple
asp.net webservice on your new windows 2003 server so as to makesure the
asp.net framework and IIS works correctly. Then, we can continue to focus
on your specific project.


Ok, I understand. I will actually do that on the work station first.

I will do it today and let you know what I find out.

Thanks, Russ

Please let me know if you have any questions.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| NNTP-Posting-Date: Mon, 24 Oct 2005 12:59:22 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Mon, 24 Oct 2005 13:59:18 -0400
| Message-ID: <pu********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
<d4********************************@4ax.com>
<4u**************@TK2MSFTNGXA01.phx.gbl>
<nc********************************@4ax.com>
<xt**************@TK2MSFTNGXA01.phx.gbl>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 401
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-mnWgmMZzSDgLc0dibOaGmDNtZP69cTDQlc3dngXWYcw4k0qJXO fG1sWSf3HLLJNh3hCvTzmI
e3Bucmc!CRFb1C/9kkVDy0wpDnOrXPLBGWeNLui/9utwvtcS9YNztk63oX2WPMPyWnCufQJZB7kt
G589JJzw!ujIEjHcT
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsf eed00.sul.t-online.de!t-onli
ne.de!border2.nntp.dca.giganews.com!border1.nntp .dca.giganews.com!nntp.gigan
ews.com!local01.nntp.dca.giganews.com!nntp.comca st.com!news.comcast.com.POST
ED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52690
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| Steven, thanks for your reply. The web service project exists on the
| local workstation, not the server. It was working when I had the old
| server running, both when running the web service on the local
| workstation and when deployed to the W2K server.
|
| Now it works on neither - and as far as I know I did not change
| anything at the workstation. As well as I can understand, the server
| should not have any effect on starting the project on the work
| station. Once the service is running on the workstation, then it
| needs the server in order to locate some data files, but the project
| should still start, even if the server was shut down. Right???
|
| And all I did was to set up a new server and remove the old one.
| Incidentally, if I copy the service to the new server and try to run
| it there, I get the same error. It seems that something has changed
| in one of the project files, but I still don't have a clue what to
| look for.
|
| One last thing. The old server was a domain server and I set up the
| new one to be a domain server with the same domain name. After the
| 2003 server was up, I removed the workstation from the domain, making
| it a workgroup computer, and then joined the domain again, to be sure
| it was registered correctly with the new server. Later in my testing
| I started up the old server and sure enough the web service would run
| on it (but still not on the work station). Then I demoted the old W2K
| server down to a workgroup computer, and then joined it to the new
| domain. At that point the web service no longer works on the W2K
| server either!
|
| Please try to make some sense of this for me - I haven't a clue!
|
| Thanks, Russ
|
| On Mon, 24 Oct 2005 04:39:22 GMT, st*****@online.microsoft.com (Steven
| Cheng[MSFT]) wrote:
|
| >Hi Russ,
| >
| >As for the new problem you mentioned, it is likely caused by some
| >deployment setting.
| >The "XXXX.Global " is a class , and generally each ASP.NET application
| >will have one(or using the default if we don't explicitly provide one).
| >When using VS.NET IDE to create the asp.net project, it'll
automatically
| >add such a global class. However, the error message you met is not
| >specific to the global class, it indicate that your asp.net
| >application(webservice) can not find the certain class (assembly) it
| >requires.(generally global class is the first class which need to be
loaded
| >into runtime...).
| >
| >So on your new 2003 server, go to your webservice(PayrollEntryService)'s
| >application dir, and check the private "bin" sub dir to see whether all
the
| >webservice's assemblies are in the "bin" dir.
| >
| >If the assemblies are all existing, then make sure your application's
| >physical dir is located in a public place (not a user specific one , for
| >example under document settings\username......) so that the ASP.NET
process
| >identity can successfully access them.
| >
| >Also, above all , you need to makesure a normal asp.net
| >application(webservice) can run correctly (hosted in IIS). If there're
| >anything unclear, please feel free to post here.
| >
| >Thanks,
| >Steven Cheng
| >Microsoft Online Support
| >
| >Get Secure! www.microsoft.com/security
| >(This posting is provided "AS IS", with no warranties, and confers no
| >rights.)
| >
| >
| >
| >
| >--------------------
| >| NNTP-Posting-Date: Fri, 21 Oct 2005 14:22:25 -0500
| >| From: Russ <ru****@eticomm.net>
| >| Newsgroups: microsoft.public.dotnet.general
| >| Subject: Re: Permission Errors
| >| Date: Fri, 21 Oct 2005 15:22:06 -0400
| >| Message-ID: <nc********************************@4ax.com>
| >| References: <th********************************@4ax.com>
| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| ><d4********************************@4ax.com>
| ><4u**************@TK2MSFTNGXA01.phx.gbl>
| >| X-Newsreader: Forte Agent 3.0/32.763
| >| MIME-Version: 1.0
| >| Content-Type: text/plain; charset=us-ascii
| >| Content-Transfer-Encoding: 7bit
| >| Lines: 253
| >| NNTP-Posting-Host: 68.37.155.53
| >| X-Trace:
|
sv3-nXJenZUWWBgFZCR9vAHhVQLHt3Ar8sodPe/9DYkFMD06e5++XOLGolXHkMgGuBK9UwTQG3M

J
|
uOW6yvi!Oh4nJ9x+wxOR0neSTmsAJJ2RUlucT5voq4zjyjd 5/cH6Ik6BJ4XkBaGpD25dXcsAPmo

o
| >ArLXAoie!/vUojs8u
| >| X-Complaints-To: ab***@comcast.net
| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >complaint properly
| >| X-Postfilter: 1.3.32
| >| Path:
|
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!news feed00.sul.t-online.de!t-onl

i
|
ne.de!border2.nntp.dca.giganews.com!border1.nnt p.dca.giganews.com!nntp.giga

n
|
ews.com!local01.nntp.dca.giganews.com!nntp.comc ast.com!news.comcast.com.POS

T
| >ED!not-for-mail
| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52567
| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >|
| >| Steven, I have now a different program that is keeping me from even
| >| getting back to the issue we were discussing. I installed the new
| >| Windows 2003 server but suddenly I cannot get the web service to work,
| >| either on the new server or even on the XP workstation. As far as I
| >| know I did not change anything on the workstation, but maybe something
| >| happened by accident. Anyway whenever I try to run the service I get
| >| the following error screen, which is rather cryptic as I cannot figure
| >| out what to do.
| >|
| >| My first question is: what is "PayrollEntryService.Global"? Is it a
| >| file, a class, or what. How do I find it and what do I do to make
| >| sure it is loadable?
| >|
| >| Thanks, Russ
| >|
| >|
| >| Server Error in '/PayrollEntryService' Application.
| >|
|
---------------------------------------------------------------------------

-
| >----
| >|
| >| Parser Error
| >| Description: An error occurred during the parsing of a resource
| >| required to service this request. Please review the following specific
| >| parse error details and modify your source file appropriately.
| >|
| >| Parser Error Message: Could not load type
| >| 'PayrollEntryService.Global'.
| >|
| >| Source Error:
| >|
| >|
| >| Line 1: <%@ Application Codebehind="Global.asax.h"
| >| Inherits="PayrollEntryService.Global" %>
| >|
| >|
| >|
| >| Source File: C:\PssDev\PayrollEntryService\global.asax Line: 1
| >|
| >|
| >|
|
---------------------------------------------------------------------------

-
| >----
| >| Version Information: Microsoft .NET Framework Version:1.1.4322.2032;
| >| ASP.NET Version:1.1.4322.2032
| >|
| >| On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com (Steven
| >| Cheng[MSFT]) wrote:
| >|
| >| >Hi Russ,
| >| >
| >| >Thanks for your response.
| >| >As you mentioned that you've use the following configuration in
| >web.config
| >| > <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >| >password="xxx" />
| >| >
| >| >that means the webservice will running under the impersonate
idenitity.
| >| >Also, the "xps.PrsNj.local\Russ" is a local account on the XP
machine,
| >yes?
| >| > If so, it is not remotable to other remote machines. Are the xp
client
| >| >machine and win2k box in a domain
| >| >environment? If so , you can try configured the webservice to running
| >under
| >| >a domain account so that it can be validated on the win2k server
| >machine.
| >| >
| >| >In addition, is there SQLserver on the win2k box? If so, you can try
let
| >| >the webservice make connection to sqlserver so that you can watch
which
| >| >cilent account is logon at the server (through the SQLserver
profiler).
| >If
| >| >no sqlserver available, you can try turning on the NTFS security
audit
| >on
| >| >that shared folder at the 2k server machine. Thus , we can watch
audit
| >log
| >| >to check the client account also.
| >| >
| >| >Thanks,
| >| >
| >| >Steven Cheng
| >| >Microsoft Online Support
| >| >
| >| >Get Secure! www.microsoft.com/security
| >| >(This posting is provided "AS IS", with no warranties, and confers no
| >| >rights.)
| >| >
| >| >
| >| >
| >| >--------------------
| >| >| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| >| >| From: Russ <ru****@eticomm.net>
| >| >| Newsgroups: microsoft.public.dotnet.general
| >| >| Subject: Re: Permission Errors
| >| >| Date: Mon, 17 Oct 2005 09:42:38 -0400
| >| >| Message-ID: <d4********************************@4ax.com>
| >| >| References: <th********************************@4ax.com>
| >| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >| >| X-Newsreader: Forte Agent 3.0/32.763
| >| >| MIME-Version: 1.0
| >| >| Content-Type: text/plain; charset=us-ascii
| >| >| Content-Transfer-Encoding: 7bit
| >| >| Lines: 126
| >| >| NNTP-Posting-Host: 68.37.155.53
| >| >| X-Trace:
| >|
|
sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0Sj

4
| >x
| >|
|
XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J26

I
| >P
| >| >8Kdp9Ub8!SFDYpnTo
| >| >| X-Complaints-To: ab***@comcast.net
| >| >| X-DMCA-Complaints-To: dm**@comcast.net
| >| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
headers
| >| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >| >complaint properly
| >| >| X-Postfilter: 1.3.32
| >| >| Path:
| >|
|
TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!to rnado.fastwebnet.it!tiscali!

n
| >e
| >|
|
wsfeed1.ip.tiscali.net!proxad.net!216.239.36.1 34.MISMATCH!postnews.google.

c
| >o
| >|
|
m!news4.google.com!border1.nntp.dca.giganews.c om!nntp.giganews.com!local01

Oct 25 '05 #12

P: n/a
Hi Russ,

Really glad that you've got things working again. Some further comments
below:

As for the "\TempConvert3" path in IIS manager, it indicate the physical
path of the virtual directory. For those virtual directories whose path is
just under the default inetpub\wwwroot, the path is like:

"\XXXsubpathname"

If the physical path of the virtual dir is not under wwwroot, it'll need to
be specified as full path like;

"d:\webfolder\myapp"

So when we move a webproject to a new server (creating the new virtual
directory for it on the new server), we need to make sure the path is also
updated to the new physical location on the new server.

Anyway thanks again for your posting. Always welcome when you meet any
problem.

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| NNTP-Posting-Date: Tue, 25 Oct 2005 16:33:53 -0500
| From: Russ <ru****@eticomm.net>
| Newsgroups: microsoft.public.dotnet.general
| Subject: Re: Permission Errors
| Date: Tue, 25 Oct 2005 17:34:07 -0400
| Message-ID: <57********************************@4ax.com>
| References: <th********************************@4ax.com>
<yI**************@TK2MSFTNGXA01.phx.gbl>
<d4********************************@4ax.com>
<4u**************@TK2MSFTNGXA01.phx.gbl>
<nc********************************@4ax.com>
<xt**************@TK2MSFTNGXA01.phx.gbl>
<pu********************************@4ax.com>
<zU**************@TK2MSFTNGXA01.phx.gbl>
<nc********************************@4ax.com>
| X-Newsreader: Forte Agent 3.0/32.763
| MIME-Version: 1.0
| Content-Type: text/plain; charset=us-ascii
| Content-Transfer-Encoding: 7bit
| Lines: 415
| NNTP-Posting-Host: 68.37.155.53
| X-Trace:
sv3-LqLh1Gv0FhKollbANUwXP+jOcniU/lYmpor8sgSono4gZiurKYb7YfWana1LnJVv+5Kgruh7
/E5qL8l!EIEIdaRQ2sat71zPr5A50eQFF00y2MFhVwR8mLWu4/b+D0kp/PlSyu3zI5rcBnci2+zt
pSD7sMlL!Z0iYV6KU
| X-Complaints-To: ab***@comcast.net
| X-DMCA-Complaints-To: dm**@comcast.net
| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
complaint properly
| X-Postfilter: 1.3.32
| Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
ne.de!border2.nntp.dca.giganews.com!border1.nntp.d ca.giganews.com!nntp.gigan
ews.com!local01.nntp.dca.giganews.com!nntp.comcast .com!news.comcast.com.POST
ED!not-for-mail
| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52823
| X-Tomcat-NG: microsoft.public.dotnet.general
|
| Ok, I built the TempConvert3 sample web service on the XP work
| station. It works fine.
|
| I then compared the files with the same files of my web service that
| does not work. I could not find anything that looks suspicious. Of
| course I have added a lot of code and additional files in my web
| service. I especially looked at global.asax.h and found no
| differences except in the name of the namespace.
|
| ... well I have it all working now! After I wrote the above, I looked
| at IIS manager and noticed a difference in the local path. For the
| TempConvert3 web it showed the path as "\TempConvert3", but for my
| service the path was "C:\PssDev\PayrollEntryService". I then deleted
| PayrollEntryService from IIS, and then cleaned/built the project in
| Visual Studio again. When it deployed, I looked in IIS again and the
| path was now "\PayrollEntryService". And my web service now works on
| the XP machine - hooray!
|
| Next I looked at the 2003 server and saw that the local path was
| similarly wrong. I deleted it from IIS and then rebuilt the service
| setup project, and then deployed it on the server. The local path was
| now right and the service runs on the server now.
|
| Finally I tested the original problem - the problem that the service
| could not open files on the server when the service was running on the
| XP work station. All seems ok now as long as I impersonate a user on
| the XP workstation when running on that machine, and impersonate a
| user on the server when running on that machine.
|
| I sure don't know how things got so screwed up, but I surely
| appreciate all the time you have taken to help me Steven. I think I
| can finally get back to working on the project again now.
|
| Thanks again, Russ
|
| On Tue, 25 Oct 2005 14:27:04 -0400, Russ <ru****@eticomm.net> wrote:
|
| >Steven, responses interspersed:
| >
| >>Hi Russ,
| >>
| >>Thanks for your response. As you said that
| >>============
| >> The web service project exists on the
| >>local workstation, not the server.
| >>============
| >>do you mean the webservice project's files and assemblies are on the
| >>workstation machine and shared to remote boxes? I'm not quite sure on
this
| >>since you deployed the webservice to your new windows 2003 server, you
| >>should also copy the files and assemblies there, didn't you?
| >
| >The web service was my first ASP.NET project. When I started the
| >project, visual studio automatically selected my work station as the
| >place where the project files would reside. I could build and host
| >the web service on the W2K work station with no problem. But once the
| >project was built and debugged I had to deploy it to the W2K server
| >for further testing with the ASP.NET client. So I built a deployment
| >project and that worked fine.
| >
| >The problem now is that the web service will not run, whether it is
| >hosted on the XP work station, or on the new 2003 server. I always
| >get the error message:
| >
| >> Parser Error Message: Could not load type
| >> 'PayrollEntryService.Global'.
| >
| >Am I correct in assuming that this problem has nothing to do with the
| >server, when I am trying to run or debug it on the work station?
| >
| >Also, keep in mind that it was working on the work station at one
| >time. Then I removed the W2K server from service and set up the new
| >2003 server. I don't see any reason why that should have caused the
| >web service to stop working on the work station.
| >
| >
| >>Also, for domain controller, generally we do not recommend hosting
asp.net
| >>application on DC since DC has some restrictions such as not have local
| >>accounts,.....
| >
| >This is not a problem for the usage that I need. And anyway the web
| >service was working fine on the W2K domain server.
| >
| >
| >> Anyway, if you can start from create and run a simple
| >>asp.net webservice on your new windows 2003 server so as to makesure
the
| >>asp.net framework and IIS works correctly. Then, we can continue to
focus
| >>on your specific project.
| >
| >Ok, I understand. I will actually do that on the work station first.
| >
| >I will do it today and let you know what I find out.
| >
| >Thanks, Russ
| >
| >>
| >>Please let me know if you have any questions.
| >>
| >>Thanks,
| >>
| >>Steven Cheng
| >>Microsoft Online Support
| >>
| >>Get Secure! www.microsoft.com/security
| >>(This posting is provided "AS IS", with no warranties, and confers no
| >>rights.)
| >>
| >>
| >>
| >>--------------------
| >>| NNTP-Posting-Date: Mon, 24 Oct 2005 12:59:22 -0500
| >>| From: Russ <ru****@eticomm.net>
| >>| Newsgroups: microsoft.public.dotnet.general
| >>| Subject: Re: Permission Errors
| >>| Date: Mon, 24 Oct 2005 13:59:18 -0400
| >>| Message-ID: <pu********************************@4ax.com>
| >>| References: <th********************************@4ax.com>
| >><yI**************@TK2MSFTNGXA01.phx.gbl>
| >><d4********************************@4ax.com>
| >><4u**************@TK2MSFTNGXA01.phx.gbl>
| >><nc********************************@4ax.com>
| >><xt**************@TK2MSFTNGXA01.phx.gbl>
| >>| X-Newsreader: Forte Agent 3.0/32.763
| >>| MIME-Version: 1.0
| >>| Content-Type: text/plain; charset=us-ascii
| >>| Content-Transfer-Encoding: 7bit
| >>| Lines: 401
| >>| NNTP-Posting-Host: 68.37.155.53
| >>| X-Trace:
|
sv3-mnWgmMZzSDgLc0dibOaGmDNtZP69cTDQlc3dngXWYcw4k0qJXO fG1sWSf3HLLJNh3hCvTz mI
|
e3Bucmc!CRFb1C/9kkVDy0wpDnOrXPLBGWeNLui/9utwvtcS9YNztk63oX2WPMPyWnCufQJZB7 kt
| >>G589JJzw!ujIEjHcT
| >>| X-Complaints-To: ab***@comcast.net
| >>| X-DMCA-Complaints-To: dm**@comcast.net
| >>| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
| >>| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >>complaint properly
| >>| X-Postfilter: 1.3.32
| >>| Path:
|TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsf eed00.sul.t-online.de!t-on li
|ne.de!border2.nntp.dca.giganews.com!border1.nntp .dca.giganews.com!nntp.gig an
|ews.com!local01.nntp.dca.giganews.com!nntp.comca st.com!news.comcast.com.PO

ST
| >>ED!not-for-mail
| >>| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52690
| >>| X-Tomcat-NG: microsoft.public.dotnet.general
| >>|
| >>| Steven, thanks for your reply. The web service project exists on the
| >>| local workstation, not the server. It was working when I had the old
| >>| server running, both when running the web service on the local
| >>| workstation and when deployed to the W2K server.
| >>|
| >>| Now it works on neither - and as far as I know I did not change
| >>| anything at the workstation. As well as I can understand, the server
| >>| should not have any effect on starting the project on the work
| >>| station. Once the service is running on the workstation, then it
| >>| needs the server in order to locate some data files, but the project
| >>| should still start, even if the server was shut down. Right???
| >>|
| >>| And all I did was to set up a new server and remove the old one.
| >>| Incidentally, if I copy the service to the new server and try to run
| >>| it there, I get the same error. It seems that something has changed
| >>| in one of the project files, but I still don't have a clue what to
| >>| look for.
| >>|
| >>| One last thing. The old server was a domain server and I set up the
| >>| new one to be a domain server with the same domain name. After the
| >>| 2003 server was up, I removed the workstation from the domain, making
| >>| it a workgroup computer, and then joined the domain again, to be sure
| >>| it was registered correctly with the new server. Later in my testing
| >>| I started up the old server and sure enough the web service would run
| >>| on it (but still not on the work station). Then I demoted the old W2K
| >>| server down to a workgroup computer, and then joined it to the new
| >>| domain. At that point the web service no longer works on the W2K
| >>| server either!
| >>|
| >>| Please try to make some sense of this for me - I haven't a clue!
| >>|
| >>| Thanks, Russ
| >>|
| >>| On Mon, 24 Oct 2005 04:39:22 GMT, st*****@online.microsoft.com (Steven
| >>| Cheng[MSFT]) wrote:
| >>|
| >>| >Hi Russ,
| >>| >
| >>| >As for the new problem you mentioned, it is likely caused by some
| >>| >deployment setting.
| >>| >The "XXXX.Global " is a class , and generally each ASP.NET
application
| >>| >will have one(or using the default if we don't explicitly provide
one).
| >>| >When using VS.NET IDE to create the asp.net project, it'll
| >>automatically
| >>| >add such a global class. However, the error message you met is not
| >>| >specific to the global class, it indicate that your asp.net
| >>| >application(webservice) can not find the certain class (assembly) it
| >>| >requires.(generally global class is the first class which need to be
| >>loaded
| >>| >into runtime...).
| >>| >
| >>| >So on your new 2003 server, go to your
webservice(PayrollEntryService)'s
| >>| >application dir, and check the private "bin" sub dir to see whether
all
| >>the
| >>| >webservice's assemblies are in the "bin" dir.
| >>| >
| >>| >If the assemblies are all existing, then make sure your
application's
| >>| >physical dir is located in a public place (not a user specific one ,
for
| >>| >example under document settings\username......) so that the ASP.NET
| >>process
| >>| >identity can successfully access them.
| >>| >
| >>| >Also, above all , you need to makesure a normal asp.net
| >>| >application(webservice) can run correctly (hosted in IIS). If
there're
| >>| >anything unclear, please feel free to post here.
| >>| >
| >>| >Thanks,
| >>| >Steven Cheng
| >>| >Microsoft Online Support
| >>| >
| >>| >Get Secure! www.microsoft.com/security
| >>| >(This posting is provided "AS IS", with no warranties, and confers
no
| >>| >rights.)
| >>| >
| >>| >
| >>| >
| >>| >
| >>| >--------------------
| >>| >| NNTP-Posting-Date: Fri, 21 Oct 2005 14:22:25 -0500
| >>| >| From: Russ <ru****@eticomm.net>
| >>| >| Newsgroups: microsoft.public.dotnet.general
| >>| >| Subject: Re: Permission Errors
| >>| >| Date: Fri, 21 Oct 2005 15:22:06 -0400
| >>| >| Message-ID: <nc********************************@4ax.com>
| >>| >| References: <th********************************@4ax.com>
| >>| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >>| ><d4********************************@4ax.com>
| >>| ><4u**************@TK2MSFTNGXA01.phx.gbl>
| >>| >| X-Newsreader: Forte Agent 3.0/32.763
| >>| >| MIME-Version: 1.0
| >>| >| Content-Type: text/plain; charset=us-ascii
| >>| >| Content-Transfer-Encoding: 7bit
| >>| >| Lines: 253
| >>| >| NNTP-Posting-Host: 68.37.155.53
| >>| >| X-Trace:
| >>|
|
sv3-nXJenZUWWBgFZCR9vAHhVQLHt3Ar8sodPe/9DYkFMD06e5++XOLGolXHkMgGuBK9UwTQG 3M
| >>J
| >>|
|uOW6yvi!Oh4nJ9x+wxOR0neSTmsAJJ2RUlucT5voq4zjyjd 5/cH6Ik6BJ4XkBaGpD25dXcsAP mo
| >>o
| >>| >ArLXAoie!/vUojs8u
| >>| >| X-Complaints-To: ab***@comcast.net
| >>| >| X-DMCA-Complaints-To: dm**@comcast.net
| >>| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
headers
| >>| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your
| >>| >complaint properly
| >>| >| X-Postfilter: 1.3.32
| >>| >| Path:
| >>|
|TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!news feed00.sul.t-online.de!t-o nl
| >>i
| >>|
|ne.de!border2.nntp.dca.giganews.com!border1.nnt p.dca.giganews.com!nntp.gi ga
| >>n
| >>|
|ews.com!local01.nntp.dca.giganews.com!nntp.comc ast.com!news.comcast.com.P OS
| >>T
| >>| >ED!not-for-mail
| >>| >| Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.dotnet.general:52567
| >>| >| X-Tomcat-NG: microsoft.public.dotnet.general
| >>| >|
| >>| >| Steven, I have now a different program that is keeping me from even
| >>| >| getting back to the issue we were discussing. I installed the new
| >>| >| Windows 2003 server but suddenly I cannot get the web service to
work,
| >>| >| either on the new server or even on the XP workstation. As far as
I
| >>| >| know I did not change anything on the workstation, but maybe
something
| >>| >| happened by accident. Anyway whenever I try to run the service I
get
| >>| >| the following error screen, which is rather cryptic as I cannot
figure
| >>| >| out what to do.
| >>| >|
| >>| >| My first question is: what is "PayrollEntryService.Global"? Is it
a
| >>| >| file, a class, or what. How do I find it and what do I do to make
| >>| >| sure it is loadable?
| >>| >|
| >>| >| Thanks, Russ
| >>| >|
| >>| >|
| >>| >| Server Error in '/PayrollEntryService' Application.
| >>| >|
| >>|
|------------------------------------------------------------------------- --
| >>-
| >>| >----
| >>| >|
| >>| >| Parser Error
| >>| >| Description: An error occurred during the parsing of a resource
| >>| >| required to service this request. Please review the following
specific
| >>| >| parse error details and modify your source file appropriately.
| >>| >|
| >>| >| Parser Error Message: Could not load type
| >>| >| 'PayrollEntryService.Global'.
| >>| >|
| >>| >| Source Error:
| >>| >|
| >>| >|
| >>| >| Line 1: <%@ Application Codebehind="Global.asax.h"
| >>| >| Inherits="PayrollEntryService.Global" %>
| >>| >|
| >>| >|
| >>| >|
| >>| >| Source File: C:\PssDev\PayrollEntryService\global.asax Line: 1
| >>| >|
| >>| >|
| >>| >|
| >>|
|------------------------------------------------------------------------- --
| >>-
| >>| >----
| >>| >| Version Information: Microsoft .NET Framework
Version:1.1.4322.2032;
| >>| >| ASP.NET Version:1.1.4322.2032
| >>| >|
| >>| >| On Wed, 19 Oct 2005 03:20:46 GMT, st*****@online.microsoft.com
(Steven
| >>| >| Cheng[MSFT]) wrote:
| >>| >|
| >>| >| >Hi Russ,
| >>| >| >
| >>| >| >Thanks for your response.
| >>| >| >As you mentioned that you've use the following configuration in
| >>| >web.config
| >>| >| > <identity impersonate="true" userName="xps.PrsNj.local\Russ"
| >>| >| >password="xxx" />
| >>| >| >
| >>| >| >that means the webservice will running under the impersonate
| >>idenitity.
| >>| >| >Also, the "xps.PrsNj.local\Russ" is a local account on the XP
| >>machine,
| >>| >yes?
| >>| >| > If so, it is not remotable to other remote machines. Are the xp
| >>client
| >>| >| >machine and win2k box in a domain
| >>| >| >environment? If so , you can try configured the webservice to
running
| >>| >under
| >>| >| >a domain account so that it can be validated on the win2k server
| >>| >machine.
| >>| >| >
| >>| >| >In addition, is there SQLserver on the win2k box? If so, you can
try
| >>let
| >>| >| >the webservice make connection to sqlserver so that you can watch
| >>which
| >>| >| >cilent account is logon at the server (through the SQLserver
| >>profiler).
| >>| >If
| >>| >| >no sqlserver available, you can try turning on the NTFS security
| >>audit
| >>| >on
| >>| >| >that shared folder at the 2k server machine. Thus , we can watch
| >>audit
| >>| >log
| >>| >| >to check the client account also.
| >>| >| >
| >>| >| >Thanks,
| >>| >| >
| >>| >| >Steven Cheng
| >>| >| >Microsoft Online Support
| >>| >| >
| >>| >| >Get Secure! www.microsoft.com/security
| >>| >| >(This posting is provided "AS IS", with no warranties, and
confers no
| >>| >| >rights.)
| >>| >| >
| >>| >| >
| >>| >| >
| >>| >| >--------------------
| >>| >| >| NNTP-Posting-Date: Mon, 17 Oct 2005 08:42:39 -0500
| >>| >| >| From: Russ <ru****@eticomm.net>
| >>| >| >| Newsgroups: microsoft.public.dotnet.general
| >>| >| >| Subject: Re: Permission Errors
| >>| >| >| Date: Mon, 17 Oct 2005 09:42:38 -0400
| >>| >| >| Message-ID: <d4********************************@4ax.com>
| >>| >| >| References: <th********************************@4ax.com>
| >>| >| ><yI**************@TK2MSFTNGXA01.phx.gbl>
| >>| >| >| X-Newsreader: Forte Agent 3.0/32.763
| >>| >| >| MIME-Version: 1.0
| >>| >| >| Content-Type: text/plain; charset=us-ascii
| >>| >| >| Content-Transfer-Encoding: 7bit
| >>| >| >| Lines: 126
| >>| >| >| NNTP-Posting-Host: 68.37.155.53
| >>| >| >| X-Trace:
| >>| >|
| >>|
|sv3-gDWyCGpEupEX0j1fSbjlcEQCmafJ9o78ImvcZFRYgzuTJrUVBX NwSDFvEjXU0WYIV5S0 Sj
| >>4
| >>| >x
| >>| >|
| >>|
|XAEYD4F!+gD1O9UCRQPn/fWaZqe5gZu0a+kJQob50YgYeH4Vz0b8yN5CDADz5iCAiAyr6i+ J 26
| >>I
| >>| >P
| >>| >| >8Kdp9Ub8!SFDYpnTo
| >>| >| >| X-Complaints-To: ab***@comcast.net
| >>| >| >| X-DMCA-Complaints-To: dm**@comcast.net
| >>| >| >| X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL
| >>headers
| >>| >| >| X-Abuse-and-DMCA-Info: Otherwise we will be unable to process
your
| >>| >| >complaint properly
| >>| >| >| X-Postfilter: 1.3.32
| >>| >| >| Path:
| >>| >|
| >>|
|TK2MSFTNGXA01.phx.gbl!TK2MSFTFEED02.phx.gbl!to rnado.fastwebnet.it!tiscal i!
| >>n
| >>| >e
| >>| >|
| >>|
|wsfeed1.ip.tiscali.net!proxad.net!216.239.36.1 34.MISMATCH!postnews.googl e.
| >>c
| >>| >o
| >>| >|
| >>|
|m!news4.google.com!border1.nntp.dca.giganews.c om!nntp.giganews.com!local

01
|

Oct 26 '05 #13

This discussion thread is closed

Replies have been disabled for this discussion.