471,339 Members | 1,246 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,339 software developers and data experts.

*.sln: starts with 2005 instead of 2003..

Hi,

I had Visual Studio 2003 installed, and installed also visual Studio 2005
Beta 2.
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003. I'm
trying to change it in the registry, or jsut simply with an "open with" and
the "always use this program to open"-option checked, but it doesn't work.
Simply changing it in the "file types" in the explorer doesn't work either,
it doesn't change there.

Has anybody else had this problem? Anybody found a workaround? Somebody who
has the 2 installed too?

any help would be really appreciated!

Thanks a lot in advance,

Pieter
Aug 9 '05 #1
8 1793
Open 2003 and open the solution from there. Other than that, you should be
able to right click and set the program that opens it, but I am not sure that
will work.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***************************
Think Outside the Box!
***************************
"DraguVaso" wrote:
Hi,

I had Visual Studio 2003 installed, and installed also visual Studio 2005
Beta 2.
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003. I'm
trying to change it in the registry, or jsut simply with an "open with" and
the "always use this program to open"-option checked, but it doesn't work.
Simply changing it in the "file types" in the explorer doesn't work either,
it doesn't change there.

Has anybody else had this problem? Anybody found a workaround? Somebody who
has the 2 installed too?

any help would be really appreciated!

Thanks a lot in advance,

Pieter

Aug 9 '05 #2
Unfortunately that won't work :-(
although, I found what it was: in the registry some things are changed, and
it doesn't realy seem too logical, hehe :-) When installing 2005, it not
only changes the startup-application for the .sln, but also add others stuff
for 2003 and 2002.

I made a reg-file that:
- makes 2003 the default-startup
- adds a "Open 2005" to the right-mouse menu to open a project with VS 2005
hope this can be usefull to some people.

************************************************

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.sln]
@="VisualStudio.Solution.7.1"
"Content Type"="application/octet-stream"

[HKEY_CLASSES_ROOT\.sln\OpenWithList]

[HKEY_CLASSES_ROOT\.sln\OpenWithList\devenv.exe]
@=""

[HKEY_CLASSES_ROOT\.sln\OpenWithProgids]
"VisualStudio.Solution.7.1"=""

[HKEY_CLASSES_ROOT\.sln\OpenWithProgids\Shared_Key]
@="Keep this key from being removed on uninstall of SxS Components"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1]
@="Microsoft Visual Studio Solution Object"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\CLSID]
@="{246C57AE-40DD-4d6b-9E8D-B0F5757BB2A8}"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Defaul tIcon]
@="C:\\Program Files\\Microsoft Visual Studio .NET
2003\\Common7\\IDE\\devenv.exe,-6826"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell]

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ open]

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ open\Command]
@="\"C:\\Program Files\\Microsoft Visual Studio .NET
2003\\Common7\\IDE\\devenv.exe\" \"%1\""

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ Open 2005]

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ Open 2005\Command]
@="\"C:\\Program Files\\Microsoft Visual Studio
8\\Common7\\IDE\\devenv.exe\" \"%1\""

************************************************

"Cowboy (Gregory A. Beamer) - MVP" <No************@comcast.netNoSpamM> wrote
in message news:90**********************************@microsof t.com...
Open 2003 and open the solution from there. Other than that, you should be
able to right click and set the program that opens it, but I am not sure that will work.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***************************
Think Outside the Box!
***************************
"DraguVaso" wrote:
Hi,

I had Visual Studio 2003 installed, and installed also visual Studio 2005 Beta 2.
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003. I'm trying to change it in the registry, or jsut simply with an "open with" and the "always use this program to open"-option checked, but it doesn't work. Simply changing it in the "file types" in the explorer doesn't work either, it doesn't change there.

Has anybody else had this problem? Anybody found a workaround? Somebody who has the 2 installed too?

any help would be really appreciated!

Thanks a lot in advance,

Pieter

Aug 9 '05 #3
Thanks for the response back. That is good information to have for others.

I have been working in VPC with the beta products, as betas tend to be a
dangerous road.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***************************
Think Outside the Box!
***************************
"DraguVaso" wrote:
Unfortunately that won't work :-(
although, I found what it was: in the registry some things are changed, and
it doesn't realy seem too logical, hehe :-) When installing 2005, it not
only changes the startup-application for the .sln, but also add others stuff
for 2003 and 2002.

I made a reg-file that:
- makes 2003 the default-startup
- adds a "Open 2005" to the right-mouse menu to open a project with VS 2005
hope this can be usefull to some people.

************************************************

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.sln]
@="VisualStudio.Solution.7.1"
"Content Type"="application/octet-stream"

[HKEY_CLASSES_ROOT\.sln\OpenWithList]

[HKEY_CLASSES_ROOT\.sln\OpenWithList\devenv.exe]
@=""

[HKEY_CLASSES_ROOT\.sln\OpenWithProgids]
"VisualStudio.Solution.7.1"=""

[HKEY_CLASSES_ROOT\.sln\OpenWithProgids\Shared_Key]
@="Keep this key from being removed on uninstall of SxS Components"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1]
@="Microsoft Visual Studio Solution Object"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\CLSID]
@="{246C57AE-40DD-4d6b-9E8D-B0F5757BB2A8}"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Defaul tIcon]
@="C:\\Program Files\\Microsoft Visual Studio .NET
2003\\Common7\\IDE\\devenv.exe,-6826"

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell]

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ open]

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ open\Command]
@="\"C:\\Program Files\\Microsoft Visual Studio .NET
2003\\Common7\\IDE\\devenv.exe\" \"%1\""

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ Open 2005]

[HKEY_CLASSES_ROOT\VisualStudio.Solution.7.1\Shell\ Open 2005\Command]
@="\"C:\\Program Files\\Microsoft Visual Studio
8\\Common7\\IDE\\devenv.exe\" \"%1\""

************************************************

"Cowboy (Gregory A. Beamer) - MVP" <No************@comcast.netNoSpamM> wrote
in message news:90**********************************@microsof t.com...
Open 2003 and open the solution from there. Other than that, you should be
able to right click and set the program that opens it, but I am not sure

that
will work.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***************************
Think Outside the Box!
***************************
"DraguVaso" wrote:
Hi,

I had Visual Studio 2003 installed, and installed also visual Studio 2005 Beta 2.
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003. I'm trying to change it in the registry, or jsut simply with an "open with" and the "always use this program to open"-option checked, but it doesn't work. Simply changing it in the "file types" in the explorer doesn't work either, it doesn't change there.

Has anybody else had this problem? Anybody found a workaround? Somebody who has the 2 installed too?

any help would be really appreciated!

Thanks a lot in advance,

Pieter


Aug 9 '05 #4
"DraguVaso" <pi**********@hotmail.com> wrote in message
news:eU**************@TK2MSFTNGP14.phx.gbl...
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003. .. . . Has anybody else had this problem?


Same problem, different versions - I have 'Studio's 6 and 2003
co-installed and all my VC6 projects try to open into '2003.

The only way around it I've found is to open the v6 Solutions from
inside the v6 IDE - nothing better than that, I'm afraid.

Regards,
Phill W.
Aug 10 '05 #5
Try once the registry-thing I posted also? It works great with me!
You just will have to change the values with those for VB6 and 2003, but the
princip will be the same I guess?

"Phill. W" <P.A.Ward@o-p-e-n-.-a-c-.-u-k> wrote in message
news:u7**************@TK2MSFTNGP12.phx.gbl...
"DraguVaso" <pi**********@hotmail.com> wrote in message
news:eU**************@TK2MSFTNGP14.phx.gbl...
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003.

. . .
Has anybody else had this problem?


Same problem, different versions - I have 'Studio's 6 and 2003
co-installed and all my VC6 projects try to open into '2003.

The only way around it I've found is to open the v6 Solutions from
inside the v6 IDE - nothing better than that, I'm afraid.

Regards,
Phill W.

Aug 10 '05 #6
> Same problem, different versions - I have 'Studio's 6 and 2003
co-installed and all my VC6 projects try to open into '2003.

The only way around it I've found is to open the v6 Solutions from
inside the v6 IDE - nothing better than that, I'm afraid.

Regards,
Phill W.


On XP, using Open With (browsing to msdev.exe once the first time, then
choosing Microsoft (R) Developer Studio from the list after that) works for
me.

This should also work (changing the paths as necessary):

; msdev.reg

[HKEY_CLASSES_ROOT\VisualStudio.dsw.7.1\shell\Open\ command]
@="\"C:\\Program Files\\DevStudio6\\Common\\MSDev98\\Bin\\msdev.exe \"
\"%1\""

[HKEY_CLASSES_ROOT\VisualStudio.dsp.7.1\shell\Open\ command]
@="\"C:\\Program Files\\DevStudio6\\Common\\MSDev98\\Bin\\msdev.exe \"
\"%1\""
--
---------------------------------------------------
Automate your software builds with Visual Build Pro
http://www.visualbuild.com/

Aug 11 '05 #7
"DraguVaso" <pi**********@hotmail.com> wrote in message
news:eU**************@TK2MSFTNGP14.phx.gbl...
Hi,

I had Visual Studio 2003 installed, and installed also visual Studio 2005
Beta 2.
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003.
I'm
trying to change it in the registry, or jsut simply with an "open with"
and
the "always use this program to open"-option checked, but it doesn't work.
Simply changing it in the "file types" in the explorer doesn't work
either,
it doesn't change there.

Has anybody else had this problem? Anybody found a workaround? Somebody
who
has the 2 installed too?

any help would be really appreciated!

Thanks a lot in advance,

Pieter


On my machine w/ 2003 and 2005 B2, it seems to intelligently launch the
correct version based on the .sln version. If you want to force it to use
2003, this should work (changing the path as necessary):

; vs2003.reg

[HKEY_CLASSES_ROOT\VisualStudio.Launcher.sln\Shell\ Open\Command]
@="\"C:\\Program Files\\VSNET2003\\Common7\\IDE\\devenv.exe\" \"%1\""

--
---------------------------------------------------
Automate your software builds with Visual Build Pro
http://www.visualbuild.com/
Aug 11 '05 #8
It gets itself the right version? that's great! But not nice it doesn't it
with me, hehe :-) What OS do you have? I have here W2000 SP4...

"Kyle Alons" <re***@to.newsgroup> wrote in message
news:%2****************@TK2MSFTNGP15.phx.gbl...
"DraguVaso" <pi**********@hotmail.com> wrote in message
news:eU**************@TK2MSFTNGP14.phx.gbl...
Hi,

I had Visual Studio 2003 installed, and installed also visual Studio 2005 Beta 2.
The problem is, when I am starting now (double click) a solution
(*.sln-file), it always start it with Visual Studio 2005, and not 2003.
I'm
trying to change it in the registry, or jsut simply with an "open with"
and
the "always use this program to open"-option checked, but it doesn't work. Simply changing it in the "file types" in the explorer doesn't work
either,
it doesn't change there.

Has anybody else had this problem? Anybody found a workaround? Somebody
who
has the 2 installed too?

any help would be really appreciated!

Thanks a lot in advance,

Pieter


On my machine w/ 2003 and 2005 B2, it seems to intelligently launch the
correct version based on the .sln version. If you want to force it to use
2003, this should work (changing the path as necessary):

; vs2003.reg

[HKEY_CLASSES_ROOT\VisualStudio.Launcher.sln\Shell\ Open\Command]
@="\"C:\\Program Files\\VSNET2003\\Common7\\IDE\\devenv.exe\" \"%1\""

--
---------------------------------------------------
Automate your software builds with Visual Build Pro
http://www.visualbuild.com/

Aug 12 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Derek | last post: by
3 posts views Thread by Tom Meerstad | last post: by
4 posts views Thread by Mark | last post: by
9 posts views Thread by DraguVaso | last post: by
2 posts views Thread by David R. | last post: by
reply views Thread by Larry Rebich | last post: by
3 posts views Thread by =?Utf-8?B?Sm9obiBXYWxrZXI=?= | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.