By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,543 Members | 1,887 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,543 IT Pros & Developers. It's quick & easy.

Stop Excel connecting to Internet?

P: n/a


I am creating an instance of Excel in a WinForm application. When I try
to run this application, there is a long wait followed by a message from
my firewall that my application is attempting to connect to the internet.

Is there any way to stop automation instance of office from connecting to
the internet?

TIA, LJ
Jul 28 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Do you know here it tries to connect ?

Do you have an Internet files in your recently opened files ? If yes what if
you clear this list ?

--
Patrice

"jersey" <je****@yahoo.com> a écrit dans le message de
news:MP************************@msnews.microsoft.c om...


I am creating an instance of Excel in a WinForm application. When I try
to run this application, there is a long wait followed by a message from
my firewall that my application is attempting to connect to the internet.

Is there any way to stop automation instance of office from connecting to
the internet?

TIA, LJ

Jul 29 '05 #2

P: n/a
I am creating an instance of Excel in a WinForm application. When I try
to run this application, there is a long wait followed by a message from
my firewall that my application is attempting to connect to the internet.

Is there any way to stop automation instance of office from connecting to
the internet?
Do you know here it tries to connect ?

Do you have an Internet files in your recently opened files ? If yes what if
you clear this list ?


No, I do not have internet files in the MRU list. I think it may be
Excel's online help trying to connect, but, that's just it, I really don't
know why this is happening.

Jul 29 '05 #3

P: n/a
Any way to see with the firewall where exactly it tries to connect ?

--
Patrice

"jersey" <je****@yahoo.com> a écrit dans le message de
news:MP************************@msnews.microsoft.c om...
I am creating an instance of Excel in a WinForm application. When I try to run this application, there is a long wait followed by a message from my firewall that my application is attempting to connect to the internet.
Is there any way to stop automation instance of office from connecting to the internet?
Do you know here it tries to connect ?

Do you have an Internet files in your recently opened files ? If yes

what if you clear this list ?


No, I do not have internet files in the MRU list. I think it may be
Excel's online help trying to connect, but, that's just it, I really don't
know why this is happening.

Jul 29 '05 #4

P: n/a
Patrice wrote...
Any way to see with the firewall where exactly it tries to connect ?


Here is the application code:

Excel.Application xl = null;

[STAThread]
static void Main()
{
Application.Run(new Form1());
}

private void button1_Click(object sender, System.EventArgs e)
{
if (xl == null)
{
xl = new Excel.Application();
xl.Visible = true;
Excel.Workbook book =
xl.Workbooks.Add(Excel.XlSheetType.xlWorksheet);
Excel.Worksheet sheet = (Excel.Worksheet)book.ActiveSheet;
Excel.Range r = (Excel.Range)sheet.Cells[1,"A"];
r.Value2 = "Hello World";
}
The following is a dump of the firewall message which happens on
application startup (before _any_ action has occurred):

File Path : WindowsApplication4.exe
Process ID : 0xD24 (Heximal) 3364 (Decimal)

Connection origin : local initiated
Protocol : TCP
Local Port : 1115
Remote Name : crl.microsoft.com
Remote Address : 131.107.115.28
Remote Port : 80 (HTTP - World Wide Web)

Jul 29 '05 #5

P: n/a
Patrice wrote...
Any way to see with the firewall where exactly it tries to connect ?


Ignore my last post. The firewall reports that my application is
attempting to connect to clr.microsoft.com. I did a Google search on that
domain name and found the solution to my problem. My application is no
longer slow to start and no more connections being attempted to the
internet.
Jul 30 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.