By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
449,264 Members | 1,743 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 449,264 IT Pros & Developers. It's quick & easy.

Installation Insanity - is THIS weird or WHAT?

P: n/a

Hi,

I'm a newbie starting up with ASP.NET,
and I'm getting off to a wonderful start
- and when I tell you "wonderful" I'm being sarcastic.

My OS is Win 2000 SP4 - and I'm using IE6.

I've gotten IIS installed, along with the .NET framework.

When I try to load a page in my webroot, I get a prompt
for a network login:
================================================== ====
Enter Network Password
------------------------------------------------------

Site: localhost
User name: [ EDIT BOX ]
Password: [ EDIT BOX ]
Domain: [ EDIT BOX ]

[] Save this password in your password list.
OK cancel

================================================== ====

My code is about as simple as it can get:
===============================================
<%@ Page Language="C#" %>

<script runat="server">
void page_load(object obj, EventArgs e)
{ lblMessage.Text = "Hello World";
}
</script>

<html><body>
<asp:Label id="lblMessage" runat="server"/>
</body></html>
===============================================

... right from the book.

I put the file into my webroot directory:
C:\Inetpub\wwwroot\

... and this URL into the IE6 address bar:
http://localhost/HelloWorld01.aspx

I've also registered ASP.NET with my IIS server,
as instructed by Gregory:
***************************
1. Open a command prompt
2. Type cd %WINDIR%\Microsoft.NET\Framework\v1.1.4322
for 1.1 Framework (assume you are using the latest)
3. Type aspnet_regiis /i

That should register ASP.NET with your IIS server.

4. Try your page again.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA
***************************

I was having a problem with access permissions after doing that,
and I found the following MS KB article:
http://support.microsoft.com/kb/316721

I did the following, as instructed by the article:
:::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::::::::::::::::::
RESOLUTION
To add read, execute, and list access for the ASPNET account
on the root Web site or on any virtual directory, follow these steps:
1. In Windows Explorer, browse to the folder that contains
the root Web site (which is C:\Inetpub\Wwwroot by default)
or the virtual directory.

2. Right-click the folder, and then click Properties.

3. On the Security tab, click Add.

4. Type ComputerName\ASPNET (for example, on a computer named Webdev,
type Webdev\ASPNET), and then click OK.

5. Allow the following permissions for the ASPNET account:
Read & Execute
List Folder Contents
Read

6. Click OK to close the Properties dialog box and to save the changes.
NOTE: You do not need to perform these steps if the Everyone group or the
Users group has read access to the root Web site or virtual directory.
:::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::::::::::::::::::

I've also given the same permissions to the "Internet Guest Account (IUSR_BOFFO-1A)"
- I still have the same problem.

What happens now, when I load the address in the address bar of IE6
(http://localhost/HelloWorld01.aspx), then click on GO,
I get that box prompting me for a username, password, and domain.

Apparently, I have a permissions issue. I am logged in as administrator,
and my C: drive is accessible. Under the "Security" tab for Properties
for Inetpub, for my "Internet Guest Account," the "Allow" boxes
for [read & execute],[list folder contents], and [Read] are checked
- BUT they are greyed out - I cannot clear them - and nothing else
is checked.

This is true for the "ASP.NET Machine Account (BOFFO-1A\ASPNET)",
as well as for the "Internet Guest Account (IUSR_BOFFO-1A)"

Now that I look further, the same thing is the case for every folder
in the root that I examined.


I have the .NET Framework 1.1 configuration tool in Administrative tools,
along with the Wizards. I have opened the configuration tool,
but I have no idea as to what I'm looking at.

I cleaned out the cache for the browser ...

C:\Documents and Settings\Administrator\Local Settings\Temporary Internet Files\
(for IE6)

... and it still doesn't work.
So this is going just "wonderfully". :-(
Does anyone have any idea as to why I'm getting that stupid network login prompt?
... or what it wants in the way of a username/password/domain?

Thanks In Advance!

- wASP
Jul 22 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a

Hi again,

If anyone is interested, this problem has been solved.

Thanks,

wASP
======================

On Sun, 10 Jul 2005 12:09:18 -0500, wASP <wylbur[at]ev1[dot]net> wrote:

Hi,

I'm a newbie starting up with ASP.NET,
and I'm getting off to a wonderful start
- and when I tell you "wonderful" I'm being sarcastic.

My OS is Win 2000 SP4 - and I'm using IE6.

I've gotten IIS installed, along with the .NET framework.

When I try to load a page in my webroot, I get a prompt
for a network login:
================================================= =====
Enter Network Password
------------------------------------------------------

Site: localhost
User name: [ EDIT BOX ]
Password: [ EDIT BOX ]
Domain: [ EDIT BOX ]

[] Save this password in your password list.
OK cancel

================================================= =====

My code is about as simple as it can get:
===============================================
<%@ Page Language="C#" %>

<script runat="server">
void page_load(object obj, EventArgs e)
{ lblMessage.Text = "Hello World";
}
</script>

<html><body>
<asp:Label id="lblMessage" runat="server"/>
</body></html>
===============================================

... right from the book.

I put the file into my webroot directory:
C:\Inetpub\wwwroot\

... and this URL into the IE6 address bar:
http://localhost/HelloWorld01.aspx

I've also registered ASP.NET with my IIS server,
as instructed by Gregory:
***************************
1. Open a command prompt
2. Type cd %WINDIR%\Microsoft.NET\Framework\v1.1.4322
for 1.1 Framework (assume you are using the latest)
3. Type aspnet_regiis /i

That should register ASP.NET with your IIS server.

4. Try your page again.


- wASP
Jul 22 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.