471,348 Members | 1,848 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,348 software developers and data experts.

Unable to open the Web project

Error when opening a solution with a web services project in it:

"Unable to open the Web project 'myproj'. The file path 'c:\code\myservice'
does not correspond to the URL 'http://localhost/myservices'. The two need to
map to the same server location. HTTP Error 404: Object Not Found"

First, this error comes up on a system that is serving other web services
just fine.
Second, the main issue here is project collaboration. We use CVS for
revision control and when checking out the web services project on a machine
that did not originally create it, this error occurs. We can force a mapping
in IIS to the correct folder but other errors arise from that.

Another issue is that I cannot seem to force the project to look at my
server for the code. I renamed 'localhost' in the webinfo file to my server
name and cannot seem to get the system to see it. I do a search through all
my files for localhost and nothing returns, yet, when I turn off my IIS
server (for testing) and load the project it still looks to localhost - not
my server name. I need to get this working so that when someone checks out
the webservices code, they can use it seemlessly.

Please advise.
--
Brad Eck
<a href="http://www.sitesdynamic.com">SitesDynamic</a>
<a href="http://www.basketsetcetera.com">Baskets Etcetera</a>
Jul 21 '05 #1
4 2557
1. As far as I know you will have to have your directory structures match
the solution structure on all machines... period... end of storry. So if the
Source Safe Structure is $\Solution\Project1 set the root ($) working folder
to your C-drive and and have everyone do the same.
2. Create your virtual directory before getting latest version. Manually
create the correct files and manually create the virdir. If you already got
latest version delete all local files or at the very least the proj file.
3. What other errors arise when you force a mapping?
4. It sounds like what you are trying to do with the localhost mod is set
up one machine that everyone develops off of and checks in and out to rather
than their own local machine. If so, try opening the solution from the
network share of the shared machine not from source safe( I am guessing here
that that is what you are doing). My suggestion would be to develop locally
and do continuous builds to the shared machine if you need to for demos or
whatever. But it I might have a better suggestion if you can flesh out your
explanation of the problem a little more.


"Brad" wrote:
Error when opening a solution with a web services project in it:

"Unable to open the Web project 'myproj'. The file path 'c:\code\myservice'
does not correspond to the URL 'http://localhost/myservices'. The two need to
map to the same server location. HTTP Error 404: Object Not Found"

First, this error comes up on a system that is serving other web services
just fine.
Second, the main issue here is project collaboration. We use CVS for
revision control and when checking out the web services project on a machine
that did not originally create it, this error occurs. We can force a mapping
in IIS to the correct folder but other errors arise from that.

Another issue is that I cannot seem to force the project to look at my
server for the code. I renamed 'localhost' in the webinfo file to my server
name and cannot seem to get the system to see it. I do a search through all
my files for localhost and nothing returns, yet, when I turn off my IIS
server (for testing) and load the project it still looks to localhost - not
my server name. I need to get this working so that when someone checks out
the webservices code, they can use it seemlessly.

Please advise.
--
Brad Eck
<a href="http://www.sitesdynamic.com">SitesDynamic</a>
<a href="http://www.basketsetcetera.com">Baskets Etcetera</a>

Jul 21 '05 #2
Well, first, I guess I am trying to find the thing we did or didn't do
before. We have other projects implemented in the same way and checked in but
we didn't see to have the same issues on those projects - just this one.

What frustrates me is my test - pointing it to my server - doesn't work
because it ALWAYS looks to localhost no matter what I try. Multiple people
will be working on these web services so to require a central server is not
viable for us.

I will do it, but what is the diff of when you create the virtual dir?

"force a mapping" - what do you mean? The only thing I forced was changing
the server name in the webinfo file from localhost to my computer name to
force the other machine to look to my computer - this was only done for a
test. We need to run local most of the time.

More info - I completely deleted everything related off my machine and
removed the virtual directory and started over. I checked everything out,
created the VD and then opened the project and all was well on my machine. I
just cannot figure why this would be different on someone else's machine -
and if it is, what file I need to adjust to get it right.

"Derek" wrote:
1. As far as I know you will have to have your directory structures match
the solution structure on all machines... period... end of storry. So if the
Source Safe Structure is $\Solution\Project1 set the root ($) working folder
to your C-drive and and have everyone do the same.
2. Create your virtual directory before getting latest version. Manually
create the correct files and manually create the virdir. If you already got
latest version delete all local files or at the very least the proj file.
3. What other errors arise when you force a mapping?
4. It sounds like what you are trying to do with the localhost mod is set
up one machine that everyone develops off of and checks in and out to rather
than their own local machine. If so, try opening the solution from the
network share of the shared machine not from source safe( I am guessing here
that that is what you are doing). My suggestion would be to develop locally
and do continuous builds to the shared machine if you need to for demos or
whatever. But it I might have a better suggestion if you can flesh out your
explanation of the problem a little more.


"Brad" wrote:
Error when opening a solution with a web services project in it:

"Unable to open the Web project 'myproj'. The file path 'c:\code\myservice'
does not correspond to the URL 'http://localhost/myservices'. The two need to
map to the same server location. HTTP Error 404: Object Not Found"

First, this error comes up on a system that is serving other web services
just fine.
Second, the main issue here is project collaboration. We use CVS for
revision control and when checking out the web services project on a machine
that did not originally create it, this error occurs. We can force a mapping
in IIS to the correct folder but other errors arise from that.

Another issue is that I cannot seem to force the project to look at my
server for the code. I renamed 'localhost' in the webinfo file to my server
name and cannot seem to get the system to see it. I do a search through all
my files for localhost and nothing returns, yet, when I turn off my IIS
server (for testing) and load the project it still looks to localhost - not
my server name. I need to get this working so that when someone checks out
the webservices code, they can use it seemlessly.

Please advise.
--
Brad Eck
<a href="http://www.sitesdynamic.com">SitesDynamic</a>
<a href="http://www.basketsetcetera.com">Baskets Etcetera</a>

Jul 21 '05 #3
1. As far as I know you will have to have your directory structures match
the solution structure on all machines... period... end of storry. So if the
Source Safe Structure is $\Solution\Project1 set the root ($) working folder
to your C-drive and and have everyone do the same.
2. Create your virtual directory before getting latest version. Manually
create the correct files and manually create the virdir. If you already got
latest version delete all local files or at the very least the proj file.
3. What other errors arise when you force a mapping?
4. It sounds like what you are trying to do with the localhost mod is set
up one machine that everyone develops off of and checks in and out to rather
than their own local machine. If so, try opening the solution from the
network share of the shared machine not from source safe( I am guessing here
that that is what you are doing). My suggestion would be to develop locally
and do continuous builds to the shared machine if you need to for demos or
whatever. But it I might have a better suggestion if you can flesh out your
explanation of the problem a little more.


"Brad" wrote:
Error when opening a solution with a web services project in it:

"Unable to open the Web project 'myproj'. The file path 'c:\code\myservice'
does not correspond to the URL 'http://localhost/myservices'. The two need to
map to the same server location. HTTP Error 404: Object Not Found"

First, this error comes up on a system that is serving other web services
just fine.
Second, the main issue here is project collaboration. We use CVS for
revision control and when checking out the web services project on a machine
that did not originally create it, this error occurs. We can force a mapping
in IIS to the correct folder but other errors arise from that.

Another issue is that I cannot seem to force the project to look at my
server for the code. I renamed 'localhost' in the webinfo file to my server
name and cannot seem to get the system to see it. I do a search through all
my files for localhost and nothing returns, yet, when I turn off my IIS
server (for testing) and load the project it still looks to localhost - not
my server name. I need to get this working so that when someone checks out
the webservices code, they can use it seemlessly.

Please advise.
--
Brad Eck
<a href="http://www.sitesdynamic.com">SitesDynamic</a>
<a href="http://www.basketsetcetera.com">Baskets Etcetera</a>

Jul 21 '05 #4
Well, first, I guess I am trying to find the thing we did or didn't do
before. We have other projects implemented in the same way and checked in but
we didn't see to have the same issues on those projects - just this one.

What frustrates me is my test - pointing it to my server - doesn't work
because it ALWAYS looks to localhost no matter what I try. Multiple people
will be working on these web services so to require a central server is not
viable for us.

I will do it, but what is the diff of when you create the virtual dir?

"force a mapping" - what do you mean? The only thing I forced was changing
the server name in the webinfo file from localhost to my computer name to
force the other machine to look to my computer - this was only done for a
test. We need to run local most of the time.

More info - I completely deleted everything related off my machine and
removed the virtual directory and started over. I checked everything out,
created the VD and then opened the project and all was well on my machine. I
just cannot figure why this would be different on someone else's machine -
and if it is, what file I need to adjust to get it right.

"Derek" wrote:
1. As far as I know you will have to have your directory structures match
the solution structure on all machines... period... end of storry. So if the
Source Safe Structure is $\Solution\Project1 set the root ($) working folder
to your C-drive and and have everyone do the same.
2. Create your virtual directory before getting latest version. Manually
create the correct files and manually create the virdir. If you already got
latest version delete all local files or at the very least the proj file.
3. What other errors arise when you force a mapping?
4. It sounds like what you are trying to do with the localhost mod is set
up one machine that everyone develops off of and checks in and out to rather
than their own local machine. If so, try opening the solution from the
network share of the shared machine not from source safe( I am guessing here
that that is what you are doing). My suggestion would be to develop locally
and do continuous builds to the shared machine if you need to for demos or
whatever. But it I might have a better suggestion if you can flesh out your
explanation of the problem a little more.


"Brad" wrote:
Error when opening a solution with a web services project in it:

"Unable to open the Web project 'myproj'. The file path 'c:\code\myservice'
does not correspond to the URL 'http://localhost/myservices'. The two need to
map to the same server location. HTTP Error 404: Object Not Found"

First, this error comes up on a system that is serving other web services
just fine.
Second, the main issue here is project collaboration. We use CVS for
revision control and when checking out the web services project on a machine
that did not originally create it, this error occurs. We can force a mapping
in IIS to the correct folder but other errors arise from that.

Another issue is that I cannot seem to force the project to look at my
server for the code. I renamed 'localhost' in the webinfo file to my server
name and cannot seem to get the system to see it. I do a search through all
my files for localhost and nothing returns, yet, when I turn off my IIS
server (for testing) and load the project it still looks to localhost - not
my server name. I need to get this working so that when someone checks out
the webservices code, they can use it seemlessly.

Please advise.
--
Brad Eck
<a href="http://www.sitesdynamic.com">SitesDynamic</a>
<a href="http://www.basketsetcetera.com">Baskets Etcetera</a>

Jul 21 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by vince | last post: by
1 post views Thread by soni29 | last post: by
16 posts views Thread by Serdar Kalaycý | last post: by
8 posts views Thread by Rob | last post: by
1 post views Thread by Winshent | last post: by
3 posts views Thread by alan_coffman2004 | last post: by
7 posts views Thread by Jed | last post: by
2 posts views Thread by Sagar | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.