471,330 Members | 1,239 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,330 software developers and data experts.

Encountered user-defined breakpoint

Can someone please tell me why this code (it is a function that has a
parameter xmlstring:

Dim objWebRequest As HttpWebRequest
Dim oRequest As WebRequest
objWebRequest = CType(WebRequest.Create("https://anon:6442"), HttpWebRequest)
objWebRequest.Method = "POST"
objWebRequest.ContentType = "text/xml"
Dim PostBuffer As Byte() =
System.Text.Encoding.GetEncoding(65001).GetBytes(X mlString)
objWebRequest.ContentLength = PostBuffer.Length
objWebRequest.ProtocolVersion = HttpVersion.Version10
Dim oStream As Stream = objWebRequest.GetRequestStream()
oStream.Write(PostBuffer, 0, PostBuffer.Length)
oStream.Close()
Dim objWebResponse As HttpWebResponse
objWebResponse = CType(objWebRequest.GetResponse, HttpWebResponse)
Dim Enc As Encoding
Enc = System.Text.Encoding.GetEncoding(65001)
Dim oStreamReader As New StreamReader(objWebResponse.GetResponseStream, Enc)

ResponseString = oStreamReader.ReadToEnd
oStreamReader.Close()

Return ResponseString
Causes this??:

The description for Event ID ( 0 ) in Source ( .NET Runtime ) cannot be
found. The local computer may not have the necessary registry information or
message DLL files to display messages from a remote computer. You may be able
to use the /AUXSOURCE= flag to retrieve this description; see Help and
Support for details. The following information is part of the event: .NET
Runtime version 1.1.4322.2032- w3wp.exe - Common Language Runtime Debugging
Services: Application has encountered a user-defined breakpoint.

Process id=0xfb8 (4024), Thread id=0x1198 (4504).

Click ABORT to terminate the application.
Click RETRY to debug the application.
Click IGNORE to ignore the breakpoint..
When I change the code above to use the old MSXML serverxmlHTTP COM object
things run great but when I tell it to use the above code i get the above
message in the application event log.

The most unusual issue about the whole thing is that it works perfectly on
my test machine which is windows xp with iis 5.1 and the same .net version.
Jul 21 '05 #1
1 7337
And to clarify some more. This is for an ASP.NET project. It was not running
on a windows 2003 server with iis 6. The remote URL that I am trying to
connect to is a Tomcat server.

"Mike" wrote:
Can someone please tell me why this code (it is a function that has a
parameter xmlstring:

Dim objWebRequest As HttpWebRequest
Dim oRequest As WebRequest
objWebRequest = CType(WebRequest.Create("https://anon:6442"), HttpWebRequest)
objWebRequest.Method = "POST"
objWebRequest.ContentType = "text/xml"
Dim PostBuffer As Byte() =
System.Text.Encoding.GetEncoding(65001).GetBytes(X mlString)
objWebRequest.ContentLength = PostBuffer.Length
objWebRequest.ProtocolVersion = HttpVersion.Version10
Dim oStream As Stream = objWebRequest.GetRequestStream()
oStream.Write(PostBuffer, 0, PostBuffer.Length)
oStream.Close()
Dim objWebResponse As HttpWebResponse
objWebResponse = CType(objWebRequest.GetResponse, HttpWebResponse)
Dim Enc As Encoding
Enc = System.Text.Encoding.GetEncoding(65001)
Dim oStreamReader As New StreamReader(objWebResponse.GetResponseStream, Enc)

ResponseString = oStreamReader.ReadToEnd
oStreamReader.Close()

Return ResponseString
Causes this??:

The description for Event ID ( 0 ) in Source ( .NET Runtime ) cannot be
found. The local computer may not have the necessary registry information or
message DLL files to display messages from a remote computer. You may be able
to use the /AUXSOURCE= flag to retrieve this description; see Help and
Support for details. The following information is part of the event: .NET
Runtime version 1.1.4322.2032- w3wp.exe - Common Language Runtime Debugging
Services: Application has encountered a user-defined breakpoint.

Process id=0xfb8 (4024), Thread id=0x1198 (4504).

Click ABORT to terminate the application.
Click RETRY to debug the application.
Click IGNORE to ignore the breakpoint..
When I change the code above to use the old MSXML serverxmlHTTP COM object
things run great but when I tell it to use the above code i get the above
message in the application event log.

The most unusual issue about the whole thing is that it works perfectly on
my test machine which is windows xp with iis 5.1 and the same .net version.

Jul 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Josh Harris | last post: by
2 posts views Thread by Trevor Benedict R | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.