471,313 Members | 1,892 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,313 software developers and data experts.

Visual Source Safe Hell

I am having loads of problem using vb.net project under visual source safe.
I’ll start with

How can I exclude source safe information from the project when I take a
copy of project home? I don’t have source safe on my home pc. Every time I
open project at home it gives me missing source safe file error. This is
really annoying. How can I fix this?

Thanks
Jul 21 '05 #1
3 5471
You can unbind the project as follows:

1. Create a copy of your project.
2. Open the copied project.
3. Click File --> Source Control --> Change Source Control
4. In Change Source Control window select Disconnect and then press OK. This
is will disconnect you from source control.
5. Click again on File --> Source Control --> Change Source Control
6. In Change Source Control window select Unbind, press Unbind on the
message box and press OK. This will unbind you from the source control.
7. Save the project.
8. You can now use the project any where with intervention of annoying
message box when you open your project.

Hope this helps.

"Job Lot" wrote:
I am having loads of problem using vb.net project under visual source safe.
I’ll start with

How can I exclude source safe information from the project when I take a
copy of project home? I don’t have source safe on my home pc. Every time I
open project at home it gives me missing source safe file error. This is
really annoying. How can I fix this?

Thanks

Jul 21 '05 #2
Sorry missed out something

Once the project is unbounded, make sure you set the read only property of
contents in the folder to false.
"Job Lot" wrote:
I am having loads of problem using vb.net project under visual source safe.
I’ll start with

How can I exclude source safe information from the project when I take a
copy of project home? I don’t have source safe on my home pc. Every time I
open project at home it gives me missing source safe file error. This is
really annoying. How can I fix this?

Thanks

Jul 21 '05 #3
You would have to be careful doing this, as you're now working with 2 copies
of your project, and you might have problems merging any changes you make at
home back into the SourceSafe files at work.

I am in the same situation. (I have VisualStudio 2003 and SourceSafe 6.0d).
At work, I am connected to the sourcesafe database, and all is well. At
Home, when I fire-up the project, and the SourceSafe login prompt comes up,
I just press Cancel, then I get a 'Change Source Control' dialog box to
which I click 'Work Disconnected' then proceeed as normal. (Thats 2 mouse
clicks). The only thing you have to remember is to do a 'Get Latest' and
check out any files you are likely to want to edit at home before leaving
the office. If the project is fairly small and/or if no-one else is likely
to need the files while you are away, just check the whole project out.
(Thats what I do)

When you come back into the office, you have to reconnect to the SourceSafe
database:
Fire up Visual Studio, and open your project.
Goto File->SourceControl->Change SourceControl
Make sure SourceSafe 'ServerName' and 'ServerBinding' is correct (it always
has been for me).
Click on the 'Connected' Check Box, and Click OK
(About 3 mouse clicks).

This way, you are always working within sourcesafe control, and there is no
risk of finishing up with 2 versions of the same file and all the associated
merging problems.

Hope this helps.

Cheers,

Chris.

"Pankaj Banga" <Pa*********@discussions.microsoft.com> wrote in message
news:C4**********************************@microsof t.com...
You can unbind the project as follows:

1. Create a copy of your project.
2. Open the copied project.
3. Click File --> Source Control --> Change Source Control
4. In Change Source Control window select Disconnect and then press OK. This is will disconnect you from source control.
5. Click again on File --> Source Control --> Change Source Control
6. In Change Source Control window select Unbind, press Unbind on the
message box and press OK. This will unbind you from the source control.
7. Save the project.
8. You can now use the project any where with intervention of annoying
message box when you open your project.

Hope this helps.

"Job Lot" wrote:
I am having loads of problem using vb.net project under visual source safe. I'll start with

How can I exclude source safe information from the project when I take a
copy of project home? I don't have source safe on my home pc. Every time I open project at home it gives me missing source safe file error. This is
really annoying. How can I fix this?

Thanks

Jul 21 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Job Lot | last post: by
54 posts views Thread by m.roello | last post: by
4 posts views Thread by Sridhar | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.