By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,665 Members | 1,251 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,665 IT Pros & Developers. It's quick & easy.

Remove connection to MSDE 2000

P: n/a
Hi,

I am struggline to make my VB.Net windows client connect remotely to a MSDE
database. The database is accessed ok from the remote PC when i used web
forms (aspx) to access it.

Can anyone provide me with an idiots guide to make the connection work from
a windows client application?

I get the following error:
Connection failed because of an error in initializing provider.
[DBNETLIB][Connection Open(Connect()).]SQL Server does not exist or access
denied
I know the SQL Server does exist so am wondering how to resolve the access
denied. The 2 PCs are on an intranet. I need to know what i need to do on
both PCs to make the connection work. Thanks for any help! J.
Jul 21 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Lemme guess.. your web forms app is on the same machine as the MSDE
instance right? It seems like the MSDE instance is not setup for access
over the network. MSDE SP3 onwards has a default setting that disables
network access to the server. Did you include the
DISABLENETWORKPROTOCOLS=0 setting in the settings.ini file (or command
line) while installing MSDE. If you didnt then MSDE is not configured
to use the network protocols to allow other machines on the network to
access it. You can enable them by doing the following:

1. Run -> svrnetcn.exe using the command line. This should open the SQL
Server Network Utility dialog.
2. If Tcp/IP and named pipes are in the disabled network protocols
list, add them to the Enabled Protocols list.

After that as a safe precaution restart the SQL Server service, and try
connecting with the client again.

You can also check out this article that shows how to confiugure MSDE.
http://www.codeproject.com/database/ConfigureMSDE.asp

Hope this helps,
NuTcAsE

Jul 21 '05 #2

P: n/a

Thanks very much - much obliged - that did the trick!!!!
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 21 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.