471,348 Members | 1,944 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,348 software developers and data experts.

IIS File Path Problem

Hello,

I am new to ASP as well as IIS. I am trying to learn how to create a web
application using asp.NET. I have followed the instructions for configuring
the IIS settings but when I click on the .sln file to open the project in VS
I get the following error:
"Unable to open the Web Project 'projectname', the file path
C:\InetPub\wwwroot\projectname does not correspond to the URL
'http://localhost/projectname. The two need to map to the same server
location."
I am using my local computer (XP Pro is OS) and IIS is installed before VS
was. I have the project folder located the InetPub\wwwroot folder. In the
project folder properties I have clicked on the Create button to put the
project name in the "Application name" filed so that the directory will be
recognized by IIS as an application. I have also added the ASPNET user with
Read & Exe, List Folder Contents, Read, & Write permissions. If I type the
URL of http://MyComputerName/projectname/filename.aspx the web page will open
up in the IE browser (although it does not display properly formatted). I
don't understand why I can't open the project by clicking on the
projectname.sln file. Any help with this will be greatly appreciated. Thank
you for reading this lenghty post.

Dave Y
Jul 21 '05 #1
3 4416
As long as you have installed IIS before VS.NET, there is no configuration
you need to do with IIS.

Just open VS.NET and create a new ASP.NET web project. VS.NET will ask IIS
to create the directory and give it the appropriate configuration settings.

The problem you are encountering at the moment is that you have manually
created an IIS application folder but the folder doesn't have normal LAN
sharing permissions that are needed for VS.NET to access the folder. In
Windows Explorer, right click the folder and choose Sharing And Security.
On the Sharing (not the Web Sharing) tab, choose to share the folder, do not
change the folder alias.

But as I said, in the future, when you want to make a new web project, just
do it from VS.NET and VS.NET will take care of all of this for you.
"Dave Y" <Da***@discussions.microsoft.com> wrote in message
news:FF**********************************@microsof t.com...
Hello,

I am new to ASP as well as IIS. I am trying to learn how to create a web
application using asp.NET. I have followed the instructions for
configuring
the IIS settings but when I click on the .sln file to open the project in
VS
I get the following error:
"Unable to open the Web Project 'projectname', the file path
C:\InetPub\wwwroot\projectname does not correspond to the URL
'http://localhost/projectname. The two need to map to the same server
location."
I am using my local computer (XP Pro is OS) and IIS is installed before VS
was. I have the project folder located the InetPub\wwwroot folder. In the
project folder properties I have clicked on the Create button to put the
project name in the "Application name" filed so that the directory will be
recognized by IIS as an application. I have also added the ASPNET user
with
Read & Exe, List Folder Contents, Read, & Write permissions. If I type the
URL of http://MyComputerName/projectname/filename.aspx the web page will
open
up in the IE browser (although it does not display properly formatted). I
don't understand why I can't open the project by clicking on the
projectname.sln file. Any help with this will be greatly appreciated.
Thank
you for reading this lenghty post.

Dave Y

Jul 21 '05 #2
Hi Scott,

I took your suggestion and shared the folder (did not change alias) but I am
still receiving the error message. As far as I know; all services are running
and priveleges are correct. I am going to start over by creating the asp
project through VS.Net. Thank you for your reply.

Dave Y

"Scott M." wrote:
As long as you have installed IIS before VS.NET, there is no configuration
you need to do with IIS.

Just open VS.NET and create a new ASP.NET web project. VS.NET will ask IIS
to create the directory and give it the appropriate configuration settings.

The problem you are encountering at the moment is that you have manually
created an IIS application folder but the folder doesn't have normal LAN
sharing permissions that are needed for VS.NET to access the folder. In
Windows Explorer, right click the folder and choose Sharing And Security.
On the Sharing (not the Web Sharing) tab, choose to share the folder, do not
change the folder alias.

But as I said, in the future, when you want to make a new web project, just
do it from VS.NET and VS.NET will take care of all of this for you.
"Dave Y" <Da***@discussions.microsoft.com> wrote in message
news:FF**********************************@microsof t.com...
Hello,

I am new to ASP as well as IIS. I am trying to learn how to create a web
application using asp.NET. I have followed the instructions for
configuring
the IIS settings but when I click on the .sln file to open the project in
VS
I get the following error:
"Unable to open the Web Project 'projectname', the file path
C:\InetPub\wwwroot\projectname does not correspond to the URL
'http://localhost/projectname. The two need to map to the same server
location."
I am using my local computer (XP Pro is OS) and IIS is installed before VS
was. I have the project folder located the InetPub\wwwroot folder. In the
project folder properties I have clicked on the Create button to put the
project name in the "Application name" filed so that the directory will be
recognized by IIS as an application. I have also added the ASPNET user
with
Read & Exe, List Folder Contents, Read, & Write permissions. If I type the
URL of http://MyComputerName/projectname/filename.aspx the web page will
open
up in the IE browser (although it does not display properly formatted). I
don't understand why I can't open the project by clicking on the
projectname.sln file. Any help with this will be greatly appreciated.
Thank
you for reading this lenghty post.

Dave Y


Jul 21 '05 #3
Hi Dave,

I should have also mentioned that if you manually created the IIS virtual
directory and give this folder LAN sharing permissions. You still haven't
created an ASP.NET application in this folder. After manually setting the
folder up as described earlier, you would then go to VS.NET and choose to
create a NEW project at the http location you set up, you would NOT be
trying to OPEN an ASP.NET application, because no application would have
been created yet, just the folder.
"Dave Y" <Da***@discussions.microsoft.com> wrote in message
news:F4**********************************@microsof t.com...
Hi Scott,

I took your suggestion and shared the folder (did not change alias) but I
am
still receiving the error message. As far as I know; all services are
running
and priveleges are correct. I am going to start over by creating the asp
project through VS.Net. Thank you for your reply.

Dave Y

"Scott M." wrote:
As long as you have installed IIS before VS.NET, there is no
configuration
you need to do with IIS.

Just open VS.NET and create a new ASP.NET web project. VS.NET will ask
IIS
to create the directory and give it the appropriate configuration
settings.

The problem you are encountering at the moment is that you have manually
created an IIS application folder but the folder doesn't have normal LAN
sharing permissions that are needed for VS.NET to access the folder. In
Windows Explorer, right click the folder and choose Sharing And Security.
On the Sharing (not the Web Sharing) tab, choose to share the folder, do
not
change the folder alias.

But as I said, in the future, when you want to make a new web project,
just
do it from VS.NET and VS.NET will take care of all of this for you.
"Dave Y" <Da***@discussions.microsoft.com> wrote in message
news:FF**********************************@microsof t.com...
> Hello,
>
> I am new to ASP as well as IIS. I am trying to learn how to create a
> web
> application using asp.NET. I have followed the instructions for
> configuring
> the IIS settings but when I click on the .sln file to open the project
> in
> VS
> I get the following error:
> "Unable to open the Web Project 'projectname', the file path
> C:\InetPub\wwwroot\projectname does not correspond to the URL
> 'http://localhost/projectname. The two need to map to the same server
> location."
> I am using my local computer (XP Pro is OS) and IIS is installed before
> VS
> was. I have the project folder located the InetPub\wwwroot folder. In
> the
> project folder properties I have clicked on the Create button to put
> the
> project name in the "Application name" filed so that the directory will
> be
> recognized by IIS as an application. I have also added the ASPNET user
> with
> Read & Exe, List Folder Contents, Read, & Write permissions. If I type
> the
> URL of http://MyComputerName/projectname/filename.aspx the web page
> will
> open
> up in the IE browser (although it does not display properly formatted).
> I
> don't understand why I can't open the project by clicking on the
> projectname.sln file. Any help with this will be greatly appreciated.
> Thank
> you for reading this lenghty post.
>
> Dave Y


Jul 21 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

17 posts views Thread by Sean Ross | last post: by
5 posts views Thread by Al | last post: by
1 post views Thread by Ronak mishra | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.