471,348 Members | 1,880 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,348 software developers and data experts.

Exclude app from displaying in the Alt-Tab window

I'm using the NotifyIcon component on a form within a Windows application
that will normally show no interface.
NotifyIcon does add an icon as required to the notification area of the Task
Bar. Unfortunately the window is showing up in the little window that is
displayed when user uses Alt-Tab to switch applications.

How do I make this application not show up in the Alt-Tab window?

Thanks.

Dale
Jul 21 '05 #1
3 2359
Set the form's ShowInTaskbar property to false, and set the
FormBorderStyle property to either FixedToolWindow or SizableToolWindow.

Regards,
Joakim

Dale wrote:
I'm using the NotifyIcon component on a form within a Windows application
that will normally show no interface.
NotifyIcon does add an icon as required to the notification area of the Task
Bar. Unfortunately the window is showing up in the little window that is
displayed when user uses Alt-Tab to switch applications.

How do I make this application not show up in the Alt-Tab window?

Thanks.

Dale

Jul 21 '05 #2
Thanks for the info Joakim.

Your suggestion doesn't completely solve the problem, but comes pretty
close. Thank you for the help.

In case anyone else has this problem, I've included my documentation below.
Please let me know if you have a simple suggestion for getting rid of the
last case. Thanks.

/// In order to make the window invisible, you need to do a few things.
/// To prevent window from normally showing in Task bar or in the Alt-Tab
window used
/// to select the foreground application:
/// - set ShowInTaskbar property to false
/// - set FormBorderStyle property to either FixedToolWindow or
SizableToolWindow
///
/// To prevent the window itself from being visible, setting WindowState to
minimized
/// does not work, due to the FormBorderStyle setting from above. You need
to:
/// - set StartPosition to Manual
/// - set Location to something off the screen, such as 2500,0
/// - set WindowState to Normal
///
/// You will still be able to see this window in the Alt-Tab window if:
/// - no window has focus (e.g. user has clicked on the task bar on a
NotifyIcon
/// therein)
/// - the NotifyIcon for this window was right-clicked
/// This seems to be standard Windows behaviour (or a consistent Windows
bug),
/// as right-clicking on any icon in the notification area of the task bar
temporarily
/// adds it to the Alt-Tab window. Left-clicking does not.
/// In my particular case, I was clicking on the NotifyIcon for this app in
the
/// task bar, and using the ContextMenu to launch a new form/window which
was used
/// to display a message. Immediately pressing Alt-Tab caused both the new
window
/// and the original "invisible" window to be listed. Clicking either the
new
/// window or any other application caused this "invisible" window to no
longer be
/// listed.
/// Getting the application that previously had focus and returning focus to
it
/// would likely resolve this.
Dale
"Joakim Karlsson" <jk*******@NOSPAMjkarlsson.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Set the form's ShowInTaskbar property to false, and set the
FormBorderStyle property to either FixedToolWindow or SizableToolWindow.

Regards,
Joakim

Dale wrote:
I'm using the NotifyIcon component on a form within a Windows application that will normally show no interface.
NotifyIcon does add an icon as required to the notification area of the Task Bar. Unfortunately the window is showing up in the little window that is displayed when user uses Alt-Tab to switch applications.

How do I make this application not show up in the Alt-Tab window?

Thanks.

Dale

Jul 21 '05 #3
Thanks for the info Joakim.

Your suggestion doesn't completely solve the problem, but comes pretty
close. Thank you for the help.

In case anyone else has this problem, I've included my documentation below.
Please let me know if you have a simple suggestion for getting rid of the
last case. Thanks.

/// In order to make the window invisible, you need to do a few things.
/// To prevent window from normally showing in Task bar or in the Alt-Tab
window used
/// to select the foreground application:
/// - set ShowInTaskbar property to false
/// - set FormBorderStyle property to either FixedToolWindow or
SizableToolWindow
///
/// To prevent the window itself from being visible, setting WindowState to
minimized
/// does not work, due to the FormBorderStyle setting from above. You need
to:
/// - set StartPosition to Manual
/// - set Location to something off the screen, such as 2500,0
/// - set WindowState to Normal
///
/// You will still be able to see this window in the Alt-Tab window if:
/// - no window has focus (e.g. user has clicked on the task bar on a
NotifyIcon
/// therein)
/// - the NotifyIcon for this window was right-clicked
/// This seems to be standard Windows behaviour (or a consistent Windows
bug),
/// as right-clicking on any icon in the notification area of the task bar
temporarily
/// adds it to the Alt-Tab window. Left-clicking does not.
/// In my particular case, I was clicking on the NotifyIcon for this app in
the
/// task bar, and using the ContextMenu to launch a new form/window which
was used
/// to display a message. Immediately pressing Alt-Tab caused both the new
window
/// and the original "invisible" window to be listed. Clicking either the
new
/// window or any other application caused this "invisible" window to no
longer be
/// listed.
/// Getting the application that previously had focus and returning focus to
it
/// would likely resolve this.
Dale
"Joakim Karlsson" <jk*******@NOSPAMjkarlsson.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
Set the form's ShowInTaskbar property to false, and set the
FormBorderStyle property to either FixedToolWindow or SizableToolWindow.

Regards,
Joakim

Dale wrote:
I'm using the NotifyIcon component on a form within a Windows application that will normally show no interface.
NotifyIcon does add an icon as required to the notification area of the Task Bar. Unfortunately the window is showing up in the little window that is displayed when user uses Alt-Tab to switch applications.

How do I make this application not show up in the Alt-Tab window?

Thanks.

Dale

Nov 22 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Waguih Boctor | last post: by
reply views Thread by Fronky | last post: by
2 posts views Thread by David Scemama | last post: by
11 posts views Thread by dba | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.