472,779 Members | 2,681 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,779 software developers and data experts.

CryptographicException, The parameter is incorrect.

Not so long I've found really strange bug in the .NET. It seems that
Evidence that I've got from the current executing Assembly is somehow
expired (it happens suddenly after about month) and Xslt Transformation
stop working at all for the whole AppDomain until I restart it. Am I
using "this.GetType().Assembly.Evidence" incorrectly? And another
question is what if I pass Evidence that I've created using
CreateEvidenceForUrl(@"my working directory")? What is the diference
between this evidence and evidence that I've retrieved from Assembly

Here is the code snippet:

XslTransform xt = new XslTransform();
xt.Load(new XmlTextReader(stream), null,
catch(XsltCompileException ex)
throw new Exception(Utils.ExceptionsToString(ex), ex);

And here is the stacktrace:

Exception: System.Security.Cryptography.CryptographicExceptio n
Message: The parameter is incorrect.
Source: mscorlib
at System.Security.Policy.PolicyLevel.GenericResolve( Evidence
evidence, Boolean& allConst)
at System.Security.Policy.PolicyLevel.Resolve(Evidenc e evidence,
Int32 count, Char[] serializedEvidence)
at System.Security.PolicyManager.Resolve(Evidence evidence,
PermissionSet request)
at System.Security.SecurityManager.ResolvePolicy(Evid ence evidence)
at System.Xml.Xsl.Compiler.Compile(NavigatorInput input, XmlResolver
xmlResolver, Evidence evidence)
at System.Xml.Xsl.XslTransform.Compile(XPathNavigator stylesheet,
XmlResolver resolver, Evidence evidence)
at System.Xml.Xsl.XslTransform.Load(XPathNavigator stylesheet,
XmlResolver resolver, Evidence evidence)
at System.Xml.Xsl.XslTransform.Load(XmlReader stylesheet,
XmlResolver resolver, Evidence evidence)

Thanks in advance,
Jul 21 '05 #1
0 2334

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: Michelle Kinsey-Clinton | last post by:
Hello, I am writing an ASP app which is giving me some very frustrating errors. They appear intermittently, no real pattern to them, and often go away if you reload, or back up a few pages and...
by: jasonjbwalton | last post by:
Hi I am implementing a solution based upon Sitecore CMS version ..Net 1.1 on a Windows 2003 server We are experiencing an error once in a while when transforming XML with XSLT. We...
by: Nick Jones | last post by:
Hello, I've got the following problem on two machines and have had no luck tracking down a solution. I've seen two other people make similar posts this year but with no response. Has anyone got...
by: Tim Barg | last post by:
I am using a CryptoStream to encrypt and then save an xml file. However, when reading it back in, I am getting a CryptographicException. I am hitting this because I have some large xml files ( >...
by: Tod Johnson | last post by:
Not so long I've found really strange bug in the .NET. It seems that Evidence that I've got from the current executing Assembly is somehow expired (it happens suddenly after about month) and Xslt...
by: Brad | last post by:
Our .Net 2 web apps recently started getting CryptographicExceptions from WebResource.axd, and these almost always seem to be when the client is a web crawler...most notably googlebot (but a few...
by: Dennis | last post by:
Hi I'm trying to alter my stored procedure to take a parameter for the Database Name, but as usual the syntax is killing me. Thanks for any help Dennis ...
by: andrew | last post by:
Hi, I have a web service application written in C# .NET 1.1 using MD5CryptoServiceProvider.ComputeHash(Byte) The problem is that after a while(web service processes requests) the call throws...
by: Porty | last post by:
Hi all, I admittedly don't know the first thing about .NET. I have a new client who has been having problems on her website and asked me to look into it (she has lost contact with the programmer...
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 2 August 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
by: erikbower65 | last post by:
Using CodiumAI's pr-agent is simple and powerful. Follow these steps: 1. Install CodiumAI CLI: Ensure Node.js is installed, then run 'npm install -g codiumai' in the terminal. 2. Connect to...
by: erikbower65 | last post by:
Here's a concise step-by-step guide for manually installing IntelliJ IDEA: 1. Download: Visit the official JetBrains website and download the IntelliJ IDEA Community or Ultimate edition based on...
by: kcodez | last post by:
As a H5 game development enthusiast, I recently wrote a very interesting little game - Toy Claw ((http://claw.kjeek.com/))。Here I will summarize and share the development experience here, and hope it...
by: DJRhino1175 | last post by:
When I run this code I get an error, its Run-time error# 424 Object required...This is my first attempt at doing something like this. I test the entire code and it worked until I added this - If...
by: DJRhino | last post by:
Private Sub CboDrawingID_BeforeUpdate(Cancel As Integer) If = 310029923 Or 310030138 Or 310030152 Or 310030346 Or 310030348 Or _ 310030356 Or 310030359 Or 310030362 Or...
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
by: lllomh | last post by:
How does React native implement an English player?
by: DJRhino | last post by:
Was curious if anyone else was having this same issue or not.... I was just Up/Down graded to windows 11 and now my access combo boxes are not acting right. With win 10 I could start typing...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.