By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,687 Members | 2,065 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,687 IT Pros & Developers. It's quick & easy.

Online Resources in .net IDE

P: n/a
In VS .net 2003 There is a online resources tab on the start page.

When I click the links such as headlines, downloads or xml services I get a
message stating that this feature requires a connection to the Internet. But
I have a always on connection to the Internet. The other links like what's
new and search online work fine.

Thanks

Paul
Jul 21 '05 #1
Share this Question
Share on Google+
21 Replies


P: n/a
Hi Paul,

First of all, I would like to confirm my understanding of your issue. From
your description, I understand that you cannot open some pages of the
resources tab. If there is any misunderstanding, please feel free to let me
know.

Based on my experience, since you already have Internet connection on your
machine, this might be caused by the status of Internet Explorer. I can
reproduce this issue by switch my IE to "work offline".

So please start your IE and check in File menu, to see if Work Offline has
been checked. If so, uncheck it. Then everything works fine. The What's New
page works fine because you have opened that page before and there is cache
on your local machine.

HTH.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #2

P: n/a
You are correct in your understanding of the issue.

But The "work offline" switch in IE is not checked.

Do you have any other ideas on this issue.

Thanks
Paul

"Kevin Yu [MSFT]" wrote:
Hi Paul,

First of all, I would like to confirm my understanding of your issue. From
your description, I understand that you cannot open some pages of the
resources tab. If there is any misunderstanding, please feel free to let me
know.

Based on my experience, since you already have Internet connection on your
machine, this might be caused by the status of Internet Explorer. I can
reproduce this issue by switch my IE to "work offline".

So please start your IE and check in File menu, to see if Work Offline has
been checked. If so, uncheck it. Then everything works fine. The What's New
page works fine because you have opened that page before and there is cache
on your local machine.

HTH.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #3

P: n/a
Hi Paul,

Could you access the URLs such as http://msdn.microsoft.com successfully
using your IE? Is there any proxy settings?

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #4

P: n/a
Yes, I csn access all sites from IE. I can also access all sites from within
VS.NET using the web toolbar. No Proxy Setting But I use a linksys firewall
router as my connection to th internet. But that should not matter because I
have no problem accessing the Internet as mentined above.

Paul

"Kevin Yu [MSFT]" wrote:
Hi Paul,

Could you access the URLs such as http://msdn.microsoft.com successfully
using your IE? Is there any proxy settings?

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #5

P: n/a
Hi Paul,

We have reviewed this issue and are currently researching on it. We will
update you ASAP. Thanks for your patience!

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #6

P: n/a
Hi Paul,

It might also have something to do with the IE language setting. These
problems can be fixed as follows:

1. In IE, go to Tools -> Internet Options -> Languages. If English is not
listed, add it to the list.
2. Make sure that the filter is set to (none) in the "What's New" page. If
not set to (none), change it to (none) and refresh page.

Try these, and if they don't fix the problem, please reply to this post.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #7

P: n/a
Did not fix.

The language was set to english already.
I set the filter in What;s New to (no filter)
Not sure how to refresh that page. If you show the web tool bar in .net IDE
the refresh button is grayed out. But changing the filter displays new info
so it seems to be refreshing ok.

More info.

Of the links under the online resource tab the following display the message

'This feature requires that you have connected to the internet previously or
are currently online'

Online community
headlines
downloads
XML web services
web hosting

The other links:

Get started
what's new
Search online

All work fine and I can use them to search the microsoft site.





"Kevin Yu [MSFT]" wrote:
Hi Paul,

It might also have something to do with the IE language setting. These
problems can be fixed as follows:

1. In IE, go to Tools -> Internet Options -> Languages. If English is not
listed, add it to the list.
2. Make sure that the filter is set to (none) in the "What's New" page. If
not set to (none), change it to (none) and refresh page.

Try these, and if they don't fix the problem, please reply to this post.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #8

P: n/a
Hi Paul,

This can also be caused by the locale setting. Could you please check your
locale setting on your machine with the following steps?

1. Open Control Panel.
2. Open Regional and Language Options dialog box.

This display the locale setting for your windows. Could you please set it
to English(US)?

If that still doesn't work, could you please let me know the locale
setting, Windows and VS.NET language version?

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #9

P: n/a
Everything on my computer, windows & .net IDE is set up for United
States(English)

Any other ideas.

Paul
"Kevin Yu [MSFT]" wrote:
Hi Paul,

This can also be caused by the locale setting. Could you please check your
locale setting on your machine with the following steps?

1. Open Control Panel.
2. Open Regional and Language Options dialog box.

This display the locale setting for your windows. Could you please set it
to English(US)?

If that still doesn't work, could you please let me know the locale
setting, Windows and VS.NET language version?

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #10

P: n/a
Hi Paul,

We have reviewed this issue and are currently researching on it. We will
update you ASAP. Thanks for your patience!

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #11

P: n/a
Hi Paul,

This problem can also occur in some corporate environments where users must
authenticate against a proxy server in order to access the Internet. To
resolve the issue:

1. Start the Visual Studio .NET 2003 IDE
2. On the View menu, click Web Browser --> Home
3. A prompt for authentication should appear. Provide a valid username and
password.

Once authenticated the Online Resources tab should function normally.

If that still doesn't work, you can also reregister msxml3.dll using
regsvr32.exe, e.g.:

regsvr32 msxml3.dll

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #12

P: n/a
No that's not it.

I already said I am not behind a proxy server. I connect to the Internet
through the local cable company.

I can access the Internet just fine through the .net IDE.

The procedure you stated below:

1. Start the Visual Studio .NET 2003 IDE
2. On the View menu, click Web Browser --> Home
3. A prompt for authentication should appear. Provide a valid username and
password.
Takes me direclty to msdn.microsoft.com through a window in the IDE, there
is no prompt for authentication because I don't need to authienticate to
browse the Internet.

Let me repeat that I can browse the web from within the Visual Studio .NET
Development Environment. and certain items on the online resources tab do
access the Internet. It is only the specific links I mentioned that do not
work.

It sounds like you are under the impresion that I can't access the Internet
at all through the IDE. But that is not the case,, It's only those specific
links that don't work.

Thanks

Paul

"Kevin Yu [MSFT]" wrote:
Hi Paul,

This problem can also occur in some corporate environments where users must
authenticate against a proxy server in order to access the Internet. To
resolve the issue:

1. Start the Visual Studio .NET 2003 IDE
2. On the View menu, click Web Browser --> Home
3. A prompt for authentication should appear. Provide a valid username and
password.

Once authenticated the Online Resources tab should function normally.

If that still doesn't work, you can also reregister msxml3.dll using
regsvr32.exe, e.g.:

regsvr32 msxml3.dll

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #13

P: n/a
Also, can you give me the url of the links that don't work for me. Like the
download link, I will browse them directly through the IDE to see if that
works.

"Pa******@newsgroup.nospam" wrote:
No that's not it.

I already said I am not behind a proxy server. I connect to the Internet
through the local cable company.

I can access the Internet just fine through the .net IDE.

The procedure you stated below:

1. Start the Visual Studio .NET 2003 IDE
2. On the View menu, click Web Browser --> Home
3. A prompt for authentication should appear. Provide a valid username and
password.


Takes me direclty to msdn.microsoft.com through a window in the IDE, there
is no prompt for authentication because I don't need to authienticate to
browse the Internet.

Let me repeat that I can browse the web from within the Visual Studio .NET
Development Environment. and certain items on the online resources tab do
access the Internet. It is only the specific links I mentioned that do not
work.

It sounds like you are under the impresion that I can't access the Internet
at all through the IDE. But that is not the case,, It's only those specific
links that don't work.

Thanks

Paul

"Kevin Yu [MSFT]" wrote:
Hi Paul,

This problem can also occur in some corporate environments where users must
authenticate against a proxy server in order to access the Internet. To
resolve the issue:

1. Start the Visual Studio .NET 2003 IDE
2. On the View menu, click Web Browser --> Home
3. A prompt for authentication should appear. Provide a valid username and
password.

Once authenticated the Online Resources tab should function normally.

If that still doesn't work, you can also reregister msxml3.dll using
regsvr32.exe, e.g.:

regsvr32 msxml3.dll

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #14

P: n/a
Hi Paul,

Since this can be caused by many reasons, we have to try more resolutions
that I can find.

This problem can be caused by security settings that are locking down the
page load. To resolve, do the following:

1. Close VS.NET and open Internet Explorer
2. Go to TOOLS, INTERNET OPTIONS and click on the Security tab
3. Set the security settings to DEFAULT for all zones
4. Re-launch VS.NET and you should not see this problem any longer

Also, it might have something to do with the user currently logged on to
the system. Please also try the following:

1) Created a new user account as Local Administrator.
2) Logged of as current user.
3) Logged in as new user.
4) Everything is working normal.

Have you tried reregistering msxml3.dll using regsvr32.exe?

I'm afraid the pages in Online Resources cannot be accessed directly using
a URL. But all the information in Online Resources you need to find can be
get from the following link:

http://msdn.microsoft.com/vstudio/

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #15

P: n/a
Hi Paul,

Just have another idea if you have any firewall software installed?

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #16

P: n/a
You Got it.

It's the user account. I have been logging in with a domain account. I
created a new domain account in active directory on the the name server
machine, used that account to log into my machine and the online resources
tab of the .net IDE works.

So something is wrong with the user account I've been using. I noticed that
when I look at the user profile setting of the acccount that does not work,
it's 'copy to' and 'delete' buttons are greyed out.

After creating the new account, I manually copied the folders from
C:\document settings\'old user Profile' to the new account name C:\document
settings\'New user Profile' . When I log in with the new account name the
online resources tab of the .net IDE no longer works.

I guess I could just delete my old account name and start over with a new
one. But I have spent alot of time setting up those account name setting. Do
you have any idea what file is causing this, then I can just copy over
everything but the problem file.

Thanks for all your hard work and sticling with me on this issue. It has
been greatly appreciated.

Paul


"Kevin Yu

[MSFT]" wrote:
Hi Paul,

Since this can be caused by many reasons, we have to try more resolutions
that I can find.

This problem can be caused by security settings that are locking down the
page load. To resolve, do the following:

1. Close VS.NET and open Internet Explorer
2. Go to TOOLS, INTERNET OPTIONS and click on the Security tab
3. Set the security settings to DEFAULT for all zones
4. Re-launch VS.NET and you should not see this problem any longer

Also, it might have something to do with the user currently logged on to
the system. Please also try the following:

1) Created a new user account as Local Administrator.
2) Logged of as current user.
3) Logged in as new user.
4) Everything is working normal.

Have you tried reregistering msxml3.dll using regsvr32.exe?

I'm afraid the pages in Online Resources cannot be accessed directly using
a URL. But all the information in Online Resources you need to find can be
get from the following link:

http://msdn.microsoft.com/vstudio/

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #17

P: n/a
You're welcome, Paul.

It seems that there is something wrong with the user's profile, so we
cannot copy all the files to the new user. I assume that there might be
something wrong with the IE setting part. To the profile issue, I
suggestion that you can try to ask it in the windows newsgroup, as I'm not
quite familiar with it. HTH.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #18

P: n/a
I was having the same issue and I followed this thread and solved the problem
only on the step for creating a new account, but then I found another way to
make this work on the original account without having to set up another
account. Go into Internet options and on the General tab in the "Temporary
Internet files" section, click the "Delete Files..." button and check the
"Delete all offline content" checkbox (not sure if this is a must or not).
After that, I was able to open Visual Studio and view the "Online Community"
section of the "Online Resources" tab.

"Kevin Yu [MSFT]" wrote:
You're welcome, Paul.

It seems that there is something wrong with the user's profile, so we
cannot copy all the files to the new user. I assume that there might be
something wrong with the IE setting part. To the profile issue, I
suggestion that you can try to ask it in the windows newsgroup, as I'm not
quite familiar with it. HTH.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #19

P: n/a
Thank you Paul and John for sharing your experience with all the people
here. If you have any questions, please feel free to post them in the
community.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #20

P: n/a
John_s

I tried your solution with the temp files and it it also works.

Thanks

"John_s" wrote:
I was having the same issue and I followed this thread and solved the problem
only on the step for creating a new account, but then I found another way to
make this work on the original account without having to set up another
account. Go into Internet options and on the General tab in the "Temporary
Internet files" section, click the "Delete Files..." button and check the
"Delete all offline content" checkbox (not sure if this is a must or not).
After that, I was able to open Visual Studio and view the "Online Community"
section of the "Online Resources" tab.

"Kevin Yu [MSFT]" wrote:
You're welcome, Paul.

It seems that there is something wrong with the user's profile, so we
cannot copy all the files to the new user. I assume that there might be
something wrong with the IE setting part. To the profile issue, I
suggestion that you can try to ask it in the windows newsgroup, as I'm not
quite familiar with it. HTH.

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Jul 21 '05 #21

P: n/a
I have the same problem. .Net 2003 works at work, but not at home.
I have not yet tried the 'delete files' idea, but the language settings do
not help at all.
What is really crazy is that with the original VS.Net, the 'Web Hosting' etc
panes worked whilst the .Net 2003 did not.
Jul 21 '05 #22

This discussion thread is closed

Replies have been disabled for this discussion.