By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,681 Members | 1,864 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,681 IT Pros & Developers. It's quick & easy.

Unalbe to start debugging on the web server....

P: n/a
Everytime I run an aspx page via the run command from Visual Studio 2003 I
get the following error.

Error while trying to run project: Unable to start debugging on the web
server. Could not start ASP.NET or ATL server debugging.

Verify that ASP.NET or ATL Server is correctly installed on the server.

I have reinstalled Framework and run repair on Visual Studio 2003.

The only thing that I can think of is that I have VS2003 installed on drive
letter D instead of C. Maybe the debugger registry is still pointing to C,
but I don't know where the reg settings my be.

Any thoughts?
--
Jim Hansen

Jul 21 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a

I think It can be fixed by running asp_regiis.exe for the correct version in
window\microsoft.net directory

"Jim Hansen" wrote:
Everytime I run an aspx page via the run command from Visual Studio 2003 I
get the following error.

Error while trying to run project: Unable to start debugging on the web
server. Could not start ASP.NET or ATL server debugging.

Verify that ASP.NET or ATL Server is correctly installed on the server.

I have reinstalled Framework and run repair on Visual Studio 2003.

The only thing that I can think of is that I have VS2003 installed on drive
letter D instead of C. Maybe the debugger registry is still pointing to C,
but I don't know where the reg settings my be.

Any thoughts?
--
Jim Hansen

Jul 21 '05 #2

P: n/a
Sorry, but that did not help.

I can build the solution and display the pages in a Browser just find, but
not with the debugger.

Thanks,

Jim

"Jun Lang" wrote:

I think It can be fixed by running asp_regiis.exe for the correct version in
window\microsoft.net directory

"Jim Hansen" wrote:
Everytime I run an aspx page via the run command from Visual Studio 2003 I
get the following error.

Error while trying to run project: Unable to start debugging on the web
server. Could not start ASP.NET or ATL server debugging.

Verify that ASP.NET or ATL Server is correctly installed on the server.

I have reinstalled Framework and run repair on Visual Studio 2003.

The only thing that I can think of is that I have VS2003 installed on drive
letter D instead of C. Maybe the debugger registry is still pointing to C,
but I don't know where the reg settings my be.

Any thoughts?
--
Jim Hansen

Jul 21 '05 #3

P: n/a
Couple thoughts...

Building in Debug or Release Mode?

web.config have debug=true?

Greg

"Jim Hansen" <Ji*******@discussions.microsoft.com> wrote in message
news:F9**********************************@microsof t.com...
Sorry, but that did not help.

I can build the solution and display the pages in a Browser just find, but
not with the debugger.

Thanks,

Jim

"Jun Lang" wrote:

I think It can be fixed by running asp_regiis.exe for the correct version
in
window\microsoft.net directory

"Jim Hansen" wrote:
> Everytime I run an aspx page via the run command from Visual Studio
> 2003 I
> get the following error.
>
> Error while trying to run project: Unable to start debugging on the web
> server. Could not start ASP.NET or ATL server debugging.
>
> Verify that ASP.NET or ATL Server is correctly installed on the server.
>
> I have reinstalled Framework and run repair on Visual Studio 2003.
>
> The only thing that I can think of is that I have VS2003 installed on
> drive
> letter D instead of C. Maybe the debugger registry is still pointing
> to C,
> but I don't know where the reg settings my be.
>
> Any thoughts?
>
>
> --
> Jim Hansen
>

Jul 21 '05 #4

P: n/a
Jim Hansen wrote:
Everytime I run an aspx page via the run command from Visual Studio 2003 I
get the following error.

Error while trying to run project: Unable to start debugging on the web
server. Could not start ASP.NET or ATL server debugging.
Make sure that in IIS that you have set up the project as an Application.

Go into the IIS manager.

Find your project, and right click on it to bring up properties.

It should be set to run as an application and the application should be the
same name as the project.

Also, set it to use Medium Protection ( if that doesn't work, use Low
Protection ).

Verify that ASP.NET or ATL Server is correctly installed on the server.

I have reinstalled Framework and run repair on Visual Studio 2003.

The only thing that I can think of is that I have VS2003 installed on
drive
letter D instead of C. Maybe the debugger registry is still pointing to
C, but I don't know where the reg settings my be.

Any thoughts?


Jul 21 '05 #5

P: n/a

Also, try running at the command window:

iisreset.exe


Jim Hansen wrote:
Everytime I run an aspx page via the run command from Visual Studio 2003 I
get the following error.

Error while trying to run project: Unable to start debugging on the web
server. Could not start ASP.NET or ATL server debugging.

Verify that ASP.NET or ATL Server is correctly installed on the server.

I have reinstalled Framework and run repair on Visual Studio 2003.

The only thing that I can think of is that I have VS2003 installed on
drive
letter D instead of C. Maybe the debugger registry is still pointing to
C, but I don't know where the reg settings my be.

Any thoughts?


Jul 21 '05 #6

P: n/a
It was an application. It was in in Medium and I tried in low as well. No
luck. Thanks for the suggestions.
"Moonraker" wrote:
Jim Hansen wrote:
Everytime I run an aspx page via the run command from Visual Studio 2003 I
get the following error.

Error while trying to run project: Unable to start debugging on the web
server. Could not start ASP.NET or ATL server debugging.


Make sure that in IIS that you have set up the project as an Application.

Go into the IIS manager.

Find your project, and right click on it to bring up properties.

It should be set to run as an application and the application should be the
same name as the project.

Also, set it to use Medium Protection ( if that doesn't work, use Low
Protection ).

Verify that ASP.NET or ATL Server is correctly installed on the server.

I have reinstalled Framework and run repair on Visual Studio 2003.

The only thing that I can think of is that I have VS2003 installed on
drive
letter D instead of C. Maybe the debugger registry is still pointing to
C, but I don't know where the reg settings my be.

Any thoughts?


Jul 21 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.