By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,544 Members | 2,065 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,544 IT Pros & Developers. It's quick & easy.

SQL Editor

P: n/a
When Editing .SQL files using .Net, when I execute the SQL or Check the SQL,
it reformats the SQL differently than we normally do it. I would like to
know how I can disable this automatic formatting. Alternatively, I would
like a format option that creates a carriage return after each field in sub
selects. I work primarily with Oracle, and this is our company standard. I
like the tabbing in many cases, but I am now on the data warehouse team, and
I need to conform to their standard. I would prefer to use .Net development
Environment to Toad if I can. Any suggestions?

Thanks,

Geoff

Jul 21 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
gswitz wrote:
When Editing .SQL files using .Net, when I execute the SQL or Check
the SQL, it reformats the SQL differently than we normally do it. I
would like to know how I can disable this automatic formatting.
Alternatively, I would like a format option that creates a carriage
return after each field in sub selects. I work primarily with
Oracle, and this is our company standard. I like the tabbing in many
cases, but I am now on the data warehouse team, and I need to conform
to their standard. I would prefer to use .Net development
Environment to Toad if I can. Any suggestions?


Try Tools / Options / Text Editor and look under SQL / T-SQL etc and see if
you find anything that stops it.
Jul 21 '05 #2

P: n/a
Leon,

Thanks for answering. I've checked all the options and cannot find one that
helps. I have turned of indenting on all SQL Type files. This has not helped
me. I would like the editor to recognize the file as PL/SQL, but I have had
no success with this. It continues to handle it as if it were T-SQL.

I would prefer to keep the standard indenting but have a carriage return
after every field listed before the FROM clause.

Additionally, I would like to have the editor recognize the file as PL/SQL.

And/Or I would like to be able disable the automatic formatting of the text.

When I posted my first message, I had already exhausted myself trying to
find the properties that might solve my problem under Tools>Options>Text
Editor>SQL Types.

Thanks,

Geoff
Jul 21 '05 #3

P: n/a
gswitz wrote:
Additionally, I would like to have the editor recognize the file as
PL/SQL.


Hmm, perhaps try a different file extension? I'm afraid I don't know what
the file extension is for PL/SQL. You could hunt it down in the registry or
have a search on the web.
Jul 21 '05 #4

P: n/a
I have not been able to guess the file extension that would cause VS.Net to
show the file as PL/SQL.

"Leon Mayne [MVP]" wrote:
gswitz wrote:
Additionally, I would like to have the editor recognize the file as
PL/SQL.


Hmm, perhaps try a different file extension? I'm afraid I don't know what
the file extension is for PL/SQL. You could hunt it down in the registry or
have a search on the web.

Jul 21 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.