By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,647 Members | 1,832 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,647 IT Pros & Developers. It's quick & easy.

asp.net adding a web refernce

P: n/a
Hi
I've been trying to add a web refernece to a asp.net application project,
from a web service within the same solution. The site is hosted on my local
host & in a virtual directory.
when I go through the process of adding the web refernce to the application
layer I get an error message stating that my LAN services are configured for
web URL discovery. I then searched through the MSDN help to discover that
this can be configured through the tools/options/internet
properties/connections TAB/LANsettings & then entering the domain name or IP
address of the local machine & associated port number.
I then did this but it still didn't work, May I need to cionfigur something
in IIS before the project is even begun, It shouldn't be this hard to add a
webreference
Thanks
Dave
Jul 21 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Dave

I try to understand your message
I've been trying to add a web refernece to a asp.net application project,
from a web service within the same solution.
So you have created a webservice
Then an aspnet application
Added a webreference in the last and have set a reference to that webservice
Than you have instanced that webservicereference in your project and than
used that in a method to call the webservice
The site is hosted on my local host & in a virtual directory.
So this a development and testing situation?
when I go through the process of adding the web refernce to the
application
layer I get an error message stating that my LAN services are configured
for
web URL discovery. I then searched through the MSDN help to discover that
this can be configured through the tools/options/internet
properties/connections TAB/LANsettings & then entering the domain name or
IP
address of the local machine & associated port number.
I then did this but it still didn't work, May I need to cionfigur
something
in IIS before the project is even begun, It shouldn't be this hard to add
a
webreference


All this above should normally not happen so first my first questions.

I hope it helps anyway in advance

Merry Christmas

Cor
Jul 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.