By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,781 Members | 1,399 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,781 IT Pros & Developers. It's quick & easy.

Application Updater Block - Won't start new version

P: n/a
I am attempting to use the Application Updater block so that I can have my
..net windows forms application automatically update when a new version is
available.

I have deployed version 1.0.0.0 to the user machine.
I have created version 1.0.0.1, and put this on the update server

I am trying to build a self updating application (started using the appstart
application as in the samples given).

I have managed to get it working to the point where it picks up the new
version and downloads it. It then asks the user if they wish to start the new
version, and if you say yes, it exits out of the application and restarts -
but it restarts the same (old) version again.

I expected that it would change the appstart.exe.config file to point to the
new version, but this doesn't get changed!!! And yet somewhere (I can't work
out where) it registers that the new version has been downloaded, as it
doesn't try to download it again.

Can anyone help me out with this? I have been looking at this for 2 days
now, and it is starting to drive me insane!!!!

Thanks in advance.
Jul 21 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.