By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,658 Members | 1,519 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,658 IT Pros & Developers. It's quick & easy.

ASP Button will not fire on localhost

P: n/a
I have a page with a submit button (<asp.button/>). When run this page in
production the button fires and submits the form, however, when I run the
page on my local machine, it won't submit!

Any ideas?
Jul 21 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Hi,

Make sure that your <asp:button> tag still has runat="server" in it. Also
make sure in the code behind that there is still a handler on the Click
function for the button:

Private Sub btnRun_Click(ByVal sender As Object, ByVal e As
System.EventArgs) Handles btnRun.Click

The "Handles btnRun.Click" at the end of the line above is necessary for the
event to fire. Good luck! Ken.

--
Ken Dopierala Jr.
For great ASP.Net web hosting try:
http://www.webhost4life.com/default.asp?refid=Spinlight

"pkp303" <da**@dsdesignsinc.com> wrote in message
news:OA*************@TK2MSFTNGP09.phx.gbl...
I have a page with a submit button (<asp.button/>). When run this page in
production the button fires and submits the form, however, when I run the
page on my local machine, it won't submit!

Any ideas?

Jul 21 '05 #2

P: n/a
If you installed SP1 for .Net 1.1, you may be interested by this:
http://weblogs.asp.net/pwilson/archi...16/230591.aspx

--

HTH

Éric Moreau, MCSD, Visual Developer - Visual Basic MVP
Conseiller Principal / Senior Consultant
Concept S2i inc.(www.s2i.com)
"pkp303" <da**@dsdesignsinc.com> wrote in message
news:OA*************@TK2MSFTNGP09.phx.gbl...
I have a page with a submit button (<asp.button/>). When run this page in
production the button fires and submits the form, however, when I run the
page on my local machine, it won't submit!

Any ideas?

Jul 21 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.