By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,179 Members | 2,192 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,179 IT Pros & Developers. It's quick & easy.

restated: VS Develper (non Admin) missing IIS MMC Management

P: n/a
Hi,

I'm reposting this question as no resultion as yet. Couple of updates,
so re-read if you have seen before.

I am trying to set up VS Developer users with non-administrator rights
debug ASP (3) in VB.Net, and of course manage IIS MMC. This has
succeeeded on 3 machines, including my own - but since then it hasnt
been able to work, with seemingly exactly the same install & debug
setup. All machines are Windows 2000 Pro with IIS 5.0.

My main 2 problems are:
1. the user cannot see the web site properties in MMC. Note: I do not
have the operators tab as it is 2000 pro.
2. I get all of the errors from this kb article
http://support.microsoft.com/default...b;EN-US;320451
(but tried the resolution and it's not it)
Note: I've copied and paste the errors below for your convenience.

I have tried re-installing IIS, VB.Net & ASP.Net 1.1 (in that order),
doing the usual permission stuff (adding the user to debugger & vs
developer group, file permissions on inetpub and temp asp.net files,
etc etc). Frontpage is installed (this shouldnt matter as it is a
local box not remote debugging). And I've tried aspnet_regiis.exe
reg'ing aspnet_isapi.dll). I've tried everything!

This is an absolute pain as we are all still developing in ASP 3 and
moving forward has taken 18 months sofar and got nowhere - any ideas
would be great!

Thanks,
Andrew Clancy

Errors when creating a VB.Net Web Application project (locally)

Microsoft Development Environment
The Web was created successfully, but an error occurred when trying to
configure the application root for this Web. Web projects may not
operate correctly without an application root. The returned error was:
Active Directory Services cannot find the web server. A possible cause
for this is an incompatibility between versions of Internet
Information Server (IIS) on the client and the server. The usual cause
for this error is creating Web projects on a Windows 2000 or newer
server from a Windows NT 4.0 client. You can manually configure the
application root using the Internet Services Manager.
-or-

Microsoft Development Environment
Unable to set the permissions on the 'bin' folder to restrict browse
access. Active Directory Services cannot find the web server. A
possible cause for this is an incompatibility between versions of
Internet Information Server (IIS) on the client and the server. The
usual cause for this error is creating Web projects on a Windows 2000
or newer server from a Windows NT 4.0 client. You can manually
restrict browse access to this folder using the Internet Services
Manager.
Jul 21 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
trying again, more newsgroups this time. Does anyone have any ideas how to
allow IIS management for non-admin users in Window 2000 Pro, and deal with
the errors in .Net project creation outlined below??

"Andrew Clancy" <us****@achren.org> wrote in message
news:dd**************************@posting.google.c om...
Hi,

I'm reposting this question as no resultion as yet. Couple of updates,
so re-read if you have seen before.

I am trying to set up VS Developer users with non-administrator rights
debug ASP (3) in VB.Net, and of course manage IIS MMC. This has
succeeeded on 3 machines, including my own - but since then it hasnt
been able to work, with seemingly exactly the same install & debug
setup. All machines are Windows 2000 Pro with IIS 5.0.

My main 2 problems are:
1. the user cannot see the web site properties in MMC. Note: I do not
have the operators tab as it is 2000 pro.
2. I get all of the errors from this kb article
http://support.microsoft.com/default...b;EN-US;320451
(but tried the resolution and it's not it)
Note: I've copied and paste the errors below for your convenience.

I have tried re-installing IIS, VB.Net & ASP.Net 1.1 (in that order),
doing the usual permission stuff (adding the user to debugger & vs
developer group, file permissions on inetpub and temp asp.net files,
etc etc). Frontpage is installed (this shouldnt matter as it is a
local box not remote debugging). And I've tried aspnet_regiis.exe
reg'ing aspnet_isapi.dll). I've tried everything!

This is an absolute pain as we are all still developing in ASP 3 and
moving forward has taken 18 months sofar and got nowhere - any ideas
would be great!

Thanks,
Andrew Clancy

Errors when creating a VB.Net Web Application project (locally)

Microsoft Development Environment
The Web was created successfully, but an error occurred when trying to
configure the application root for this Web. Web projects may not
operate correctly without an application root. The returned error was:
Active Directory Services cannot find the web server. A possible cause
for this is an incompatibility between versions of Internet
Information Server (IIS) on the client and the server. The usual cause
for this error is creating Web projects on a Windows 2000 or newer
server from a Windows NT 4.0 client. You can manually configure the
application root using the Internet Services Manager.
-or-

Microsoft Development Environment
Unable to set the permissions on the 'bin' folder to restrict browse
access. Active Directory Services cannot find the web server. A
possible cause for this is an incompatibility between versions of
Internet Information Server (IIS) on the client and the server. The
usual cause for this error is creating Web projects on a Windows 2000
or newer server from a Windows NT 4.0 client. You can manually
restrict browse access to this folder using the Internet Services
Manager.

Jul 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.